Bug 280882 - Notifications / Bell in Non-Visible Session doesn't work
Summary: Notifications / Bell in Non-Visible Session doesn't work
Status: RESOLVED DUPLICATE of bug 174505
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 2.7
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-27 12:46 UTC by Jérôme Poisson
Modified: 2011-08-27 13:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jérôme Poisson 2011-08-27 12:46:33 UTC
Version:           2.7 (using KDE 4.7.0) 
OS:                Linux

Bell notifications are really necessary e.g. to be notified when somebody write to you in a chat software.

There are 2 options for that in Konsole 2.7:
- Bell in Visible Session
- Bell in Non-Visible Session

To try them, I just do a echo -e "\a"

Bell in Visible session works, but all the time, even when the session is not visible, this can be annoying when you are chatting (you can have a bell each time somebody is writing to you).

Bell in Non-Visible Session doesn't work at all, neither "Play a sound", "Show a message in a popup" or whatever). To try it, I use a sleep 5; echo -e "\a" then I change konsole tab, or go to an other app during the delay.

I'm using Kubuntu 11.04.

There are a few (old) bugs similar to this one, but it seems that the notifications menu where not present at the time, so I added this entry:

- https://bugs.kde.org/show_bug.cgi?id=165193 
- https://bugs.kde.org/show_bug.cgi?id=124241
- https://bugs.kde.org/show_bug.cgi?id=177861

I would be nice to fix this.

thanks

Reproducible: Always

Steps to Reproduce:
- Tick one of "Bell in Non-Visible Session" notification
- use this: sleep 10; echo -e "\a"
- during the 10s delay, change tab or windows


Actual Results:  
Nothing happen

Expected Results:  
the notification should occur
Comment 1 Jekyll Wu 2011-08-27 13:30:49 UTC

*** This bug has been marked as a duplicate of bug 174505 ***