Bug 280288 - "Guess from filename" does not remember settings
Summary: "Guess from filename" does not remember settings
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Metadata Editing and Reading (show other bugs)
Version: 2.4-GIT
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: 2.5
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-17 17:45 UTC by S. Burmeister
Modified: 2011-09-26 11:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 2.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2011-08-17 17:45:33 UTC
Version:           2.4-GIT (using KDE 4.7.0) 
OS:                Linux

If I spend some time on putting together the %tags% to guess the correct id3 tags for a file it is quite disappointing that when I want to do the same for another file I have to start all over again.

Reproducible: Didn't try

Steps to Reproduce:
Use "Guess form filename"
click ok
use "guess from filename" again

Actual Results:  
empty %tags%

Expected Results:  
Remember at least the last settings if not a list of the last x used.

OS: Linux (x86_64) release 2.6.37.6-0.7-desktop
Compiler: gcc
Comment 1 Myriam Schweingruber 2011-08-17 21:19:02 UTC

*** This bug has been marked as a duplicate of bug 264302 ***
Comment 2 Sergey Ivanov 2011-08-20 17:10:46 UTC
Git commit 0d78ff0561ce2717789f298d716b971b2c87a36c by Sergey Ivanov.
Committed on 20/08/2011 at 19:09.
Pushed by ivanov into branch 'master'.

Fixed several bugs in TagGuesser. Now It can store presets (as OrganizeCollection do), correctly save settings on close and correctly guesses tags in case of using full file path.
BUG: 280288
BUG: 264302
Particaly 264632
FIXED-IN: 2.4.4

M  +5    -93   src/dialogs/OrganizeCollectionDialogBase.ui
M  +4    -31   src/dialogs/TagDialog.cpp
M  +3    -0    ChangeLog
M  +7    -2    shared/TagsFromFileNameGuesser.cpp
M  +12   -0    src/dialogs/FilenameLayoutDialog.h
M  +2    -1    src/dialogs/TagGuesser.cpp
M  +0    -8    src/dialogs/OrganizeCollectionDialog.h
M  +93   -5    src/dialogs/FilenameLayoutDialog.ui
M  +336  -231  src/dialogs/FilenameLayoutDialog.cpp
M  +2    -92   src/dialogs/OrganizeCollectionDialog.cpp

http://commits.kde.org/amarok/0d78ff0561ce2717789f298d716b971b2c87a36c