Bug 264302 - Guess Tags from file name does not save results into Track Details Dialog
Summary: Guess Tags from file name does not save results into Track Details Dialog
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Metadata Editing and Reading (show other bugs)
Version: 2.4-GIT
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-25 23:54 UTC by Sebastian Körner (Mailings)
Modified: 2011-08-27 21:53 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Körner (Mailings) 2011-01-25 23:54:49 UTC
Version:           2.4-GIT (using KDE 4.4.5) 
OS:                Linux

Using the Guess Tags from filename dialog does not change the tags in the Track Details dialog - even if Guess Tags showed valid data in "Result Preview" and was ended with OK.


Reproducible: Always

Steps to Reproduce:
Right click a mp3 music file from the playlist
Say Edit Track Details
Choose Guess Tags from filename
Click a reasonable layout
choose OK when done

Actual Results:  
The Tags in the Track Details window remain the same.

Expected Results:  
The tags in the Track Details window should be updated by the ones seen in Results Preview (Guess Tags From Filename)

OS: Linux (x86_64) release 2.6.34.7-0.7-default
Compiler: gcc
Comment 1 Myriam Schweingruber 2011-01-29 10:40:59 UTC
*** Bug 264632 has been marked as a duplicate of this bug. ***
Comment 2 m35371 2011-07-05 12:16:48 UTC
I have also experienced this bug.
Amarok version 2.4.1-3 (Archlinux)

I am able to reproduce it only when "Use Full File Path" is enabled under "Guess Tags from filename" - i.e. Steps to Reproduce:

Right click a music file in the collection (tried on .wav and .mp3)
Edit Track Details > Guess Tags from filename > Use full file path (with reasonable depth) > Reasonable filename scheme > OK

As reported, even though the result preview shows the correct tags, changes are not reflected in the track details.

The feature seems to work fine (on my setup) when not using full file path.
Comment 3 Myriam Schweingruber 2011-07-06 10:06:00 UTC
You are aware that *.wav files do not have id3 tags, aren't you?
Comment 4 m35371 2011-07-06 15:23:58 UTC
Yes, I am aware of that, but I'm able to change Track Details under Amarok manually for my wav files, and Amarok remembers these changes - I haven't figured out how they are tagged.

The bug is still valid for mp3 files though.
Comment 5 m35371 2011-07-06 16:36:19 UTC
(In reply to comment #1)
> *** Bug 264632 has been marked as a duplicate of this bug. ***

I only just noticed that you have marked bug 264632 as a duplicate of this bug.

To clarify - the problem being faced in this bug is that the track details are not updated from the Guess Tag from file name feature (ie tags for a single file are not being changed). The other bug seems to be about multiple files being edited at the same time. Can these two be addressed as separate bugs?
Comment 6 Myriam Schweingruber 2011-07-07 10:08:56 UTC
Why? those are clearly related.
Comment 7 Hagai Kariti 2011-07-23 14:08:15 UTC
(In reply to comment #6)
> Why? those are clearly related.

Not really. bug 264632 reports problems in the Guess Tags from Filename *dialog*, limiting its usefulness when tagging multiple files (i.e. it works, it's just not as comfortable as it could be). This bug reports a problem the Guess Tags from Filename *functionality* (i.e. doesn't work). They should be separate bugs.
Comment 8 Myriam Schweingruber 2011-08-17 21:19:02 UTC
*** Bug 280288 has been marked as a duplicate of this bug. ***
Comment 9 Sergey Ivanov 2011-08-20 17:10:46 UTC
Git commit 0d78ff0561ce2717789f298d716b971b2c87a36c by Sergey Ivanov.
Committed on 20/08/2011 at 19:09.
Pushed by ivanov into branch 'master'.

Fixed several bugs in TagGuesser. Now It can store presets (as OrganizeCollection do), correctly save settings on close and correctly guesses tags in case of using full file path.
BUG: 280288
BUG: 264302
Particaly 264632
FIXED-IN: 2.4.4

M  +5    -93   src/dialogs/OrganizeCollectionDialogBase.ui
M  +4    -31   src/dialogs/TagDialog.cpp
M  +3    -0    ChangeLog
M  +7    -2    shared/TagsFromFileNameGuesser.cpp
M  +12   -0    src/dialogs/FilenameLayoutDialog.h
M  +2    -1    src/dialogs/TagGuesser.cpp
M  +0    -8    src/dialogs/OrganizeCollectionDialog.h
M  +93   -5    src/dialogs/FilenameLayoutDialog.ui
M  +336  -231  src/dialogs/FilenameLayoutDialog.cpp
M  +2    -92   src/dialogs/OrganizeCollectionDialog.cpp

http://commits.kde.org/amarok/0d78ff0561ce2717789f298d716b971b2c87a36c