Bug 280054 - Amarok crash when media is opened from folders.
Summary: Amarok crash when media is opened from folders.
Status: RESOLVED DUPLICATE of bug 258741
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.4.3
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: 2.5
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-14 00:17 UTC by Silverhand92
Modified: 2011-09-26 11:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Silverhand92 2011-08-14 00:17:49 UTC
Application: amarok (2.4.3)
KDE Platform Version: 4.7.00 (4.7.0) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-10-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

Audio files located @ Home/Music
User opened file folders and attempted to play file on Amarok media player.
Files appear to be intact, working correctly on alternate player, (Audacity)
Issue is not resolved by restarting application. Removed ~.kde/share/apps/amarok and restarted system. (Kubuntu 11.10.) and attempted to play another media file, with same crash results.

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0xb6442720 (LWP 1698))]

Thread 10 (Thread 0xac805b70 (LWP 1703)):
#0  0x005ba7a4 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x077cb656 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x05c10961 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x05c11270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x05c11524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0464f577 in QEventDispatcherGlib::processEvents (this=0x8bfcae0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x04621289 in QEventLoop::processEvents (this=0xac805280, flags=...) at kernel/qeventloop.cpp:149
#7  0x04621522 in QEventLoop::exec (this=0xac805280, flags=...) at kernel/qeventloop.cpp:201
#8  0x0452b2a0 in QThread::exec (this=0x8bdc368) at thread/qthread.cpp:492
#9  0x04602fdb in QInotifyFileSystemWatcherEngine::run (this=0x8bdc368) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0452dda2 in QThreadPrivate::start (arg=0x8bdc368) at thread/qthread_unix.cpp:320
#11 0x005b6e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x077bd73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 9 (Thread 0xa9f18b70 (LWP 1704)):
#0  0x005ba7a4 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x077cb656 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x05c10648 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x05c1103a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x05c11524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0464f577 in QEventDispatcherGlib::processEvents (this=0x8ef6380, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x04621289 in QEventLoop::processEvents (this=0xa9f18280, flags=...) at kernel/qeventloop.cpp:149
#7  0x04621522 in QEventLoop::exec (this=0xa9f18280, flags=...) at kernel/qeventloop.cpp:201
#8  0x0452b2a0 in QThread::exec (this=0x8f71778) at thread/qthread.cpp:492
#9  0x04602fdb in QInotifyFileSystemWatcherEngine::run (this=0x8f71778) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0452dda2 in QThreadPrivate::start (arg=0x8f71778) at thread/qthread_unix.cpp:320
#11 0x005b6e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x077bd73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 8 (Thread 0xa970fb70 (LWP 1705)):
#0  0x0058a416 in __kernel_vsyscall ()
#1  0x005bb48c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x077cb3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb71f3b57 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0x005b6e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#5  0x077bd73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 7 (Thread 0xa85ddb70 (LWP 1708)):
#0  0x0058a416 in __kernel_vsyscall ()
#1  0x005bb48c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x077cb3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x07e28817 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f3c1c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x07e28851 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f3c1c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x005b6e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x077bd73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 6 (Thread 0xa63ffb70 (LWP 1709)):
#0  0x0058a416 in __kernel_vsyscall ()
#1  0x005bb48c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x077cb3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x07c2a93e in ?? () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#4  0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#5  0x03726b5d in ?? () from /usr/lib/libgstreamer-0.10.so.0
#6  0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#7  0x03726b5d in ?? () from /usr/lib/libgstreamer-0.10.so.0
#8  0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#9  0x0834c6b5 in ?? () from /usr/lib/gstreamer-0.10/libgstflump3dec.so
#10 0x0834d7d7 in ?? () from /usr/lib/gstreamer-0.10/libgstflump3dec.so
#11 0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#12 0x053a71c2 in ?? () from /usr/lib/gstreamer-0.10/libgstaudioparsersbad.so
#13 0x053a7ee3 in ?? () from /usr/lib/gstreamer-0.10/libgstaudioparsersbad.so
#14 0x053ab0f3 in ?? () from /usr/lib/gstreamer-0.10/libgstaudioparsersbad.so
#15 0x03766bba in ?? () from /usr/lib/libgstreamer-0.10.so.0
#16 0x03767ef7 in ?? () from /usr/lib/libgstreamer-0.10.so.0
#17 0x05c3ca39 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#18 0x05c3a2df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#19 0x005b6e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#20 0x077bd73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 5 (Thread 0xa5bfeb70 (LWP 1710)):
#0  0x0058a416 in __kernel_vsyscall ()
#1  0x005bb48c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x077cb3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x0578af5e in gst_base_sink_wait_preroll () from /usr/lib/libgstbase-0.10.so.0
#4  0x0546bf8e in ?? () from /usr/lib/libgstaudio-0.10.so.0
#5  0x0578d716 in ?? () from /usr/lib/libgstbase-0.10.so.0
#6  0x05790ef9 in ?? () from /usr/lib/libgstbase-0.10.so.0
#7  0x05791382 in ?? () from /usr/lib/libgstbase-0.10.so.0
#8  0x0579185a in ?? () from /usr/lib/libgstbase-0.10.so.0
#9  0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#10 0x057a178d in ?? () from /usr/lib/libgstbase-0.10.so.0
#11 0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#12 0x057a178d in ?? () from /usr/lib/libgstbase-0.10.so.0
#13 0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#14 0x057a178d in ?? () from /usr/lib/libgstbase-0.10.so.0
#15 0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#16 0x07c2bbb9 in ?? () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#17 0x03766bba in ?? () from /usr/lib/libgstreamer-0.10.so.0
#18 0x03767ef7 in ?? () from /usr/lib/libgstreamer-0.10.so.0
#19 0x05c3ca39 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#20 0x05c3a2df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#21 0x005b6e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#22 0x077bd73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xa53fdb70 (LWP 1711)):
#0  0x0058a416 in __kernel_vsyscall ()
#1  0x005bb48c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x077cb3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x07c2a93e in ?? () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#4  0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#5  0x03726b5d in ?? () from /usr/lib/libgstreamer-0.10.so.0
#6  0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#7  0x07c38b46 in ?? () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#8  0x07c38dc6 in ?? () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#9  0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#10 0x03726b5d in ?? () from /usr/lib/libgstreamer-0.10.so.0
#11 0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#12 0x057a178d in ?? () from /usr/lib/libgstbase-0.10.so.0
#13 0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#14 0x057a178d in ?? () from /usr/lib/libgstbase-0.10.so.0
#15 0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#16 0x07c2bbb9 in ?? () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#17 0x03766bba in ?? () from /usr/lib/libgstreamer-0.10.so.0
#18 0x03767ef7 in ?? () from /usr/lib/libgstreamer-0.10.so.0
#19 0x05c3ca39 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#20 0x05c3a2df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#21 0x005b6e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#22 0x077bd73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xa4bfcb70 (LWP 1712)):
#0  0x0058a416 in __kernel_vsyscall ()
#1  0x005bb48c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x077cb3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x07c2a93e in ?? () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#4  0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#5  0x03726b5d in ?? () from /usr/lib/libgstreamer-0.10.so.0
#6  0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#7  0x07c388d7 in ?? () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#8  0x07c38dc6 in ?? () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#9  0x0373d3a0 in gst_pad_push () from /usr/lib/libgstreamer-0.10.so.0
#10 0x07c2bbb9 in ?? () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#11 0x03766bba in ?? () from /usr/lib/libgstreamer-0.10.so.0
#12 0x03767ef7 in ?? () from /usr/lib/libgstreamer-0.10.so.0
#13 0x05c3ca39 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#14 0x05c3a2df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#15 0x005b6e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#16 0x077bd73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb1669b70 (LWP 1713)):
#0  0x0058a416 in __kernel_vsyscall ()
#1  0x077aef76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x01c6b4a2 in ?? () from /usr/lib/libpulse.so.0
#3  0x01c5a3a9 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#4  0x01c5ab84 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#5  0x01c5ac64 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#6  0x01c6b443 in ?? () from /usr/lib/libpulse.so.0
#7  0x02211a75 in ?? () from /usr/lib/libpulsecommon-0.9.22.so
#8  0x005b6e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#9  0x077bd73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb6442720 (LWP 1698)):
[KCrash Handler]
#7  operator!= (this=0x8f6fda0, t=...) at /usr/include/qt4/QtCore/qbasicatomic.h:75
#8  QList<QWeakPointer<QAbstractAnimation> >::append (this=0x8f6fda0, t=...) at /usr/include/qt4/QtCore/qlist.h:496
#9  0x00b8c36b in enqueue (this=0x8f6fd68, anim=0x8f53ab8) at /usr/include/qt4/QtCore/qqueue.h:59
#10 Context::ContextView::addCollapseAnimation (this=0x8f6fd68, anim=0x8f53ab8) at ../../src/context/ContextView.cpp:257
#11 0x00b87888 in Context::Applet::collapse (this=0x8f05af0, on=true) at ../../src/context/Applet.cpp:320
#12 0x00b87d35 in Context::Applet::setCollapseOn (this=0x8f05af0) at ../../src/context/Applet.cpp:273
#13 0x068eee12 in LyricsApplet::dataUpdated (this=0x8f05af0, name=..., data=...) at ../../../../../src/context/applets/lyrics/LyricsApplet.cpp:618
#14 0x068f1d14 in LyricsApplet::qt_metacall (this=0x8f05af0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfe92724) at ./LyricsApplet.moc:102
#15 0x046286ba in QMetaObject::metacall (object=0x8f05af0, cl=QMetaObject::InvokeMetaMethod, idx=72, argv=0xbfe92724) at kernel/qmetaobject.cpp:237
#16 0x046384ff in QMetaObject::activate (sender=0x8fb2aa8, m=0x1b34904, local_signal_index=0, argv=0xbfe92724) at kernel/qobject.cpp:3287
#17 0x01972289 in Plasma::DataContainer::dataUpdated (this=0x8fb2aa8, _t1=..., _t2=...) at ./datacontainer.moc:112
#18 0x019727c3 in Plasma::DataContainer::checkForUpdate (this=0x8fb2aa8) at ../../plasma/datacontainer.cpp:297
#19 0x01975861 in Plasma::DataEngine::timerEvent (this=0x8f8aab0, event=0xbfe92c9c) at ../../plasma/dataengine.cpp:386
#20 0x04637214 in QObject::event (this=0x8f8aab0, e=0xbfe92c9c) at kernel/qobject.cpp:1190
#21 0x02cc7d24 in QApplicationPrivate::notify_helper (this=0x873d328, receiver=0x8f8aab0, e=0xbfe92c9c) at kernel/qapplication.cpp:4462
#22 0x02ccc8ce in QApplication::notify (this=0xbfe92fc4, receiver=0x8f8aab0, e=0xbfe92c9c) at kernel/qapplication.cpp:3862
#23 0x002e793a in KApplication::notify (this=0xbfe92fc4, receiver=0x8f8aab0, event=0xbfe92c9c) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x046220bb in QCoreApplication::notifyInternal (this=0xbfe92fc4, receiver=0x8f8aab0, event=0xbfe92c9c) at kernel/qcoreapplication.cpp:731
#25 0x046521e4 in sendEvent (this=0x8735054) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x8735054) at kernel/qeventdispatcher_unix.cpp:604
#27 0x0464edf4 in timerSourceDispatch (source=0x8735020) at kernel/qeventdispatcher_glib.cpp:184
#28 0x05c10aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#29 0x05c11270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0x05c11524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0x0464f53c in QEventDispatcherGlib::processEvents (this=0x8605a78, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#32 0x02d7e1e5 in QGuiEventDispatcherGlib::processEvents (this=0x8605a78, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x04621289 in QEventLoop::processEvents (this=0xbfe92f34, flags=...) at kernel/qeventloop.cpp:149
#34 0x04621522 in QEventLoop::exec (this=0xbfe92f34, flags=...) at kernel/qeventloop.cpp:201
#35 0x04625ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#36 0x02cc58e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#37 0x08054e95 in main (argc=) at ../../src/main.cpp:289

This bug may be a duplicate of or related to bug 258741.

Possible duplicates by query: bug 279971, bug 270781, bug 269740, bug 259378.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2011-08-14 21:03:28 UTC

*** This bug has been marked as a duplicate of bug 258741 ***