Bug 279971 - Amarok cash after last update Kubuntu 11.10
Summary: Amarok cash after last update Kubuntu 11.10
Status: RESOLVED DUPLICATE of bug 258741
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.4.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: 2.5
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-12 13:42 UTC by Sergio Casagrande
Modified: 2011-09-26 11:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergio Casagrande 2011-08-12 13:42:05 UTC
Application: amarok (2.4.3)
KDE Platform Version: 4.7.00 (4.7.0)
Qt Version: 4.7.3
Operating System: Linux 3.0.0-8-generic x86_64
Distribution: Ubuntu oneiric (development branch)

-- Information about the crash:
When I start amarok, it crashes
After install kubuntu 11.10 alpha 3, amarok worked proprerly, but after the last updates it crash every time I run it

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fac5b76f780 (LWP 1920))]

Thread 10 (Thread 0x7fac3c8ff700 (LWP 1927)):
#0  0x00007fac580c1433 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fac504a41bf in ?? () from /usr/lib/libpulse.so.0
#2  0x00007fac50496036 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007fac50496669 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007fac50496720 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007fac504a416f in ?? () from /usr/lib/libpulse.so.0
#6  0x00007fac4bdb4228 in ?? () from /usr/lib/libpulsecommon-0.9.23.so
#7  0x00007fac548dbedc in start_thread (arg=0x7fac3c8ff700) at pthread_create.c:304
#8  0x00007fac580cd55d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fac3850d700 (LWP 1931)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fac3850caf0 in ?? ()
#2  0x00007fff880b07e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 8 (Thread 0x7fac300e9700 (LWP 1933)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fac5892e1fb in wait (time=18446744073709551615, this=0x2149500) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2149720, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fac55e6b864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2149360, th=0x2149c10) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fac55e6de0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2149840, th=0x2149c10) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fac55e6cccf in ThreadWeaver::ThreadRunHelper::run (this=0x7fac300e8e20, parent=0x2149360, th=0x2149c10) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fac55e6cd5b in ThreadWeaver::Thread::run (this=0x2149c10) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fac5892dd55 in QThreadPrivate::start (arg=0x2149c10) at thread/qthread_unix.cpp:320
#8  0x00007fac548dbedc in start_thread (arg=0x7fac300e9700) at pthread_create.c:304
#9  0x00007fac580cd55d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fac2d557700 (LWP 1934)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fac2d556af0 in ?? ()
#2  0x00007fff880b07e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 6 (Thread 0x7fac2cb3a700 (LWP 1935)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fac5892e1fb in wait (time=18446744073709551615, this=0x2149500) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2149720, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fac55e6b864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2149360, th=0x252bf50) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fac55e6de0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2149840, th=0x252bf50) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fac55e6cccf in ThreadWeaver::ThreadRunHelper::run (this=0x7fac2cb39e20, parent=0x2149360, th=0x252bf50) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fac55e6cd5b in ThreadWeaver::Thread::run (this=0x252bf50) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fac5892dd55 in QThreadPrivate::start (arg=0x252bf50) at thread/qthread_unix.cpp:320
#8  0x00007fac548dbedc in start_thread (arg=0x7fac2cb3a700) at pthread_create.c:304
#9  0x00007fac580cd55d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fac27fff700 (LWP 1936)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fac5892e1fb in wait (time=18446744073709551615, this=0x2149500) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2149720, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fac55e6b864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2149360, th=0x24b7730) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fac55e6de0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2149840, th=0x24b7730) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fac55e6cccf in ThreadWeaver::ThreadRunHelper::run (this=0x7fac27ffee20, parent=0x2149360, th=0x24b7730) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fac55e6cd5b in ThreadWeaver::Thread::run (this=0x24b7730) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fac5892dd55 in QThreadPrivate::start (arg=0x24b7730) at thread/qthread_unix.cpp:320
#8  0x00007fac548dbedc in start_thread (arg=0x7fac27fff700) at pthread_create.c:304
#9  0x00007fac580cd55d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fac277fe700 (LWP 1937)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fac5892e1fb in wait (time=18446744073709551615, this=0x2149500) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2149720, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fac55e6b864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2149360, th=0x24e8ab0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fac55e6de0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2149840, th=0x24e8ab0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fac55e6cccf in ThreadWeaver::ThreadRunHelper::run (this=0x7fac277fde20, parent=0x2149360, th=0x24e8ab0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fac55e6cd5b in ThreadWeaver::Thread::run (this=0x24e8ab0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fac5892dd55 in QThreadPrivate::start (arg=0x24e8ab0) at thread/qthread_unix.cpp:320
#8  0x00007fac548dbedc in start_thread (arg=0x7fac277fe700) at pthread_create.c:304
#9  0x00007fac580cd55d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fac26375700 (LWP 1939)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fac4f89bd4c in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007fac4f89be79 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x00007fac548dbedc in start_thread (arg=0x7fac26375700) at pthread_create.c:304
#4  0x00007fac580cd55d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fac2465e700 (LWP 1943)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fac54eb7d82 in ?? () from /usr/lib/libQtScript.so.4
#2  0x00007fac54eb7db9 in ?? () from /usr/lib/libQtScript.so.4
#3  0x00007fac548dbedc in start_thread (arg=0x7fac2465e700) at pthread_create.c:304
#4  0x00007fac580cd55d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fac5b76f780 (LWP 1920)):
[KCrash Handler]
#6  operator!= (value=1, this=0x8) at /usr/include/qt4/QtCore/qbasicatomic.h:75
#7  QList<QWeakPointer<QAbstractAnimation> >::append (this=0x247bcb0, t=...) at /usr/include/qt4/QtCore/qlist.h:496
#8  0x00007fac5a3f5f80 in enqueue (t=..., this=<optimized out>) at /usr/include/qt4/QtCore/qqueue.h:59
#9  Context::ContextView::addCollapseAnimation (this=0x247bc40, anim=0x2966250) at ../../src/context/ContextView.cpp:257
#10 0x00007fac5a3f1564 in Context::Applet::collapse (this=0x26485f0, on=<optimized out>) at ../../src/context/Applet.cpp:320
#11 0x00007fac265a76d2 in Albums::dataUpdated (this=0x26485f0, data=<optimized out>, name=<optimized out>) at ../../../../../src/context/applets/albums/Albums.cpp:155
#12 0x00007fac265a8939 in Albums::dataUpdated (this=0x26485f0, name=<optimized out>, data=...) at ../../../../../src/context/applets/albums/Albums.cpp:132
#13 0x00007fac265a8c46 in Albums::qt_metacall (this=0x26485f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff880723f0) at ./Albums.moc:91
#14 0x00007fac58a276ea in QMetaObject::activate (sender=0x25cc7d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff880723f0) at kernel/qobject.cpp:3278
#15 0x00007fac552dca37 in Plasma::DataContainer::dataUpdated (this=<optimized out>, _t1=<optimized out>, _t2=<optimized out>) at ./datacontainer.moc:112
#16 0x00007fac552dcf0e in Plasma::DataContainer::checkForUpdate (this=0x25cc7d0) at ../../plasma/datacontainer.cpp:297
#17 0x00007fac552de82f in timerEvent (this=<optimized out>, event=<optimized out>) at ../../plasma/dataengine.cpp:386
#18 Plasma::DataEngine::timerEvent (this=<optimized out>, event=<optimized out>) at ../../plasma/dataengine.cpp:361
#19 0x00007fac58a2afb9 in QObject::event (this=0x24e8390, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fac59412154 in notify_helper (e=0x7fff88072990, receiver=0x24e8390, this=0x16842e0) at kernel/qapplication.cpp:4467
#21 QApplicationPrivate::notify_helper (this=0x16842e0, receiver=0x24e8390, e=0x7fff88072990) at kernel/qapplication.cpp:4439
#22 0x00007fac59416fc1 in QApplication::notify (this=0x7fff88072c90, receiver=0x24e8390, e=0x7fff88072990) at kernel/qapplication.cpp:4346
#23 0x00007fac5b16dde6 in KApplication::notify (this=0x7fff88072c90, receiver=0x24e8390, event=0x7fff88072990) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fac58a14a6c in QCoreApplication::notifyInternal (this=0x7fff88072c90, receiver=0x24e8390, event=0x7fff88072990) at kernel/qcoreapplication.cpp:731
#25 0x00007fac58a415e2 in sendEvent (event=0x7fff88072990, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x167e2e0) at kernel/qeventdispatcher_unix.cpp:604
#27 0x00007fac58a3ed84 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fac52e375bd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fac52e37db8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fac52e37f89 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fac58a3f746 in QEventDispatcherGlib::processEvents (this=0x14f7f40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fac594b972e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fac58a13c62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fac58a13e67 in QEventLoop::exec (this=0x7fff88072c20, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fac58a1807b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#36 0x000000000040916e in main (argc=1, argv=0x7fff88075298) at ../../src/main.cpp:289

Possible duplicates by query: bug 270781, bug 269740, bug 259378.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2011-08-13 09:43:33 UTC

*** This bug has been marked as a duplicate of bug 258741 ***