Bug 279981 - plasma crashes when suspending to ram
Summary: plasma crashes when suspending to ram
Status: RESOLVED DUPLICATE of bug 272964
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-12 16:20 UTC by john ratliff
Modified: 2011-08-12 18:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john ratliff 2011-08-12 16:20:34 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-10-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
Closed lid; when reopened the crash notification came on.  Closing lid set to "Suspend to RAM" in power management settings.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7710ad0 (LWP 1653))]

Thread 3 (Thread 0xaf843b70 (LWP 1661)):
#0  0x027b436b in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x0072c616 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x01ae5924 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01ae6270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01ae6524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x023bc577 in QEventDispatcherGlib::processEvents (this=0x8f9d200, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x0238e289 in QEventLoop::processEvents (this=0xaf843280, flags=...) at kernel/qeventloop.cpp:149
#7  0x0238e522 in QEventLoop::exec (this=0xaf843280, flags=...) at kernel/qeventloop.cpp:201
#8  0x022982a0 in QThread::exec (this=0x8f95880) at thread/qthread.cpp:492
#9  0x0236ffdb in QInotifyFileSystemWatcherEngine::run (this=0x8f95880) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0229ada2 in QThreadPrivate::start (arg=0x8f95880) at thread/qthread_unix.cpp:320
#11 0x027b1e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x0071e73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xae201b70 (LWP 1664)):
#0  0x0072c647 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#1  0x01ae5648 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x01ae603a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01ae6524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x023bc577 in QEventDispatcherGlib::processEvents (this=0x8fdb428, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x0238e289 in QEventLoop::processEvents (this=0xae201280, flags=...) at kernel/qeventloop.cpp:149
#6  0x0238e522 in QEventLoop::exec (this=0xae201280, flags=...) at kernel/qeventloop.cpp:201
#7  0x022982a0 in QThread::exec (this=0x8fd74b8) at thread/qthread.cpp:492
#8  0x0236ffdb in QInotifyFileSystemWatcherEngine::run (this=0x8fd74b8) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x0229ada2 in QThreadPrivate::start (arg=0x8fd74b8) at thread/qthread_unix.cpp:320
#10 0x027b1e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x0071e73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7710ad0 (LWP 1653)):
[KCrash Handler]
#7  0x024c80d1 in vtable for QtSharedPointer::ExternalRefCountData () from /usr/lib/libQtCore.so.4
#8  0x023a4da7 in QObject::disconnect (sender=0x96a0a50, signal=0x91f1071 "hasDefaultRouteChanged(bool)", receiver=0x8afee88, method=0x97a2fd1 "handleHasDefaultRouteChanged(bool)") at kernel/qobject.cpp:2737
#9  0x02776552 in InterfaceItem::currentConnectionChanged (this=0x8afee88) at ../../applet/interfaceitem.cpp:310
#10 0x0277638f in InterfaceItem::setConnectionInfo (this=0x8afee88) at ../../applet/interfaceitem.cpp:268
#11 0x02777c8f in WirelessInterfaceItem::setConnectionInfo (this=0x8afee88) at ../../applet/wirelessinterfaceitem.cpp:64
#12 0x02777c54 in WirelessInterfaceItem::updateInfo (this=0x8afee88) at ../../applet/wirelessinterfaceitem.cpp:54
#13 0x02769dc1 in WirelessInterfaceItem::qt_metacall (this=0x8afee88, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf81a958) at moc_wirelessinterfaceitem.cpp:74
#14 0x023956ba in QMetaObject::metacall (object=0x8afee88, cl=QMetaObject::InvokeMetaMethod, idx=56, argv=0xbf81a958) at kernel/qmetaobject.cpp:237
#15 0x023a54ff in QMetaObject::activate (sender=0x8fb3c00, m=0x278883c, local_signal_index=0, argv=0xbf81a958) at kernel/qobject.cpp:3287
#16 0x027694e3 in WirelessStatus::strengthChanged (this=0x8fb3c00, _t1=0) at moc_wirelessstatus.cpp:94
#17 0x02781920 in WirelessStatus::setStrength (this=0x8fb3c00, strength=0) at ../../applet/wirelessstatus.cpp:189
#18 0x02782017 in WirelessStatus::accessPointDestroyed (this=0x8fb3c00, ap=0x9001f10) at ../../applet/wirelessstatus.cpp:223
#19 0x0276955e in WirelessStatus::qt_metacall (this=0x8fb3c00, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf81ab08) at moc_wirelessstatus.cpp:82
#20 0x023956ba in QMetaObject::metacall (object=0x8fb3c00, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbf81ab08) at kernel/qmetaobject.cpp:237
#21 0x023a54ff in QMetaObject::activate (sender=0x9001f10, m=0x24c5230, local_signal_index=0, argv=0xbf81ab08) at kernel/qobject.cpp:3287
#22 0x023a59a3 in QObject::destroyed (this=0x9001f10, _t1=0x9001f10) at .moc/release-shared/moc_qobject.cpp:149
#23 0x023a6fba in QObject::~QObject (this=0x9001f10, __in_chrg=<value optimized out>) at kernel/qobject.cpp:843
#24 0x07a6b4cc in Solid::Control::AccessPoint::~AccessPoint (this=0x9001f10, __in_chrg=<value optimized out>) at ../../../../libs/solid/control/wirelessaccesspoint.cpp:69
#25 0x07a6b502 in Solid::Control::AccessPoint::~AccessPoint (this=0x9001f10, __in_chrg=<value optimized out>) at ../../../../libs/solid/control/wirelessaccesspoint.cpp:72
#26 0x07a6caae in Solid::Control::WirelessNetworkInterface::_k_accessPointRemoved (this=0x8d0e268, uni=...) at ../../../../libs/solid/control/wirelessnetworkinterface.cpp:163
#27 0x07a6ccfd in Solid::Control::WirelessNetworkInterface::qt_metacall (this=0x8d0e268, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf81ad08) at ./wirelessnetworkinterface.moc:116
#28 0x023956ba in QMetaObject::metacall (object=0x8d0e268, cl=QMetaObject::InvokeMetaMethod, idx=14, argv=0xbf81ad08) at kernel/qmetaobject.cpp:237
#29 0x023a54ff in QMetaObject::activate (sender=0x8d23ef8, m=0x2c33514, local_signal_index=4, argv=0xbf81ad08) at kernel/qobject.cpp:3287
#30 0x02c18cf3 in NMWirelessNetworkInterface::accessPointDisappeared (this=0x8d23ef8, _t1=...) at moc_wirelessnetworkinterface.cpp:140
#31 0x02c25a14 in NMWirelessNetworkInterface::accessPointRemoved (this=0x8d23ef8, apPath=...) at ../../../solid/networkmanager-0.7/wirelessnetworkinterface.cpp:188
#32 0x02c18efd in NMWirelessNetworkInterface::qt_metacall (this=0x8d23ef8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf81ae98) at moc_wirelessnetworkinterface.cpp:100
#33 0x023956ba in QMetaObject::metacall (object=0x8d23ef8, cl=QMetaObject::InvokeMetaMethod, idx=15, argv=0xbf81ae98) at kernel/qmetaobject.cpp:237
#34 0x023a54ff in QMetaObject::activate (sender=0x8d18dcc, m=0x2c34c04, local_signal_index=1, argv=0xbf81ae98) at kernel/qobject.cpp:3287
#35 0x02c2ca93 in OrgFreedesktopNetworkManagerDeviceWirelessInterface::AccessPointRemoved (this=0x8d18dcc, _t1=...) at ./nm-device-wifiinterface.moc:141
#36 0x02c2ce2d in OrgFreedesktopNetworkManagerDeviceWirelessInterface::qt_metacall (this=0x8d18dcc, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf81b02c) at ./nm-device-wifiinterface.moc:92
#37 0x003f7acd in QDBusConnectionPrivate::deliverCall (this=0x88f5ba0, object=0x8d18dcc, msg=..., metaTypes=..., slotIdx=6) at qdbusintegrator.cpp:942
#38 0x004021d7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8ec91a8, object=0x8d18dcc) at qdbusintegrator_p.h:103
#39 0x023a43b7 in QObject::event (this=0x8d18dcc, e=0x8ec91a8) at kernel/qobject.cpp:1226
#40 0x03316d24 in QApplicationPrivate::notify_helper (this=0x889cef8, receiver=0x8d18dcc, e=0x8ec91a8) at kernel/qapplication.cpp:4462
#41 0x0331b8ce in QApplication::notify (this=0x888e0d0, receiver=0x8d18dcc, e=0x8ec91a8) at kernel/qapplication.cpp:3862
#42 0x010923ca in KApplication::notify (this=0x888e0d0, receiver=0x8d18dcc, event=0x8ec91a8) at ../../kdeui/kernel/kapplication.cpp:311
#43 0x0238f0bb in QCoreApplication::notifyInternal (this=0x888e0d0, receiver=0x8d18dcc, event=0x8ec91a8) at kernel/qcoreapplication.cpp:731
#44 0x02392c79 in sendEvent (receiver=0x0, event_type=0, data=0x8836f50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#45 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8836f50) at kernel/qcoreapplication.cpp:1372
#46 0x02392e0d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#47 0x023bc3c4 in sendPostedEvents (s=0x889caa8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#48 postEventSourceDispatch (s=0x889caa8) at kernel/qeventdispatcher_glib.cpp:277
#49 0x01ae5aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#50 0x01ae6270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#51 0x01ae6524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#52 0x023bc53c in QEventDispatcherGlib::processEvents (this=0x8836aa8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#53 0x033cd1e5 in QGuiEventDispatcherGlib::processEvents (this=0x8836aa8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#54 0x0238e289 in QEventLoop::processEvents (this=0xbf81b814, flags=...) at kernel/qeventloop.cpp:149
#55 0x0238e522 in QEventLoop::exec (this=0xbf81b814, flags=...) at kernel/qeventloop.cpp:201
#56 0x02392ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#57 0x033148e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#58 0x005305a5 in kdemain (argc=1, argv=0xbf81ba24) at ../../../../plasma/desktop/shell/main.cpp:118
#59 0x080485cb in main (argc=1, argv=0xbf81ba24) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 266097.

Possible duplicates by query: bug 274183, bug 272964, bug 270316, bug 268634.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-08-12 18:13:16 UTC
Update networkmanagement plasmoid to newest version.

*** This bug has been marked as a duplicate of bug 272964 ***