Bug 270316 - Plasma crash on lid close
Summary: Plasma crash on lid close
Status: RESOLVED DUPLICATE of bug 268862
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: networkmanagement-daemon (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-07 13:26 UTC by Maurice James
Modified: 2011-04-07 18:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maurice James 2011-04-07 13:26:51 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.11-83.fc14.i686 i686
Distribution: "Fedora release 14 (Laughlin)"

-- Information about the crash:
- What I was doing when the application crashed:Closed the lid to my netbook. Upon reopening the was a message that the application had crashed

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7831780 (LWP 2037))]

Thread 2 (Thread 0xaf665b70 (LWP 2038)):
#0  0x00c90e56 in clock_gettime (clock_id=1, tp=0xaf664f70) at ../sysdeps/unix/clock_gettime.c:100
#1  0x020b94b9 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x02188083 in updateCurrentTime (this=0xaed01a34, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xaed01a34, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x02186882 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaf66505c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0218691d in timerSourcePrepare (source=0xaed01a00, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x00cee6b6 in g_main_context_prepare (context=<value optimized out>, priority=0xaf6650cc) at gmain.c:2469
#8  0x00cef55b in g_main_context_iterate (context=0xaed004e8, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2760
#9  0x00cefc35 in g_main_context_iteration (context=0xaed004e8, may_block=1) at gmain.c:2843
#10 0x021870e7 in QEventDispatcherGlib::processEvents (this=0xaed00468, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x0215854a in QEventLoop::processEvents (this=0xaf665220, flags=...) at kernel/qeventloop.cpp:149
#12 0x021587fa in QEventLoop::exec (this=0xaf665220, flags=...) at kernel/qeventloop.cpp:201
#13 0x0205f36b in QThread::exec (this=0x9a66938) at thread/qthread.cpp:490
#14 0x02139bcc in QInotifyFileSystemWatcherEngine::run (this=0x9a66938) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x02061e6a in QThreadPrivate::start (arg=0x9a66938) at thread/qthread_unix.cpp:285
#16 0x00c2ae99 in start_thread (arg=0xaf665b70) at pthread_create.c:301
#17 0x00b69d2e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb7831780 (LWP 2037)):
[KCrash Handler]
#7  0x02293670 in vtable for QtSharedPointer::ExternalRefCountData () from /usr/lib/libQtCore.so.4
#8  0x02170059 in QObject::disconnect (sender=0xa1b7480, signal=0xa2eb721 "hasDefaultRouteChanged(bool)", receiver=0x9ca8c40, method=0x9eb65f1 "handleHasDefaultRouteChanged(bool)") at kernel/qobject.cpp:2722
#9  0x012eea53 in InterfaceItem::currentConnectionChanged (this=0x9ca8c40) at /usr/src/debug/networkmanagement-0.9/applet/interfaceitem.cpp:309
#10 0x012ee880 in InterfaceItem::setConnectionInfo (this=0x9ca8c40) at /usr/src/debug/networkmanagement-0.9/applet/interfaceitem.cpp:267
#11 0x012f01b0 in WirelessInterfaceItem::setConnectionInfo (this=0x9ca8c40) at /usr/src/debug/networkmanagement-0.9/applet/wirelessinterfaceitem.cpp:64
#12 0x012f0175 in WirelessInterfaceItem::updateInfo (this=0x9ca8c40) at /usr/src/debug/networkmanagement-0.9/applet/wirelessinterfaceitem.cpp:54
#13 0x012e2482 in WirelessInterfaceItem::qt_metacall (this=0x9ca8c40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfdfaf88) at /usr/src/debug/networkmanagement-0.9/i686-redhat-linux-gnu/applet/moc_wirelessinterfaceitem.cpp:74
#14 0x0215fbeb in QMetaObject::metacall (object=0x9ca8c40, cl=QMetaObject::InvokeMetaMethod, idx=56, argv=0xbfdfaf88) at kernel/qmetaobject.cpp:237
#15 0x0216f0c7 in QMetaObject::activate (sender=0x9d51d60, m=0x1303080, local_signal_index=0, argv=0xbfdfaf88) at kernel/qobject.cpp:3272
#16 0x012e1c84 in WirelessStatus::strengthChanged (this=0x9d51d60, _t1=0) at /usr/src/debug/networkmanagement-0.9/i686-redhat-linux-gnu/applet/moc_wirelessstatus.cpp:94
#17 0x012f90c1 in WirelessStatus::setStrength (this=0x9d51d60, strength=0) at /usr/src/debug/networkmanagement-0.9/applet/wirelessstatus.cpp:189
#18 0x012f97d7 in WirelessStatus::accessPointDestroyed (this=0x9d51d60, ap=0x96b3ab0) at /usr/src/debug/networkmanagement-0.9/applet/wirelessstatus.cpp:223
#19 0x012e1cfe in WirelessStatus::qt_metacall (this=0x9d51d60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfdfb138) at /usr/src/debug/networkmanagement-0.9/i686-redhat-linux-gnu/applet/moc_wirelessstatus.cpp:82
#20 0x0215fbeb in QMetaObject::metacall (object=0x9d51d60, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfdfb138) at kernel/qmetaobject.cpp:237
#21 0x0216f0c7 in QMetaObject::activate (sender=0x96b3ab0, m=0x22907d0, local_signal_index=0, argv=0xbfdfb138) at kernel/qobject.cpp:3272
#22 0x0216f564 in QObject::destroyed (this=0x96b3ab0, _t1=0x96b3ab0) at .moc/release-shared/moc_qobject.cpp:149
#23 0x0217184b in QObject::~QObject (this=0x96b3ab0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:842
#24 0x0133c4ed in Solid::Control::AccessPoint::~AccessPoint (this=0x96b3ab0, __in_chrg=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.1/libs/solid/control/wirelessaccesspoint.cpp:69
#25 0x0133c523 in Solid::Control::AccessPoint::~AccessPoint (this=0x96b3ab0, __in_chrg=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.1/libs/solid/control/wirelessaccesspoint.cpp:72
#26 0x0133db2f in Solid::Control::WirelessNetworkInterface::_k_accessPointRemoved (this=0x9b85a90, uni=...) at /usr/src/debug/kdebase-workspace-4.6.1/libs/solid/control/wirelessnetworkinterface.cpp:163
#27 0x0133dd8d in Solid::Control::WirelessNetworkInterface::qt_metacall (this=0x9b85a90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfdfb338) at /usr/src/debug/kdebase-workspace-4.6.1/i686-redhat-linux-gnu/libs/solid/control/wirelessnetworkinterface.moc:116
#28 0x0215fbeb in QMetaObject::metacall (object=0x9b85a90, cl=QMetaObject::InvokeMetaMethod, idx=14, argv=0xbfdfb338) at kernel/qmetaobject.cpp:237
#29 0x0216f0c7 in QMetaObject::activate (sender=0x9c62688, m=0x138d0b8, local_signal_index=4, argv=0xbfdfb338) at kernel/qobject.cpp:3272
#30 0x0136dd64 in NMWirelessNetworkInterface::accessPointDisappeared (this=0x9c62688, _t1=...) at /usr/src/debug/kdebase-workspace-4.6.1/i686-redhat-linux-gnu/solid/networkmanager-0.7/moc_wirelessnetworkinterface.cpp:140
#31 0x0137b045 in NMWirelessNetworkInterface::accessPointRemoved (this=0x9c62688, apPath=...) at /usr/src/debug/kdebase-workspace-4.6.1/solid/networkmanager-0.7/wirelessnetworkinterface.cpp:188
#32 0x0136df6d in NMWirelessNetworkInterface::qt_metacall (this=0x9c62688, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfdfb4c8) at /usr/src/debug/kdebase-workspace-4.6.1/i686-redhat-linux-gnu/solid/networkmanager-0.7/moc_wirelessnetworkinterface.cpp:100
#33 0x0215fbeb in QMetaObject::metacall (object=0x9c62688, cl=QMetaObject::InvokeMetaMethod, idx=15, argv=0xbfdfb4c8) at kernel/qmetaobject.cpp:237
#34 0x0216f0c7 in QMetaObject::activate (sender=0x95a48fc, m=0x138e7a4, local_signal_index=1, argv=0xbfdfb4c8) at kernel/qobject.cpp:3272
#35 0x013820b4 in OrgFreedesktopNetworkManagerDeviceWirelessInterface::AccessPointRemoved (this=0x95a48fc, _t1=...) at /usr/src/debug/kdebase-workspace-4.6.1/i686-redhat-linux-gnu/solid/networkmanager-0.7/nm-device-wifiinterface.moc:141
#36 0x01382475 in OrgFreedesktopNetworkManagerDeviceWirelessInterface::qt_metacall (this=0x95a48fc, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfdfb69c) at /usr/src/debug/kdebase-workspace-4.6.1/i686-redhat-linux-gnu/solid/networkmanager-0.7/nm-device-wifiinterface.moc:92
#37 0x023d1a15 in QDBusConnectionPrivate::deliverCall (this=0x960c368, object=0x95a48fc, msg=..., metaTypes=..., slotIdx=6) at qdbusintegrator.cpp:919
#38 0x023dd3f8 in QDBusCallDeliveryEvent::placeMetaCall (this=0x9dc3d18, object=0x95a48fc) at qdbusintegrator_p.h:103
#39 0x0216ebcf in QObject::event (this=0x95a48fc, e=0x9dc3d18) at kernel/qobject.cpp:1211
#40 0x03a3826c in QApplicationPrivate::notify_helper (this=0x95af600, receiver=0x95a48fc, e=0x9dc3d18) at kernel/qapplication.cpp:4445
#41 0x03a3ced2 in QApplication::notify (this=0x95aa590, receiver=0x95a48fc, e=0x9dc3d18) at kernel/qapplication.cpp:3845
#42 0x0328a92b in KApplication::notify (this=0x95aa590, receiver=0x95a48fc, event=0x9dc3d18) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#43 0x021593b3 in QCoreApplication::notifyInternal (this=0x95aa590, receiver=0x95a48fc, event=0x9dc3d18) at kernel/qcoreapplication.cpp:732
#44 0x0215d105 in sendEvent (receiver=0x0, event_type=0, data=0x95770e8) at kernel/qcoreapplication.h:215
#45 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x95770e8) at kernel/qcoreapplication.cpp:1373
#46 0x0215d2de in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#47 0x02186f35 in sendPostedEvents (s=0x95ad1e8) at kernel/qcoreapplication.h:220
#48 postEventSourceDispatch (s=0x95ad1e8) at kernel/qeventdispatcher_glib.cpp:277
#49 0x00cef192 in g_main_dispatch (context=0x95b0378) at gmain.c:2149
#50 g_main_context_dispatch (context=0x95b0378) at gmain.c:2702
#51 0x00cef978 in g_main_context_iterate (context=0x95b0378, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#52 0x00cefc35 in g_main_context_iteration (context=0x95b0378, may_block=1) at gmain.c:2843
#53 0x021870ad in QEventDispatcherGlib::processEvents (this=0x9576b98, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#54 0x03aeb406 in QGuiEventDispatcherGlib::processEvents (this=0x9576b98, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#55 0x0215854a in QEventLoop::processEvents (this=0xbfdfbe94, flags=...) at kernel/qeventloop.cpp:149
#56 0x021587fa in QEventLoop::exec (this=0xbfdfbe94, flags=...) at kernel/qeventloop.cpp:201
#57 0x0215d3a7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#58 0x03a36078 in QApplication::exec () at kernel/qapplication.cpp:3719
#59 0x02f91f91 in kdemain (argc=1, argv=0xbfdfc0b4) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/desktop/shell/main.cpp:118
#60 0x0804883c in main (argc=1, argv=0xbfdfc0b4) at /usr/src/debug/kdebase-workspace-4.6.1/i686-redhat-linux-gnu/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 268634.

Reported using DrKonqi
Comment 1 Beat Wolf 2011-04-07 13:40:06 UTC

*** This bug has been marked as a duplicate of bug 268634 ***
Comment 2 Lamarque V. Souza 2011-04-07 18:50:08 UTC

*** This bug has been marked as a duplicate of bug 268862 ***