Bug 279354 - amarok looses track of files when using "organize files"
Summary: amarok looses track of files when using "organize files"
Status: RESOLVED DUPLICATE of bug 263640
Alias: None
Product: amarok
Classification: Applications
Component: Collections/Local (show other bugs)
Version: 2.4.1
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: 2.5
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-04 07:49 UTC by Gandalf Lechner
Modified: 2011-09-26 11:57 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gandalf Lechner 2011-08-04 07:49:04 UTC
Version:           2.4.1 (using KDE 4.7.0) 
OS:                Linux

When using "organize files" on a set of files/albums in the collection, amarok apparantly doesn't update the file location information in its database: The files cannot be played after they have been moved by "organize files". A rescan of the collection fixes this.

Reproducible: Always

Steps to Reproduce:
1. Select a bunch of files from the collection, go to "organize files" and move them with this method to a new location.
2. Drag the moved songs from the collection bar to the playlist and try to play them.

Actual Results:  
Files don't play after moving. Amarok jumps to the next unmoved file in the playlist (if there is any), otherwise it reports something like "too many errors in the playlist".

Expected Results:  
play the files

OS: Linux (x86_64) release 2.6.38-11-generic
Compiler: gcc
Comment 1 Myriam Schweingruber 2011-08-07 10:05:44 UTC

*** This bug has been marked as a duplicate of bug 263640 ***
Comment 2 Sandeep 2011-08-07 10:48:03 UTC
I don't think this is the same as bug 263640, since in that report the only thing that is required is to inform the user that some files aren't available for playback. Here, the file's location information needs to be updated after organizing files.
Comment 3 Myriam Schweingruber 2011-08-07 11:03:34 UTC
Sandeep: in both cases it is a wrong information in the database that is solved with a collection update. If not, then the other bug should not be in the component "Collection" but in the "Saved playlists".