Bug 263640 - JJ: moving a music folder, collection won't inform user of stale reference
Summary: JJ: moving a music folder, collection won't inform user of stale reference
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Collections/Local (show other bugs)
Version: 2.4.0
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords: junior-jobs, usability
: 279354 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-19 12:30 UTC by gert huizenga
Modified: 2011-08-27 21:53 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gert huizenga 2011-01-19 12:30:33 UTC
Version:           2.4.0 (using KDE 4.4.4) 
OS:                Linux

when moving my music to a different map, collection holds the old info to non-existing files.
This in itself is not an issue as it is good for external storage etc. but it fails to inform the user that the info is not physical available. This leads to files that are in playlist but for some reason won't play.

a notify that directory so and so isn't available would prevent confusion.
Updating collection settings by removal of old map and adding new map solves it. 
I know it looks silly but beleive me it took some time before i figured out that i had moved the complete map to a different disk. 

Reproducible: Didn't try


Actual Results:  
failing to play music files

Expected Results:  
notification that the '/home/USER/. ./music/artist/album/track' isn't accessible.
maybe with automatic rescanning and sequential notification that map.... is not available asking if it is ofline or that it needs to be removed from collection.

OS: Linux (x86_64) release 2.6.34.7-0.7-desktop
Compiler: gcc
Comment 1 Myriam Schweingruber 2011-01-20 02:05:23 UTC
What map are you talking about? Do you mean the database?
Comment 2 gert huizenga 2011-01-20 20:09:20 UTC
(In reply to comment #1)
> What map are you talking about? Do you mean the database?

i meant the music folder itself

i had my music in a folder in my home directory and moved the whole folder to a new disk that i have mounted under '/media/storage' 
after this amarok still had the old information as if the folder in my home directory still existed.
Comment 3 Myriam Schweingruber 2011-01-21 13:19:53 UTC
Thank you for the feedback.
Comment 4 Vavelin Kevin 2011-02-04 17:20:26 UTC
I want to know, did you mean the collection of Amarok (who save your tracks with directory when you add music or just the playlist?
Comment 5 Rohit U 2011-03-03 02:47:08 UTC
Ok, something like what Windows Media Player does in library? You move something, and the library is updated instantaneously.
Comment 6 Ralf Engels 2011-03-04 10:57:12 UTC
I understand,

you want to be informed if one of the collection folders is not longer existing.

(we are not talking here about the folder underneath it. Folders with albums in it get deleted every time)

The keyword junior-job is already set. I agree.
Comment 7 Sandeep 2011-03-20 20:41:48 UTC
I'll do it. Anyone I can ask about this?
Comment 8 Myriam Schweingruber 2011-03-20 20:45:56 UTC
(In reply to comment #7)
> I'll do it. Anyone I can ask about this?

Please ask in amarok-devel@kde.org
Comment 9 Myriam Schweingruber 2011-08-07 10:05:44 UTC
*** Bug 279354 has been marked as a duplicate of this bug. ***
Comment 10 Bart Cerneels 2011-08-22 12:06:34 UTC
Git commit 01d13d4becb370cd80e433303ec170a7d2eba066 by Bart Cerneels.
Committed on 22/08/2011 at 13:47.
Pushed by shanachie into branch 'master'.

Grey out playlist items when unplayable.

Patch by Sandeep Raghuraman

BUG: 263640
REVIEW: 102181
GUI:

M  +66   -45   src/playlist/view/PlaylistViewCommon.cpp
M  +3    -1    src/playlist/navigators/TrackNavigator.cpp
M  +6    -0    src/core-impl/collections/daap/DaapMeta.cpp
M  +1    -0    ChangeLog
M  +4    -1    src/services/lastfm/meta/LastFmMeta.cpp
M  +30   -5    src/playlist/navigators/StandardTrackNavigator.cpp
M  +1    -0    src/services/ampache/AmpacheMeta.h
M  +5    -1    src/core-impl/meta/stream/Stream.cpp
M  +7    -1    src/core-impl/meta/file/File.cpp
M  +6    -1    src/core-impl/collections/mediadevicecollection/MediaDeviceMeta.cpp
M  +4    -0    src/core-impl/collections/upnpcollection/UpnpMeta.cpp
M  +9    -0    src/services/ampache/AmpacheMeta.cpp
M  +1    -0    src/core-impl/collections/daap/CMakeLists.txt
M  +7    -1    src/core-impl/collections/audiocd/AudioCdMeta.cpp
M  +21   -1    src/playlist/view/listview/PrettyItemDelegate.cpp
M  +1    -0    src/services/ampache/CMakeLists.txt

http://commits.kde.org/amarok/01d13d4becb370cd80e433303ec170a7d2eba066