Bug 279215 - Log-out dialog is visually broken, and has no focus
Summary: Log-out dialog is visually broken, and has no focus
Status: RESOLVED FIXED
Alias: None
Product: ksmserver
Classification: Plasma
Component: ui (show other bugs)
Version: 4.6.x
Platform: Debian unstable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-02 21:22 UTC by Alex Dănilă
Modified: 2016-10-23 18:07 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
composited (592.47 KB, image/png)
2011-08-02 21:23 UTC, Alex Dănilă
Details
uncomposited (409.18 KB, image/png)
2011-08-02 21:24 UTC, Alex Dănilă
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Dănilă 2011-08-02 21:22:11 UTC
Version:           unspecified (using KDE 4.6.5) 
OS:                Linux

The log-out dialog tries to cover the contents of the desktop, but actually produces a lot of garbage pixels. In the non-composited version the dialog is only displayed partly, as can be seen in the screenshot.

In systemsettings no compositing effects related to this are enabled.

Two additional problems are just important, and I'll come with separate bug reports:

2. The log-out dialog does not seem to have keyboard focus. If I press enter or escape the key actually goes to the last active window.

3. This happens in a multiple display set-up. After the main display has been removed, that dialog is impossible to reach, because I cannot see it. I see two solutions for this: a) draw that dialog on all screens; b)the dialog should make a wild guess and draw itself on the window with the cursor.
Please don't dismiss this as invalid, as long as KDE and randr still have problems detecting and taking the right decision when display configuration changes.

Reproducible: Always

Steps to Reproduce:
Trigger the log-out dialog, with and without compositing.

Actual Results:  
Garbage pixels, dialog has no focus, dialog might be out of the visible area if a display has been removed.

Expected Results:  
A clean screen, dialog should have exclusive focus, dialog should be visible under all circumstances.
Comment 1 Alex Dănilă 2011-08-02 21:23:21 UTC
Created attachment 62487 [details]
composited

Compositing enabled.
Comment 2 Alex Dănilă 2011-08-02 21:24:08 UTC
Created attachment 62488 [details]
uncomposited

Compositing disabled, dialog only partly visible.
Comment 3 Christoph Feck 2011-08-02 22:38:55 UTC
Can you please check if the attachments are broken, or if the program that generated them has a bug that may be reported separately?

*** This bug has been marked as a duplicate of bug 199965 ***
Comment 4 Alex Dănilă 2011-08-03 06:40:44 UTC
The attachments are fine, they correspond with what my eyes see (apart from the two red rectangles, which I drew) :) 

Also, I don't know if it's the same bug. My background is always full of garbage, and that cut off window happens regardless of the state of compositing at login.
Comment 5 Alex Dănilă 2011-08-03 18:01:32 UTC
I'm setting it back to unconfirmed. I'll try to take a look at the garbage. The other issues are too complicated.
Comment 6 Lamarque V. Souza 2012-08-11 00:36:22 UTC
Can you test if this still happen in 4.9.0? The dialog has been rebuilt in QML now.
Comment 7 Myriam Schweingruber 2012-09-08 09:50:24 UTC
Waiting for feedback.
Comment 8 Alex Dănilă 2016-10-23 17:58:29 UTC
Please close, this is fixed.