Bug 199965 - Shutdown dialog not drawn correctly with desktop effects turned off
Summary: Shutdown dialog not drawn correctly with desktop effects turned off
Status: RESOLVED FIXED
Alias: None
Product: ksmserver
Classification: Plasma
Component: ui (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-13 06:03 UTC by S. Christian Collins
Modified: 2012-08-03 16:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of bug (8.85 KB, image/jpeg)
2009-07-13 06:04 UTC, S. Christian Collins
Details
With desktop effects (32.38 KB, image/png)
2009-09-28 17:20 UTC, Manuel Mommertz
Details
Without desktop effects (3.54 KB, image/png)
2009-09-28 17:22 UTC, Manuel Mommertz
Details
Grafik for logout dialog (from opaque folder) (29.01 KB, image/svg+xml)
2009-09-28 17:26 UTC, Manuel Mommertz
Details
Without desktop effects (Plasma desktop 4.4) (28.97 KB, image/png)
2010-02-17 10:49 UTC, Manuel Mommertz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description S. Christian Collins 2009-07-13 06:03:43 UTC
Version:            (using KDE 4.2.96)
OS:                Linux
Installed from:    Ubuntu Packages

When desktop effects are turned off, the shutdown dialog (and restart, logout, etc.) isn't drawn correctly.  I have attached a screenshot.  Notice the square corners and the misaligned graphics on the top-left and top-bottom corners.  This was tested using the Oxygen desktop theme.  Note that desktop effects need to be disabled from the beginning of the session for the problem to occur (in other words, don't start the session with desktop effects enabled and then disable them to check this bug--you need to disable desktop effects and then log off and back on again for it to work).

Test system:
Motherboard: MSI K9N SLI Platinum (nForce 570 SLI chipset)
CPU: AMD Athlon(tm) 64 Processor 4000+
RAM: 2GB DDR2
Video: NVIDIA GeForce 7600 GT (PCI Express)
OS: Kubuntu 9.04

Test environment:
Kernel: 2.6.30-020630-generic
KDE: 4.3 RC2
NVIDIA driver: 185.18.14
Comment 1 S. Christian Collins 2009-07-13 06:04:21 UTC
Created attachment 35267 [details]
screenshot of bug
Comment 2 S. Christian Collins 2009-07-13 06:05:19 UTC
"top-bottom" should read "bottom-left", hee hee.
Comment 3 S. Christian Collins 2009-07-24 21:55:54 UTC
Still present in KDE 4.3 RC3 (Kubuntu 9.04 packages).  The shutdown dialog looks better with the Air theme, but three of the four corners are black around the edges.
Comment 4 S. Christian Collins 2009-08-06 18:19:31 UTC
Still present in KDE 4.3 final.
Comment 5 Manuel Mommertz 2009-09-28 17:10:54 UTC
This seems like a problem with the mask of the widget. I am the author of an plasma theme, where this effect is extrem visible. Look at the screenshots.
Comment 6 Manuel Mommertz 2009-09-28 17:20:33 UTC
Created attachment 37218 [details]
With desktop effects

With desktop effects it looks good (apart from the black screen, which is
present since an update of xorg, so not kde-related)
Comment 7 Manuel Mommertz 2009-09-28 17:22:41 UTC
Created attachment 37219 [details]
Without desktop effects

This is how it looks if desktop effects are turned of. Seems like the mask is
set before the grafik is scaled to the window-size (the visible area has the
same size as the the grafik in the svg-file)
Comment 8 Manuel Mommertz 2009-09-28 17:26:17 UTC
Created attachment 37220 [details]
Grafik for logout dialog (from opaque folder)

This is the SVG-File which leads to the result.
Comment 9 Manuel Mommertz 2010-02-17 10:49:57 UTC
Created attachment 40871 [details]
Without desktop effects (Plasma desktop 4.4)

This is how it looks in 4.4. It's now only cutoff in vertical.
Comment 10 S. Christian Collins 2010-03-29 00:58:22 UTC
I can confirm this is still an issue in KDE SC 4.4.1 (tested using Kubuntu Lucid beta 1).
Comment 11 S. Christian Collins 2010-04-12 16:36:19 UTC
I can confirm this is still an issue in KDE SC 4.4.2 (tested using Kubuntu Lucid beta 2).
Comment 12 S. Christian Collins 2011-07-12 18:21:50 UTC
This bug is still present in KDE SC 4.6.5 (tested with Kubuntu 11.04).
Comment 13 S. Christian Collins 2011-07-29 20:40:14 UTC
I can confirm that this bug still exists in KDE 4.7.0 (tested using Kubuntu Natty).
Comment 14 Christoph Feck 2011-08-02 22:38:55 UTC
*** Bug 279215 has been marked as a duplicate of this bug. ***
Comment 15 S. Christian Collins 2012-08-03 16:00:08 UTC
This bug no longer seems relevant as of KDE 4.8.  With compositing disabled, both 4.8 and 4.9 change the background to black when logging off.  The black corners on the logout screen that were showing previously are not visible against a black background.