Bug 279023 - sorted contact list (idependent of different accounts) is missing
Summary: sorted contact list (idependent of different accounts) is missing
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: contactlist (show other bugs)
Version: git-latest
Platform: Ubuntu Packages Linux
: NOR wishlist
Target Milestone: 0.6-next
Assignee: David Edmundson
URL:
Keywords:
: 283039 312449 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-01 11:17 UTC by m.wege
Modified: 2014-02-18 12:12 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.wege 2011-08-01 11:17:43 UTC
Version:           git-latest (using KDE 4.7.0) 
OS:                Linux

I am missing a sorted contact list which is idependent of different accounts types, which just sorts all contacts by alphabet, online-status or other criteria. 

Reproducible: Didn't try



Expected Results:  
see above.

OS: Linux (x86_64) release 3.0.0-7-generic
Compiler: gcc
Comment 1 David Edmundson 2011-08-01 11:41:38 UTC
Confirmed.

Martin - if we wanted to do this, there is a class called flat-model-proxy, using this would solve this issue. 

However then the list of proxy models starts to get a bit length/confusing.
We would have the Accounts Model, Groups Model and FlatModel

Alternatively the Nepomuk PersonSetModel (for 0.3) is a flat model anyway, which solves this bug (at the expense of no longer having a group by accounts)
Comment 2 Martin Klapetek 2011-09-29 15:45:59 UTC
*** Bug 283039 has been marked as a duplicate of this bug. ***
Comment 3 David Edmundson 2012-10-26 06:41:43 UTC
My new models will fix this. Targetting 0.6, Assigned to me.
Comment 4 David Edmundson 2013-01-01 12:44:56 UTC
*** Bug 312449 has been marked as a duplicate of this bug. ***
Comment 5 David Edmundson 2013-01-01 12:56:16 UTC
One can already test this using the model_refactor_2 branch of ktp-common-internals and ktp-contact-list
Comment 6 David Edmundson 2013-01-15 17:01:17 UTC
Git commit 3315e817fb1ce8fd802b9ff7e9aa665d352573ef by David Edmundson.
Committed on 15/01/2013 at 18:00.
Pushed by davidedmundson into branch 'master'.

Merge big model refactor.

Replace all the models used to power KTp

Subclass of Tp::Contact (KTp::Contact) to power the model
Create a list of contacts ContactListModel
Which can be grouped into AccountsTreeProxyModel or GroupsTreeProxyModel
Related: bug 304085, bug 307899, bug 282218

REVIEW: 107377
REVIEW: 107629

DIGEST:

M  +5    -0    KTp/CMakeLists.txt

http://commits.kde.org/telepathy-common-internals/3315e817fb1ce8fd802b9ff7e9aa665d352573ef