Bug 278309 - Notifications don't have their lower styled part
Summary: Notifications don't have their lower styled part
Status: RESOLVED UNMAINTAINED
Alias: None
Product: plasma4
Classification: Plasma
Component: notifications (show other bugs)
Version: 4.8.0
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
: 317547 (view as bug list)
Depends on:
Blocks: extramile
  Show dependency treegraph
 
Reported: 2011-07-23 07:48 UTC by Unknown
Modified: 2013-04-20 12:08 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments
Missing lower part, rounded corners etc. (25.00 KB, image/png)
2011-07-23 07:48 UTC, Unknown
Details
Bug in KDE 4.10 (12.15 KB, image/png)
2013-02-27 17:23 UTC, Unknown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2011-07-23 07:48:07 UTC
Created attachment 62106 [details]
Missing lower part, rounded corners etc.

Version:           unspecified (using Devel) 
OS:                Linux

As you can see in the attached picture when the panel is rotated to be on the left side, the notifications don't have their lower styled border part. 

Interestingly, the window previews are styled normally.

Reproducible: Always



Expected Results:  
 

OS: Linux (x86_64) release 2.6.37.6-0.5-desktop
Compiler: gcc
Comment 1 Unknown 2012-02-04 11:54:13 UTC
This bug is still valid in KDE 4.8.0.
Comment 2 Martin Koller 2012-08-04 22:44:00 UTC
still the case in 4.9
Comment 3 rockonthemoonfm 2013-02-27 16:46:43 UTC
looks fixed to me in 4.10
Comment 4 Unknown 2013-02-27 17:23:27 UTC
Created attachment 77629 [details]
Bug in KDE 4.10

Unfortunately it's not fixed in KDE 4.10 either.
Comment 5 Richard Llom 2013-04-01 11:51:39 UTC
*** Bug 317547 has been marked as a duplicate of this bug. ***
Comment 6 Richard Llom 2013-04-01 12:00:14 UTC
Yes, still not fixed in KDE 4.10.1.

I would suggest to mark this as an extramile bug, to do so write in the "Blocks" field: extramile

On a side note:
Actually the lower part of the notification are always "flat" (no round corners, no shadow), this is for a nicer styling. But when you don't have a bottom panel, this flat side must adapt to the location of the panel, which is currently not the case.
You ca also see my bug report about this.
Comment 7 Myriam Schweingruber 2013-04-12 07:58:16 UTC
Since the Notification widget was replaced with a newer QML-based one, the previous versions are now considered unmaintained. There will be no more code contribution to the older versions.

Please only report bugs and wishes to the new version, available since KDE 4.10
Comment 8 Unknown 2013-04-12 08:08:30 UTC
Since the previous comments - backed by screenshots - clearly state that this bug does exist in at least KDE 4.10.1, hereby I reopen this report.

If I should move this to an other component, tell me.

To be an "extramile" bug, I need "agreement from the maintainer" (as stated here: http://community.kde.org/Getinvolved/Extra_Mile ). So I ask for a permission to make this bug extramile.
Comment 9 Richard Llom 2013-04-12 11:29:40 UTC
(In reply to comment #8)
> To be an "extramile" bug, I need "agreement from the maintainer" (as stated
> So I ask for a permission to make this bug extramile.
> 
Who&how do you ask? Or do you mean hereby you ask? If the latter, sorry, I highly doubt you will ever get an answer to that...

Maybe its worth a try the other way around:
Mark this bug as extramile and if the maintainer doesn't agree, this still can be revoked.
Comment 10 Unknown 2013-04-12 15:52:39 UTC
Well, worth a try :) .
Comment 11 Myriam Schweingruber 2013-04-17 19:21:29 UTC
Please do NOT reopen reports that are marked as unmaintained, there is a new Notification widget in KDE 4.10.x, use that one.
Comment 12 Christoph Feck 2013-04-17 20:38:36 UTC
Richard, simply file a new bug for 4.10.1, it's easier than to argue :)
Comment 13 Richard Llom 2013-04-17 22:25:52 UTC
@Szőts Ákos:
Can you test with the current 4.10.2? Here it is fixed with 4.10.2. :-)

@Christoph:
I did already (bug 317547) shall I really reopen this dupe now?
Comment 14 Sebastian Kügler 2013-04-18 18:01:59 UTC
Here, the bug is also not reproducable, so I'll leave it closed.

@Szőts Please retry with 4.10.2, and let us know if it's fixed there, if not, please add another screenshot showing it.
Comment 15 Unknown 2013-04-20 12:08:12 UTC
Seems it's fixed. Bye.