Bug 277387 - Plasma and Amarok errors after powersave mode on desktop
Summary: Plasma and Amarok errors after powersave mode on desktop
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-08 20:39 UTC by token
Modified: 2011-07-08 22:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description token 2011-07-08 20:39:30 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

I'm listen music by Amarok. Plasma KDE effects are on, and after powersave mode on my desktop, Amarok crash

-- Backtrace:
Application: Оболочка Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78c9720 (LWP 1881))]

Thread 3 (Thread 0xaf6ffb70 (LWP 1969)):
#0  0x00b75d41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x01e15dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x01ee24f2 in updateCurrentTime (this=0x8a1371c, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x8a1371c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x01ee0d32 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaf6ff0cc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x01ee0dcd in timerSourcePrepare (source=0x8a136e8, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x07a3afd4 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x07a3be63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x07a3c524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x01ee1577 in QEventDispatcherGlib::processEvents (this=0x8a146e8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x01eb3289 in QEventLoop::processEvents (this=0xaf6ff280, flags=...) at kernel/qeventloop.cpp:149
#12 0x01eb3522 in QEventLoop::exec (this=0xaf6ff280, flags=...) at kernel/qeventloop.cpp:201
#13 0x01dbd2a0 in QThread::exec (this=0x8a13f88) at thread/qthread.cpp:492
#14 0x01e94fdb in QInotifyFileSystemWatcherEngine::run (this=0x8a13f88) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x01dbfda2 in QThreadPrivate::start (arg=0x8a13f88) at thread/qthread_unix.cpp:320
#16 0x01474e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xae0bdb70 (LWP 1970)):
#0  0x07a3c51f in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x01ee1577 in QEventDispatcherGlib::processEvents (this=0x8abfe08, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#2  0x01eb3289 in QEventLoop::processEvents (this=0xae0bd280, flags=...) at kernel/qeventloop.cpp:149
#3  0x01eb3522 in QEventLoop::exec (this=0xae0bd280, flags=...) at kernel/qeventloop.cpp:201
#4  0x01dbd2a0 in QThread::exec (this=0x8acdca0) at thread/qthread.cpp:492
#5  0x01e94fdb in QInotifyFileSystemWatcherEngine::run (this=0x8acdca0) at io/qfilesystemwatcher_inotify.cpp:248
#6  0x01dbfda2 in QThreadPrivate::start (arg=0x8acdca0) at thread/qthread_unix.cpp:320
#7  0x01474e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb78c9720 (LWP 1881)):
[KCrash Handler]
#7  0x0105f454 in QString (this=0x85c0061, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#8  KIconEffect::fingerprint (this=0x85c0061, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0x01065352 in KIconLoaderPrivate::makeCacheKey (this=0x85c004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0x0106c398 in KIconLoader::loadIcon (this=0x91326e0, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0x01063d76 in KIconEngine::pixmap (this=0x913bca8, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x04b05ca2 in QIcon::pixmap (this=0x927eea4, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0x00640969 in Plasma::IconWidgetPrivate::decoration (this=0x927ee00, option=0x859cb70, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#14 0x0064721d in Plasma::IconWidget::paint (this=0x9277bc0, painter=0xbfca940c, option=0x859cb70, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1128
#15 0x041420dd in ?? () from /usr/lib/kde4/plasma_applet_systemtray.so
#16 0x050ae9ec in _q_paintItem (item=<value optimized out>, painter=0x859cb70, option=0x859cb70, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#17 0x050aecf2 in _q_paintIntoCache (pix=0xbfca98dc, item=0x9277bc8, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x859cb70, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#18 0x050c2a00 in QGraphicsScenePrivate::drawItemHelper (this=0x859ca20, item=0x9277bc8, painter=0xbfcab0c4, option=0x859cb70, widget=0x8ecd358, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#19 0x050c36c2 in QGraphicsScenePrivate::draw (this=0x859ca20, item=0x9277bc8, painter=0xbfcab0c4, viewTransform=0xbfcaaeac, transformPtr=0xbfca9cc0, exposedRegion=0x8ed32a0, widget=0x8ecd358, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#20 0x050c4402 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x859ca20, item=0x9277bc8, painter=0xbfcab0c4, viewTransform=0xbfcaaeac, exposedRegion=0x8ed32a0, widget=0x8ecd358, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#21 0x050c34ec in QGraphicsScenePrivate::draw (this=0x859ca20, item=0x87705c0, painter=0xbfcab0c4, viewTransform=0xbfcaaeac, transformPtr=0xbfcaa160, exposedRegion=0x8ed32a0, widget=0x8ecd358, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#22 0x050c4402 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x859ca20, item=0x87705c0, painter=0xbfcab0c4, viewTransform=0xbfcaaeac, exposedRegion=0x8ed32a0, widget=0x8ecd358, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#23 0x050c34ec in QGraphicsScenePrivate::draw (this=0x859ca20, item=0x87729f0, painter=0xbfcab0c4, viewTransform=0xbfcaaeac, transformPtr=0xbfcaa600, exposedRegion=0x8ed32a0, widget=0x8ecd358, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#24 0x050c4402 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x859ca20, item=0x87729f0, painter=0xbfcab0c4, viewTransform=0xbfcaaeac, exposedRegion=0x8ed32a0, widget=0x8ecd358, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#25 0x050c34ec in QGraphicsScenePrivate::draw (this=0x859ca20, item=0x85d6218, painter=0xbfcab0c4, viewTransform=0xbfcaaeac, transformPtr=0xbfcaaaa0, exposedRegion=0x8ed32a0, widget=0x8ecd358, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#26 0x050c4402 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x859ca20, item=0x85d6218, painter=0xbfcab0c4, viewTransform=0xbfcaaeac, exposedRegion=0x8ed32a0, widget=0x8ecd358, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#27 0x050c4c06 in QGraphicsScenePrivate::drawItems (this=0x859ca20, painter=0xbfcab0c4, viewTransform=0xbfcaaeac, exposedRegion=0x8ed32a0, widget=0x8ecd358) at graphicsview/qgraphicsscene.cpp:4735
#28 0x050e3ea1 in QGraphicsView::paintEvent (this=0x8ed2c98, event=0xbfcab7d4) at graphicsview/qgraphicsview.cpp:3469
#29 0x00473484 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#30 0x04aa818e in QWidget::event (this=0x8ed2c98, event=0xbfcab7d4) at kernel/qwidget.cpp:8405
#31 0x04e99f63 in QFrame::event (this=0x8ed2c98, e=0xbfcab7d4) at widgets/qframe.cpp:557
#32 0x04f285d2 in QAbstractScrollArea::viewportEvent (this=0x8ed2c98, e=0xbfcab7d4) at widgets/qabstractscrollarea.cpp:1043
#33 0x050e536f in QGraphicsView::viewportEvent (this=0x8ed2c98, event=0xbfcab7d4) at graphicsview/qgraphicsview.cpp:2864
#34 0x04f2aed5 in viewportEvent (this=0x8b409c0, o=0x8ecd358, e=0xbfcab7d4) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x8b409c0, o=0x8ecd358, e=0xbfcab7d4) at widgets/qabstractscrollarea_p.h:116
#36 0x01eb425a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x856a478, receiver=0x8ecd358, event=0xbfcab7d4) at kernel/qcoreapplication.cpp:846
#37 0x04a4fd00 in QApplicationPrivate::notify_helper (this=0x856a478, receiver=0x8ecd358, e=0xbfcab7d4) at kernel/qapplication.cpp:4458
#38 0x04a5497b in QApplication::notify (this=0x855c4d8, receiver=0x8ecd358, e=0xbfcab7d4) at kernel/qapplication.cpp:4427
#39 0x010be3ca in KApplication::notify (this=0x855c4d8, receiver=0x8ecd358, event=0xbfcab7d4) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x01eb40bb in QCoreApplication::notifyInternal (this=0x855c4d8, receiver=0x8ecd358, event=0xbfcab7d4) at kernel/qcoreapplication.cpp:731
#41 0x04aa4f0c in sendSpontaneousEvent (this=0x8ed0f70, pdev=0x8ed335c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8ed3328) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x8ed0f70, pdev=0x8ed335c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8ed3328) at kernel/qwidget.cpp:5492
#43 0x04aa5b7c in QWidgetPrivate::paintSiblingsRecursive (this=0x8ed2f50, pdev=0x8ed335c, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8ed3328) at kernel/qwidget.cpp:5699
#44 0x04aa5a42 in QWidgetPrivate::paintSiblingsRecursive (this=0x8ed2f50, pdev=0x8ed335c, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8ed3328) at kernel/qwidget.cpp:5686
#45 0x04aa5a42 in QWidgetPrivate::paintSiblingsRecursive (this=0x8ed2f50, pdev=0x8ed335c, siblings=..., index=5, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8ed3328) at kernel/qwidget.cpp:5686
#46 0x04aa4c80 in QWidgetPrivate::drawWidget (this=0x8ed2f50, pdev=0x8ed335c, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x8ed3328) at kernel/qwidget.cpp:5545
#47 0x04c80908 in QWidgetBackingStore::sync (this=0x8ed3328) at painting/qbackingstore.cpp:1333
#48 0x04a9a843 in QWidgetPrivate::syncBackingStore (this=0x8ed2f50) at kernel/qwidget.cpp:1842
#49 0x04aa87e5 in QWidget::event (this=0x8ed2c98, event=0x91326e0) at kernel/qwidget.cpp:8552
#50 0x04e99f63 in QFrame::event (this=0x8ed2c98, e=0x91326e0) at widgets/qframe.cpp:557
#51 0x04f2a33f in QAbstractScrollArea::event (this=0x8ed2c98, e=0x91326e0) at widgets/qabstractscrollarea.cpp:996
#52 0x050d8686 in QGraphicsView::event (this=0x8ed2c98, event=0x91326e0) at graphicsview/qgraphicsview.cpp:2741
#53 0x004737c3 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#54 0x04a4fd24 in QApplicationPrivate::notify_helper (this=0x856a478, receiver=0x8ed2c98, e=0x91326e0) at kernel/qapplication.cpp:4462
#55 0x04a5497b in QApplication::notify (this=0x855c4d8, receiver=0x8ed2c98, e=0x91326e0) at kernel/qapplication.cpp:4427
#56 0x010be3ca in KApplication::notify (this=0x855c4d8, receiver=0x8ed2c98, event=0x91326e0) at ../../kdeui/kernel/kapplication.cpp:311
#57 0x01eb40bb in QCoreApplication::notifyInternal (this=0x855c4d8, receiver=0x8ed2c98, event=0x91326e0) at kernel/qcoreapplication.cpp:731
#58 0x01eb7c79 in sendEvent (receiver=0x8ed2c98, event_type=77, data=0x8508f68) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#59 QCoreApplicationPrivate::sendPostedEvents (receiver=0x8ed2c98, event_type=77, data=0x8508f68) at kernel/qcoreapplication.cpp:1372
#60 0x01eb7e0d in QCoreApplication::sendPostedEvents (receiver=0x8ed2c98, event_type=77) at kernel/qcoreapplication.cpp:1265
#61 0x050bb1b6 in dispatchPendingUpdateRequests (this=0x859ca20) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#62 QGraphicsScenePrivate::_q_processDirtyItems (this=0x859ca20) at graphicsview/qgraphicsscene.cpp:510
#63 0x050bb596 in QGraphicsScene::qt_metacall (this=0x860d5e0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x8885160) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#64 0x00583a9a in Plasma::Corona::qt_metacall (this=0x860d5e0, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x8885160) at ./corona.moc:109
#65 0x0046620a in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#66 0x01eba6ba in QMetaObject::metacall (object=0x860d5e0, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x8885160) at kernel/qmetaobject.cpp:237
#67 0x01ec4e16 in QMetaCallEvent::placeMetaCall (this=0x9167178, object=0x860d5e0) at kernel/qobject.cpp:535
#68 0x01ec93b7 in QObject::event (this=0x860d5e0, e=0x9167178) at kernel/qobject.cpp:1226
#69 0x050c83b4 in QGraphicsScene::event (this=0x860d5e0, event=0x9167178) at graphicsview/qgraphicsscene.cpp:3544
#70 0x04a4fd24 in QApplicationPrivate::notify_helper (this=0x856a478, receiver=0x860d5e0, e=0x9167178) at kernel/qapplication.cpp:4462
#71 0x04a548ce in QApplication::notify (this=0x855c4d8, receiver=0x860d5e0, e=0x9167178) at kernel/qapplication.cpp:3862
#72 0x010be3ca in KApplication::notify (this=0x855c4d8, receiver=0x860d5e0, event=0x9167178) at ../../kdeui/kernel/kapplication.cpp:311
#73 0x01eb40bb in QCoreApplication::notifyInternal (this=0x855c4d8, receiver=0x860d5e0, event=0x9167178) at kernel/qcoreapplication.cpp:731
#74 0x01eb7c79 in sendEvent (receiver=0x0, event_type=0, data=0x8508f68) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#75 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8508f68) at kernel/qcoreapplication.cpp:1372
#76 0x01eb7e0d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#77 0x01ee13c4 in sendPostedEvents (s=0x856b638) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#78 postEventSourceDispatch (s=0x856b638) at kernel/qeventdispatcher_glib.cpp:277
#79 0x07a3baa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#80 0x07a3c270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#81 0x07a3c524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#82 0x01ee153c in QEventDispatcherGlib::processEvents (this=0x8508ac0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#83 0x04b03775 in QGuiEventDispatcherGlib::processEvents (this=0x8508ac0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#84 0x01eb3289 in QEventLoop::processEvents (this=0xbfcad244, flags=...) at kernel/qeventloop.cpp:149
#85 0x01eb3522 in QEventLoop::exec (this=0xbfcad244, flags=...) at kernel/qeventloop.cpp:201
#86 0x01eb7ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#87 0x04a4d8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#88 0x0046d5a5 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#89 0x080485cb in _start ()

This bug may be a duplicate of or related to bug 275395, bug 275753.

Possible duplicates by query: bug 277359, bug 277342, bug 277264, bug 277129, bug 277093.

Reported using DrKonqi
Comment 1 Dario Andres 2011-07-08 22:36:39 UTC
[Comment from a bug triager]
The bug is fixed since KDE SC 4.6.4. The issue was being tracked at bug 258706, merging.
Thanks

*** This bug has been marked as a duplicate of bug 258706 ***