Bug 277283 - Krita segfault on opening of X3F file
Summary: Krita segfault on opening of X3F file
Status: RESOLVED DUPLICATE of bug 244566
Alias: None
Product: krita
Classification: Applications
Component: General (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-07 10:01 UTC by bronto1959
Modified: 2011-07-08 12:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bronto1959 2011-07-07 10:01:18 UTC
Application: krita (2.3.1)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.5-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

Attempting to open Sigma (Foveon Sensor) .X3F raw image file with Krita. Krita was suggested by the system as an application suited for opening such raw files. Image file was downloaded from http://www.photographyblog.com/reviews/sigma_dp2x_review/sample_images/

Immediately after downloading and installing Krita the app crashed with segfault. Subsequent opening of said file has same results.

The crash can be reproduced every time.

-- Backtrace:
Application: Krita (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#7  0xace432a4 in qRgb (this=0x86b1448) at /usr/include/QtGui/qrgb.h:70
#8  KisRawImport::slotUpdatePreview (this=0x86b1448) at /usr/src/debug/koffice-2.3.1/krita/plugins/formats/raw/kis_raw_import.cpp:182
#9  0xace435f5 in KisRawImport::convert (this=0x86b1448, from=..., to=...) at /usr/src/debug/koffice-2.3.1/krita/plugins/formats/raw/kis_raw_import.cpp:105
#10 0xb2580f27 in KOfficeFilter::ChainLink::invokeFilter (this=0x86a3ce8, parentChainLink=0x0) at /usr/src/debug/koffice-2.3.1/libs/main/KoFilterChainLink.cpp:90
#11 0xb257800a in KoFilterChain::invokeChain (this=0x86a4550) at /usr/src/debug/koffice-2.3.1/libs/main/KoFilterChain.cpp:94
#12 0xb257658f in KoFilterManager::importDocument (this=0x86a22b8, url=..., status=@0xbfa50e84) at /usr/src/debug/koffice-2.3.1/libs/main/KoFilterManager.cpp:164
#13 0xb25294c1 in KoDocument::openFile (this=0x820a920) at /usr/src/debug/koffice-2.3.1/libs/main/KoDocument.cpp:1336
#14 0xb4f615c0 in KParts::ReadOnlyPartPrivate::openLocalFile (this=0x853c960) at /usr/src/debug/kdelibs-4.6.0/kparts/part.cpp:592
#15 0xb4f61c89 in KParts::ReadOnlyPart::openUrl (this=0x820a920, url=...) at /usr/src/debug/kdelibs-4.6.0/kparts/part.cpp:556
#16 0xb252c101 in KoDocument::openUrl (this=0x820a920, _url=...) at /usr/src/debug/koffice-2.3.1/libs/main/KoDocument.cpp:1251
#17 0xb2548df4 in KoMainWindow::openDocumentInternal (this=0x8198068, url=..., newdoc=<value optimized out>) at /usr/src/debug/koffice-2.3.1/libs/main/KoMainWindow.cpp:679
#18 0xb2546f8c in KoMainWindow::openDocument (this=0x8198068, newdoc=0x820a920, url=...) at /usr/src/debug/koffice-2.3.1/libs/main/KoMainWindow.cpp:662
#19 0xb251724c in KoApplication::start (this=0xbfa514a0) at /usr/src/debug/koffice-2.3.1/libs/main/KoApplication.cpp:252
#20 0xb559d364 in kdemain (argc=2, argv=0x809c420) at /usr/src/debug/koffice-2.3.1/krita/main.cc:46
#21 0x0804e531 in _start ()

Reported using DrKonqi
Comment 1 Cyrille Berger 2011-07-08 12:11:02 UTC
Thanks for the report, this is actually fixed in the development version.

*** This bug has been marked as a duplicate of bug 244566 ***