Bug 244566 - krita crashed when opening a raw file
Summary: krita crashed when opening a raw file
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
: 244778 273280 274222 274541 276945 277283 278563 283905 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-14 04:43 UTC by Craig Magina
Modified: 2014-10-12 20:32 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.56 KB, text/plain)
2010-08-20 17:44 UTC, Alberto Montero
Details
New crash information added by DrKonqi (3.90 KB, text/plain)
2011-04-13 01:34 UTC, robert.l.kief
Details
New crash information added by DrKonqi (8.62 KB, text/plain)
2011-05-02 03:30 UTC, facundo
Details
New crash information added by DrKonqi (2.35 KB, text/plain)
2011-05-25 09:24 UTC, Ryan
Details
Automatically created bug-report on 2014-10-13 (9.21 KB, text/plain)
2014-10-12 20:28 UTC, Sergey Bubnov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Craig Magina 2010-07-14 04:43:08 UTC
Application: krita (2.2.1)
KDE Platform Version: 4.4.92 (KDE 4.4.92 (KDE 4.5 RC2))
Qt Version: 4.7.0
Operating System: Linux 2.6.32-24-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
I clicked an image in Dolphin and it tried to use Krita to open the raw photo.  Krita appeared to open, but before it displayed the image, it crashed.  I just installed the latest Krita from Kubuntu's ppa.

The crash can be reproduced every time.

-- Backtrace:
Application: Krita (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1393791760 (LWP 12447))]

Thread 2 (Thread 0x7f1378edc710 (LWP 12448)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f13920acd7b in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0xf55bf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xf55bf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f13920a8a6b in QSemaphore::acquire (this=0x7f137ab908b0, n=1) at thread/qsemaphore.cpp:142
#4  0x00007f137a84250e in KisTileDataPooler::waitForWork (this=0x7f137ab908a0) at ../../../krita/image/tiles3/kis_tile_data_pooler.cc:133
#5  0x00007f137a8429a8 in KisTileDataPooler::run (this=0x7f137ab908a0) at ../../../krita/image/tiles3/kis_tile_data_pooler.cc:162
#6  0x00007f13920ac1be in QThreadPrivate::start (arg=0x7f137ab908a0) at thread/qthread_unix.cpp:266
#7  0x00007f1391e1a9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#8  0x00007f13904836fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1393791760 (LWP 12447)):
[KCrash Handler]
#6  QBasicAtomicInt::ref (this=0x7fff4db46628, other=...) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:121
#7  QString::operator= (this=0x7fff4db46628, other=...) at tools/qstring.cpp:1323
#8  0x00007f136b85777b in KDcrawIface::RawDecodingSettings::operator= (this=0x7fff4db465b8, o=...) at ../../../../libs/libkdcraw/libkdcraw/rawdecodingsettings.cpp:126
#9  0x00007f136b84db72 in KDcrawIface::KDcraw::decodeHalfRAWImage (this=0x7fff4db465a0, filePath=..., rawDecodingSettings=..., imageData=..., width=@0x7fff4db4676c, height=@0x7fff4db46768, 
    rgbmax=@0x7fff4db46764) at ../../../../libs/libkdcraw/libkdcraw/kdcraw.cpp:357
#10 0x00007f136baa8562 in KisRawImport::slotUpdatePreview (this=0x121c1f0) at ../../../../../krita/plugins/formats/raw/kis_raw_import.cpp:169
#11 0x00007f136baa9004 in KisRawImport::convert (this=0x121c1f0, from=<value optimized out>, to=<value optimized out>) at ../../../../../krita/plugins/formats/raw/kis_raw_import.cpp:101
#12 0x00007f13843cd5ff in KOfficeFilter::ChainLink::invokeFilter (this=0x1242bf0, parentChainLink=0x0) at ../../../libs/main/KoFilterChainLink.cpp:73
#13 0x00007f13843c446b in KoFilterChain::invokeChain (this=0x12296f0) at ../../../libs/main/KoFilterChain.cpp:94
#14 0x00007f13843c2548 in KoFilterManager::importDocument (this=0x1221520, url=<value optimized out>, status=<value optimized out>) at ../../../libs/main/KoFilterManager.cpp:163
#15 0x00007f1384378721 in KoDocument::openFile (this=0x1190130) at ../../../libs/main/KoDocument.cpp:1253
#16 0x00007f138a05bc07 in KParts::ReadOnlyPart::openUrl (this=0x1190130, url=<value optimized out>) at ../../kparts/part.cpp:557
#17 0x00007f138437822c in KoDocument::openUrl (this=0x1190130, _url=...) at ../../../libs/main/KoDocument.cpp:1181
#18 0x00007f13843985b7 in KoMainWindow::openDocumentInternal (this=0x11c44d0, url=..., newdoc=0x1190130) at ../../../libs/main/KoMainWindow.cpp:671
#19 0x00007f138439957a in KoMainWindow::openDocument (this=0x11c44d0, newdoc=0x1190130, url=...) at ../../../libs/main/KoMainWindow.cpp:654
#20 0x00007f1384368a0c in KoApplication::start (this=<value optimized out>) at ../../../libs/main/KoApplication.cpp:216
#21 0x00007f1384660d63 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../krita/main.cc:46
#22 0x0000000000407d53 in launch (argc=2, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=16, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0xd6b6f4 "raumo;1279074724;479023;12316_TIME19724581") at ../../kinit/kinit.cpp:723
#23 0x00000000004089a0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1215
#24 0x0000000000408f2a in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1408
#25 0x0000000000409b02 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1892

Reported using DrKonqi
Comment 1 Halla Rempt 2010-07-14 07:42:43 UTC
Thanks for your report. It looks like some mismatch between kdcraw and Krita, but I have to experiment. Could you attach or mail me a NEF file (boud@valdyas.org)?
Comment 2 Sven Langkamp 2010-07-16 13:34:15 UTC
*** Bug 244778 has been marked as a duplicate of this bug. ***
Comment 3 Halla Rempt 2010-07-16 15:05:16 UTC
Hm... It looks like a problem with the libkdcraw that comes with KDE 4.5. I'm still using 4.4 myself, but today I noticed a lot of deprecation warnings after upgrading to 4.4.5.
Comment 4 caulier.gilles 2010-07-16 20:23:32 UTC
I already see this crash in the pass with digiKam. This is relevant of both install of libkdcraw (an old one and trunk). BC have been broken in raw settings container. Check your system.

On my computer, i always use trunk. I always work in raw, and i cannpt see crash there.

Gilles Caulier
Comment 5 Halla Rempt 2010-08-15 14:58:47 UTC
The right dcraw and krita should be packaged together.
Comment 6 Alberto Montero 2010-08-20 17:44:00 UTC
Created attachment 50786 [details]
New crash information added by DrKonqi

krita (2.1.2) on KDE Platform 4.5.00 (KDE 4.5.0) using Qt 4.7.0

Trying to open a Canon raw file, both from dolphin and from the open file dialog.

-- Backtrace (Reduced):
#7  QString::operator= (this=0x7fff54aab228, other=...) at tools/qstring.cpp:1323
#8  0x00007ff3682c377b in KDcrawIface::RawDecodingSettings::operator=(KDcrawIface::RawDecodingSettings const&) () from /usr/lib/libkdcraw.so.8
#9  0x00007ff3682b9b72 in KDcrawIface::KDcraw::decodeHalfRAWImage(QString const&, KDcrawIface::RawDecodingSettings const&, QByteArray&, int&, int&, int&) () from /usr/lib/libkdcraw.so.8
[...]
[...]
[...]
#13 0x00007ff3985a797b in KoFilterChain::invokeChain() () from /usr/lib/libkomain.so.6
#14 0x00007ff3985a5a88 in KoFilterManager::importDocument(QString const&, KoFilter::ConversionStatus&) () from /usr/lib/libkomain.so.6
Comment 7 robert.l.kief 2011-04-13 01:34:13 UTC
Created attachment 58864 [details]
New crash information added by DrKonqi

krita (2.3.3) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.1

- What I was doing when the application crashed: I was running DigiCam and had selected the option to open the file manager.  I pathed to the folder I wanted open 1nd, after the files were displayed, double clicked on the first .NEF file.  Crash!  I am using the Gnome 2.32.0 desktop.

-- Backtrace (Reduced):
#6  0x00007ff7fda30fe8 in KisRawImport::slotUpdatePreview (this=0x7f92130) at /usr/src/debug/koffice-2.3.3/krita/plugins/formats/raw/kis_raw_import.cpp:182
#7  0x00007ff7fda312f4 in KisRawImport::convert (this=0x7f92130, from=<value optimized out>, to=<value optimized out>) at /usr/src/debug/koffice-2.3.3/krita/plugins/formats/raw/kis_raw_import.cpp:105
#8  0x00007ff81fdbab92 in KOfficeFilter::ChainLink::invokeFilter (this=0x7f92d30, parentChainLink=0x0) at /usr/src/debug/koffice-2.3.3/libs/main/KoFilterChainLink.cpp:90
#9  0x00007ff81fdb2719 in KoFilterChain::invokeChain (this=0x7f92c90) at /usr/src/debug/koffice-2.3.3/libs/main/KoFilterChain.cpp:94
#10 0x00007ff81fdb0f89 in KoFilterManager::importDocument (this=0x7fa04d0, url=..., status=@0x7fff6d52622c) at /usr/src/debug/koffice-2.3.3/libs/main/KoFilterManager.cpp:164
Comment 8 facundo 2011-05-02 03:30:03 UTC
Created attachment 59521 [details]
New crash information added by DrKonqi

krita (2.3.3) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:
I was trying to open a nokin raw file with extension nef.

-- Backtrace (Reduced):
#6  KisRawImport::slotUpdatePreview (this=0x60953c0) at ../../../../../krita/plugins/formats/raw/kis_raw_import.cpp:182
#7  0x00007f1643fc012a in KisRawImport::convert (this=0x60953c0, from=..., to=<value optimized out>) at ../../../../../krita/plugins/formats/raw/kis_raw_import.cpp:105
#8  0x00007f167a404e92 in KOfficeFilter::ChainLink::invokeFilter (this=0x6084fb0, parentChainLink=0x0) at ../../../libs/main/KoFilterChainLink.cpp:90
#9  0x00007f167a3fcdd9 in KoFilterChain::invokeChain (this=0x5cdefd0) at ../../../libs/main/KoFilterChain.cpp:94
#10 0x00007f167a3fb629 in KoFilterManager::importDocument (this=0x5e73110, url=..., status=@0x7fff4d0ee99c) at ../../../libs/main/KoFilterManager.cpp:164
Comment 9 Cyrille Berger 2011-05-14 21:09:25 UTC
*** Bug 273280 has been marked as a duplicate of this bug. ***
Comment 10 Halla Rempt 2011-05-21 08:01:53 UTC
It happens because of a mismatch between kdcraw and krita -- I'm not sure what kind of checks we can implement to prevent it, though.
Comment 11 Ryan 2011-05-25 09:24:32 UTC
Created attachment 60295 [details]
New crash information added by DrKonqi

krita (2.3.1) on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

Same: opened an NEF from inside Dolphin (from Nikon D3000). Krita crashed three times in a row right as it was starting to open it.

-- Backtrace (Reduced):
#6  0xad83e263 in KisRawImport::slotUpdatePreview (this=0x86d4860) at /usr/src/debug/koffice-2.3.1/krita/plugins/formats/raw/kis_raw_import.cpp:182
#7  0xad83e5f5 in KisRawImport::convert (this=0x86d4860, from=..., to=...) at /usr/src/debug/koffice-2.3.1/krita/plugins/formats/raw/kis_raw_import.cpp:105
#8  0xb2467f27 in KOfficeFilter::ChainLink::invokeFilter (this=0x86d3c58, parentChainLink=0x0) at /usr/src/debug/koffice-2.3.1/libs/main/KoFilterChainLink.cpp:90
#9  0xb245f00a in KoFilterChain::invokeChain (this=0x86d33a0) at /usr/src/debug/koffice-2.3.1/libs/main/KoFilterChain.cpp:94
#10 0xb245d58f in KoFilterManager::importDocument (this=0x86d1cc0, url=..., status=@0xbff7fc44) at /usr/src/debug/koffice-2.3.1/libs/main/KoFilterManager.cpp:164
Comment 12 Sven Langkamp 2011-05-26 22:18:18 UTC
*** Bug 274222 has been marked as a duplicate of this bug. ***
Comment 13 Cyrille Berger 2011-05-31 00:08:21 UTC
*** Bug 274541 has been marked as a duplicate of this bug. ***
Comment 14 Cyrille Berger 2011-06-06 07:57:07 UTC
Git commit efc7e5d62b617f67b0df66e5e4e01e4587df06a1 by Cyrille Berger.
Committed on 06/06/2011 at 07:55.
Pushed by berger into branch 'master'.

make the preview directly as 8bit image

fix crash when loading the preview with kdcraw >= 4.6, still crash later

CCBUG: 244566

M  +3    -7    krita/plugins/formats/raw/kis_raw_import.cpp     

http://commits.kde.org/calligra/efc7e5d62b617f67b0df66e5e4e01e4587df06a1
Comment 15 Cyrille Berger 2011-06-06 08:58:01 UTC
Hum the other crash I had was due to me needed to recompile everything. Now it is gone.
Comment 16 Cyrille Berger 2011-07-02 15:58:41 UTC
*** Bug 276945 has been marked as a duplicate of this bug. ***
Comment 17 Cyrille Berger 2011-07-08 12:11:02 UTC
*** Bug 277283 has been marked as a duplicate of this bug. ***
Comment 18 Sven Langkamp 2011-07-26 17:35:52 UTC
*** Bug 278563 has been marked as a duplicate of this bug. ***
Comment 19 Sven Langkamp 2011-10-13 22:35:11 UTC
*** Bug 283905 has been marked as a duplicate of this bug. ***
Comment 20 Sergey Bubnov 2014-10-12 20:28:35 UTC
Created attachment 89104 [details]
Automatically created bug-report on 2014-10-13

In krita 2.8.3 this bug appears too. Attachment is bug-report.
Thank you for attention.
Comment 21 Sergey Bubnov 2014-10-12 20:32:35 UTC
Comment on attachment 89104 [details]
Automatically created bug-report on 2014-10-13

Oh, I forgot about that system Russified.