Bug 277015 - In Unified mode the collection is not grouped after startup according to the selected groups (artist/album)
Summary: In Unified mode the collection is not grouped after startup according to the ...
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Collection Browser (show other bugs)
Version: 2.4-GIT
Platform: Gentoo Packages Linux
: NOR minor (vote)
Target Milestone: 2.5
Assignee: Amarok Developers
URL:
Keywords: release_blocker
: 283198 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-03 16:46 UTC by simon
Modified: 2011-11-18 18:43 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description simon 2011-07-03 16:46:57 UTC
Version:           2.4-GIT (using KDE 4.6.3) 
OS:                Linux

In Unified mode the collection is not grouped after startup according to the selected groups (artist/album).
If one does a quick filter on the collection: e.g. acdc and clears this the collection is grouped fine.
This occurs only after fresh start with View Mode=UnifiedCollection.

Reproducible: Always

Steps to Reproduce:
set View Mode to UnifiedCollection, quit amarok and restart.


Actual Results:  
Single tracks are shown in collection browser

Expected Results:  
Tracks are grouped below artist/album (depending on own grouping settings)

maybe related to https://bugs.kde.org/show_bug.cgi?id=269535
Comment 1 Sam Lade 2011-07-03 16:55:52 UTC
Confirm this with Amarok git, KDE 4.6.4 on Kubuntu. Setting merged view causes the collection to be initially incorrectly sorted. (I don't think it even requires an Amarok restart, just press the merged view button.)
Comment 2 Myriam Schweingruber 2011-07-03 19:08:17 UTC
Thank you for the fast feedback, setting to confirmed.
Comment 3 Sergey Ivanov 2011-11-05 21:54:21 UTC
Git commit a41f01e046179a5f275c4db4d17ab7b7d5c7df19 by Sergey Ivanov.
Committed on 05/11/2011 at 21:56.
Pushed by ivanov into branch 'master'.

Fixed collection browser tracks grouping after switching to Merged View.
BUG: 277015
FIXED-IN: 2.5

M  +1    -0    ChangeLog
M  +3    -0    src/browsers/SingleCollectionTreeItemModel.cpp

http://commits.kde.org/amarok/a41f01e046179a5f275c4db4d17ab7b7d5c7df19
Comment 4 Sergey Ivanov 2011-11-18 18:43:09 UTC
*** Bug 283198 has been marked as a duplicate of this bug. ***