Bug 269535 - Collection browser doesn't update when collection changes in Merged View
Summary: Collection browser doesn't update when collection changes in Merged View
Status: RESOLVED DUPLICATE of bug 262504
Alias: None
Product: amarok
Classification: Unclassified
Component: Collection Browser (show other bugs)
Version: 2.6.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: 2.8
Assignee: Amarok Developers
URL:
Keywords:
Depends on: 172542
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-27 13:35 UTC by fatgerman
Modified: 2013-07-21 23:33 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fatgerman 2011-03-27 13:35:03 UTC
Version:           2.4.0.90 (using KDE 4.6.1) 
OS:                Linux

I've found various operations I can do through the collection browser that require the browser to update but it doesn't.

Reproducible: Always

Steps to Reproduce:
1. Choose an album and select 'Show Under Various Artists' (or 'Do Not Show Under Various Artists'). I would expect the album to disappear and reappear in the appropriate place. It doesn't disappear though, which makes it look like the operation hasn't worked. A restart of amarok shows that it has been moved to the correct place though.

2. Edit the ID3 tags for a track - either to change the track name or to change the artists name. In both cases the track will stay exactly as it was in the collection display until amarok is restarted. It's very confusing :-)

3. I've also found that on occasion, newly added tracks (via 'Update Collection') do not appear in the collection browser until amarok is restarted. This one is NOT 100% reproducible.
Comment 1 Myriam Schweingruber 2011-03-29 08:08:23 UTC
Strange, my collection browser displays the changes immediately here, using the default embedded MySQL, local collection files on Kubuntu 10.10 with KDE 4.6.1 and Amarok 2.4-git

Can somebody else confirm this?
Comment 2 fatgerman 2011-03-30 00:45:21 UTC
Found it! I had 'Merged View' enabled. When I disable this option everything works as expected.
Comment 3 Myriam Schweingruber 2011-03-30 08:01:00 UTC
Thank you for the feedback.
Comment 4 Myriam Schweingruber 2011-03-30 08:02:40 UTC
Actually, this is still a bug, as it should also update in Merged View, changing title accordingly.
Comment 5 Ralf Engels 2011-06-01 17:54:04 UTC
The merged view relies on the proxy collection which does not implement some functionalities and tries to combine albums from several sources.

We will need some more time to clean this up.
Comment 6 Myriam Schweingruber 2011-06-04 12:24:21 UTC
Set status correctly.
Comment 7 Thinus Pollard 2012-10-14 07:41:31 UTC
This seems to be a problem that is still present in Amarok v2.6 (running on OpenSuse 12.2 64bit).

Current setup is an external MySQL database. It would seem that the database tables are updated when you edit the track details or use the organize files feature to rename songs, but the collection browser does not update to reflect those changes.

At some point in time the collection browser becomes confused and then displays only the top half.

What would be nice is a button (or action that can be bound to a keyboard shortcut) that manually refreshes the collection browser view (no, not a full/partial rescan of the files, just syncing of the collection browser view with back-end storage). In this way the issue can be fixed by the user while all the actions that updates information can be hunted down and fixed.
Comment 8 Myriam Schweingruber 2012-10-21 12:06:04 UTC
Thank you for the feedback, setting version correctly.
Comment 9 Matěj Laitl 2013-05-23 14:08:08 UTC
I think this may as well be the famous caching bug with Collection View, i.e. bug 262504, which doesn't happen every time, so the Merged view may be just a coincidence. On the other hand, it if well possible that the bug in in AggregateCollection (renamed from ProxyCollection) may not be correctly implemented.

There is an easy test for it: if you see collection browser not being consistent with your expectation, clear the playlist and drag the whole collection to the playlist. Study the tracks in the playlist - are they correctly updated? Removed files removed and added files added? If

a) yes (when dragged to playlist, the files look up-to-date) -> then this is a definitely another symptom of bug 262504.
b) no, tracks aren't updated even when dragged to playlist -> then this is a bug in particular collections not updating themselves correctly.

Someone who can reproduce this bug please perform the test. In case of a), please mark this as a duplicate of bug 262504.
Comment 10 Myriam Schweingruber 2013-07-21 23:33:02 UTC
Can't reproduce b), so this is most likely case a), but it is not reproducible with v2.7.90-53-gbf655f7

*** This bug has been marked as a duplicate of bug 262504 ***