Bug 275748 - knetworkmanager accesses kwallet without need
Summary: knetworkmanager accesses kwallet without need
Status: RESOLVED DUPLICATE of bug 274702
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-15 18:36 UTC by mattm3a
Modified: 2011-06-17 20:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mattm3a 2011-06-15 18:36:26 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

knetworkmanager requests access to kwallet to connect to unsecured wireless networks (network has no password). This is unnecessary. 

Reproducible: Always

Steps to Reproduce:
1) Disconnect from wireless network
2) Close kwallet connections to applications and close default wallet. 
3) Connect to unsecured wireless network

Actual Results:  
knetworkmanager attempts to open kwallet and prompts for kwallet password. 

Expected Results:  
knetworkmanager should connect to unsecured network without prompting for password.
Comment 1 Lamarque V. Souza 2011-06-15 20:48:53 UTC
Which Plasma NM version are using? if your package is named

*** This bug has been marked as a duplicate of bug 274702 ***
Comment 2 mattm3a 2011-06-16 21:36:07 UTC
It looks like my network manager version is 0.8.2.
Comment 3 Lamarque V. Souza 2011-06-16 21:49:19 UTC
I asked about the Plasma NetworkManagement version, it is called plasmoid-networkmanagemnet in OpenSuse. This problem has nothing to do with NetworkManager.
Comment 4 mattm3a 2011-06-17 16:56:00 UTC
Sorry, that was not clear. The plasmoid-networkmanagement package is not installed.
Comment 5 Lamarque V. Souza 2011-06-17 20:01:27 UTC
So you are using monolithic knetworkmanager, which is not maintained anymore. Please uninstall it and install plasmoid-networkmanagement using these instructions:

http://lists.opensuse.org/opensuse-kde/2011-05/msg00035.html