Bug 274702 - KWallet password is requested even for unencrypted WiFi
Summary: KWallet password is requested even for unencrypted WiFi
Status: RESOLVED FIXED
Alias: None
Product: Network Management
Classification: Unclassified
Component: Wireless (show other bugs)
Version: 0.9
Platform: openSUSE RPMs Linux
: NOR normal with 10 votes (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
: 275748 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-01 20:49 UTC by Rolf Eike Beer
Modified: 2011-07-30 23:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Eike Beer 2011-06-01 20:49:53 UTC
Version:           0.9 (using KDE 4.6.3) 
OS:                Linux

There are still unencrypted WiFis out there. If KNetworkmanager tries to attach to one it requests the KWallet password even if that is not necessary. Both entering the correct password as well as aborting the password entry will both lead to successful network attach.

Reproducible: Always
Comment 1 Lamarque V. Souza 2011-06-07 07:47:29 UTC
What you are saying is that the access point has a secret key, but you can connect with or without the secret key. But if there is a key stored in kwallet then Plasma NM should try it in my oppinion. It is not efficent first trying without the key and if that fails open the kwallet and try again with the key. Doing that would delay all connections to access points that do require a secret key.
Comment 2 Rolf Eike Beer 2011-06-07 09:15:55 UTC
> What you are saying is that the access point has a secret key, but you can
> connect with or without the secret key. But if there is a key stored in
> kwallet then Plasma NM should try it in my oppinion. It is not efficent
> first trying without the key and if that fails open the kwallet and try
> again with the key.
> Doing that would delay all connections to access points that do require a
> secret key.

No, what I say is that the AP has _no_ key at all and has never been but
NM still asks for the KWallet password. If there is a key stored (with
whatever content) it's probably NM's own fault as he stored it there.
Comment 3 Lamarque V. Souza 2011-06-07 23:46:06 UTC
Git commit b268b15d8797fbfcc1dd60e2b8b97aa1f38636a7 by Lamarque V. Souza.
Committed on 07/06/2011 at 23:26.
Pushed by lvsouza into branch 'master'.

Try to prevent opening kwallet when there is no secret to retrieve.

CCBUG: 274702

M  +10   -8    backends/NetworkManager/settings/802-11-wireless-securitydbus.cpp     
M  +4    -0    libs/internals/settings/802-11-wireless-security.h     
M  +0    -1    libs/ui/wirelesspreferences.h     

http://commits.kde.org/networkmanagement/b268b15d8797fbfcc1dd60e2b8b97aa1f38636a7
Comment 4 Lamarque V. Souza 2011-06-07 23:47:51 UTC
Ok, reopening the bug then. Please test the commit above. I do not have NM-0.8 installed anymore to test it. This problem seems not to happen with NM-0.9.
Comment 5 Lamarque V. Souza 2011-06-08 01:30:09 UTC
Git commit f5052080d0b4bedbbcd48ce8b8bfb7ad11a38160 by Lamarque V. Souza.
Committed on 08/06/2011 at 01:29.
Pushed by lvsouza into branch 'nm09'.

When deleting a connection do not open kwallet if it is not needed.

CCBUG: 275161
CCBUG: 274702

M  +4    -0    libs/service/secretstorage.cpp     

http://commits.kde.org/networkmanagement/f5052080d0b4bedbbcd48ce8b8bfb7ad11a38160
Comment 6 Lamarque V. Souza 2011-06-08 01:31:05 UTC
Git commit 026bd215749fba9d6f898ec7778543a0ca12aab1 by Lamarque V. Souza.
Committed on 08/06/2011 at 01:27.
Pushed by lvsouza into branch 'master'.

When deleting a connection do not open kwallet if it is not needed.

CCBUG: 275161
CCBUG: 274702

M  +6    -3    settings/config/manageconnectionwidget.cpp     

http://commits.kde.org/networkmanagement/026bd215749fba9d6f898ec7778543a0ca12aab1
Comment 7 Lamarque V. Souza 2011-06-15 20:48:53 UTC
*** Bug 275748 has been marked as a duplicate of this bug. ***
Comment 8 Lamarque V. Souza 2011-07-18 20:44:21 UTC
Is this still happening?
Comment 9 mattm3a 2011-07-27 15:38:44 UTC
Works for me.