Bug 274850 - Digikam crash on face scanning
Summary: Digikam crash on face scanning
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Faces-Engine (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-03 16:35 UTC by nola mike
Modified: 2019-12-23 06:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nola mike 2011-06-03 16:35:25 UTC
Application: digikam (2.0.0-beta6)
KDE Platform Version: 4.6.3 (4.6.3)
Qt Version: 4.7.2
Operating System: Linux 2.6.39-020639rc5-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

Scan collection for faces.  Seems like it only happens scanning certain albums.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4f339faa20 (LWP 2758))]

Thread 7 (Thread 0x7f4f10151700 (LWP 2759)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4f2c0c182b in wait (this=<value optimized out>, mutex=0x202f648, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x202f648, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000000005b64a8 in Digikam::ScanController::run (this=0x2059f10) at /build/buildd/digikam2-2.0.0~beta6/core/digikam/database/scancontroller.cpp:618
#4  0x00007f4f2c0c1175 in QThreadPrivate::start (arg=0x2059f10) at thread/qthread_unix.cpp:320
#5  0x00007f4f2ad98d8c in start_thread (arg=0x7f4f10151700) at pthread_create.c:304
#6  0x00007f4f2b09604d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f4f0f950700 (LWP 2760)):
#0  0x00007f4f2ad9cd83 in __pthread_mutex_unlock_usercnt (mutex=0x202bce8) at pthread_mutex_unlock.c:38
#1  __pthread_mutex_unlock (mutex=0x202bce8) at pthread_mutex_unlock.c:290
#2  0x00007f4f24fc6fef in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4f24fc7f9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f4f24fc8639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f4f2c1d3446 in QEventDispatcherGlib::processEvents (this=0x206fb70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f4f2c1a7882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f4f2c1a7abc in QEventLoop::exec (this=0x7f4f0f94fb30, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007f4f2c0be924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#9  0x00007f4f2c189c2f in QInotifyFileSystemWatcherEngine::run (this=0x204ed60) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f4f2c0c1175 in QThreadPrivate::start (arg=0x204ed60) at thread/qthread_unix.cpp:320
#11 0x00007f4f2ad98d8c in start_thread (arg=0x7f4f0f950700) at pthread_create.c:304
#12 0x00007f4f2b09604d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f4f0f14f700 (LWP 2763)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4f2c0c182b in wait (this=<value optimized out>, mutex=0x20561f8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x20561f8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f4f30523f77 in Digikam::ParkingThread::run (this=0x20561e0) at /build/buildd/digikam2-2.0.0~beta6/core/libs/threads/threadmanager.cpp:119
#4  0x00007f4f2c0c1175 in QThreadPrivate::start (arg=0x20561e0) at thread/qthread_unix.cpp:320
#5  0x00007f4f2ad98d8c in start_thread (arg=0x7f4f0f14f700) at pthread_create.c:304
#6  0x00007f4f2b09604d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f4f07fff700 (LWP 2764)):
#0  0x00007f4f2ad9cd87 in __pthread_mutex_unlock_usercnt (mutex=<value optimized out>) at pthread_mutex_unlock.c:41
#1  __pthread_mutex_unlock (mutex=<value optimized out>) at pthread_mutex_unlock.c:290
#2  0x00007f4f24fc7f19 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4f24fc8639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f4f2c1d3446 in QEventDispatcherGlib::processEvents (this=0x26523a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f4f2c1a7882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f4f2c1a7abc in QEventLoop::exec (this=0x7f4f07ffeb30, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f4f2c0be924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007f4f2c189c2f in QInotifyFileSystemWatcherEngine::run (this=0x26517e0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f4f2c0c1175 in QThreadPrivate::start (arg=0x26517e0) at thread/qthread_unix.cpp:320
#10 0x00007f4f2ad98d8c in start_thread (arg=0x7f4f07fff700) at pthread_create.c:304
#11 0x00007f4f2b09604d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f4efaad3700 (LWP 2773)):
#0  0x00007f4f2b088ed4 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:93
#1  0x00007f4f24fc8104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4f24fc8639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4f2c1d3446 in QEventDispatcherGlib::processEvents (this=0x30fd340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f4f2c1a7882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f4f2c1a7abc in QEventLoop::exec (this=0x7f4efaad2b00, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f4f3052361f in Digikam::WorkerObjectRunnable::run (this=0x53a7940) at /build/buildd/digikam2-2.0.0~beta6/core/libs/threads/threadmanager.cpp:196
#7  0x00007f4f2c0b6188 in QThreadPoolThread::run (this=0x35bf1a0) at concurrent/qthreadpool.cpp:106
#8  0x00007f4f2c0c1175 in QThreadPrivate::start (arg=0x35bf1a0) at thread/qthread_unix.cpp:320
#9  0x00007f4f2ad98d8c in start_thread (arg=0x7f4efaad3700) at pthread_create.c:304
#10 0x00007f4f2b09604d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4ef3b1b700 (LWP 2784)):
#0  0x00007f4f2c0a57a8 in pthread_once@plt () from /usr/lib/libQtCore.so.4
#1  0x00007f4f2c0c1236 in get_thread_data () at thread/qthread_unix.cpp:160
#2  QThreadData::current () at thread/qthread_unix.cpp:199
#3  0x00007f4f2c1d2e99 in postEventSourcePrepare (s=0x4817e80, timeout=0x7f4ef3b1a96c) at kernel/qeventdispatcher_glib.cpp:254
#4  0x00007f4f24fc70a2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f4f24fc7f9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f4f24fc8639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f4f2c1d3446 in QEventDispatcherGlib::processEvents (this=0x3f55da0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#8  0x00007f4f2c1a7882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#9  0x00007f4f2c1a7abc in QEventLoop::exec (this=0x7f4ef3b1ab00, flags=...) at kernel/qeventloop.cpp:201
#10 0x00007f4f3052361f in Digikam::WorkerObjectRunnable::run (this=0x52dcff0) at /build/buildd/digikam2-2.0.0~beta6/core/libs/threads/threadmanager.cpp:196
#11 0x00007f4f2c0b6188 in QThreadPoolThread::run (this=0x4aa0a40) at concurrent/qthreadpool.cpp:106
#12 0x00007f4f2c0c1175 in QThreadPrivate::start (arg=0x4aa0a40) at thread/qthread_unix.cpp:320
#13 0x00007f4f2ad98d8c in start_thread (arg=0x7f4ef3b1b700) at pthread_create.c:304
#14 0x00007f4f2b09604d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#15 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4f339faa20 (LWP 2758)):
[KCrash Handler]
#6  0x00007f4f319cf737 in KFaceIface::Image::toQImage() const () from /usr/lib/libkface.so.1
#7  0x0000000000504b54 in Digikam::BatchFaceDetector::slotShowOneDetected (this=0x54e6910, package=...) at /build/buildd/digikam2-2.0.0~beta6/core/utilities/batch/batchfacedetector.cpp:370
#8  0x00000000005059f1 in Digikam::BatchFaceDetector::qt_metacall (this=0x54e6910, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1c150560) at /build/buildd/digikam2-2.0.0~beta6/obj-x86_64-linux-gnu/core/digikam/batchfacedetector.moc:91
#9  0x00007f4f2c1bd5f8 in QMetaObject::activate (sender=0x4ea5b90, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff1c150560) at kernel/qobject.cpp:3287
#10 0x0000000000677400 in Digikam::FacePipeline::processed (this=<value optimized out>, _t1=<value optimized out>) at /build/buildd/digikam2-2.0.0~beta6/obj-x86_64-linux-gnu/core/digikam/facepipeline.moc:155
#11 0x000000000067fdac in Digikam::FacePipeline::FacePipelinePriv::finishProcess (this=0x52de980, package=...) at /build/buildd/digikam2-2.0.0~beta6/core/utilities/facedetection/facepipeline.cpp:956
#12 0x0000000000680252 in Digikam::FacePipeline::FacePipelinePriv::qt_metacall (this=0x52de980, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x4f4a120) at /build/buildd/digikam2-2.0.0~beta6/obj-x86_64-linux-gnu/core/digikam/facepipeline_p.moc:668
#13 0x00007f4f2c1bc49a in QObject::event (this=0x52de980, e=<value optimized out>) at kernel/qobject.cpp:1226
#14 0x00007f4f2cdbf9e4 in QApplicationPrivate::notify_helper (this=0x1f47410, receiver=0x52de980, e=0x37b7a30) at kernel/qapplication.cpp:4462
#15 0x00007f4f2cdc43aa in QApplication::notify (this=<value optimized out>, receiver=0x52de980, e=0x37b7a30) at kernel/qapplication.cpp:4341
#16 0x00007f4f2dadf196 in KApplication::notify (this=0x7fff1c1510d0, receiver=0x52de980, event=0x37b7a30) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x00007f4f2c1a849c in QCoreApplication::notifyInternal (this=0x7fff1c1510d0, receiver=0x52de980, event=0x37b7a30) at kernel/qcoreapplication.cpp:731
#18 0x00007f4f2c1abc25 in sendEvent (receiver=0x0, event_type=0, data=0x1ec2e50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1ec2e50) at kernel/qcoreapplication.cpp:1372
#20 0x00007f4f2c1d3253 in sendPostedEvents (s=0x1f499c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=0x1f499c0) at kernel/qeventdispatcher_glib.cpp:277
#22 0x00007f4f24fc7bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f4f24fc83a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f4f24fc8639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f4f2c1d33ef in QEventDispatcherGlib::processEvents (this=0x1ec25f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#26 0x00007f4f2ce66dfe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f4f2c1a7882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007f4f2c1a7abc in QEventLoop::exec (this=0x7fff1c150f20, flags=...) at kernel/qeventloop.cpp:201
#29 0x00007f4f2c1abecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#30 0x000000000068ae34 in main (argc=5, argv=0x7fff1c151928) at /build/buildd/digikam2-2.0.0~beta6/core/digikam/main/main.cpp:232

This bug may be a duplicate of or related to bug 274660.

Possible duplicates by query: bug 274727, bug 274660.

Reported using DrKonqi
Comment 1 caulier.gilles 2011-06-05 21:04:48 UTC

*** This bug has been marked as a duplicate of bug 274660 ***
Comment 2 caulier.gilles 2019-12-23 06:22:01 UTC
Problem is fixed with new 7.0.0-beta1 through this long story from this bug

https://bugs.kde.org/show_bug.cgi?id=399923

You can test digiKam 7.0.0-beta1 with bundle available here:

https://download.kde.org/unstable/digikam/

Don't hesitate to give us a fresh feedback about his entry.

Thanks in advance

Gilles Caulier