Bug 274727 - crash on scan of faces
Summary: crash on scan of faces
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Faces-Engine (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-02 08:59 UTC by Ed
Modified: 2019-12-23 06:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed 2011-06-02 08:59:02 UTC
Application: digikam (2.0.0-beta6)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
I requested to scan the existing faces to identify potential matches.  Settings where set at 100% accuracy and to use all cpus (1 quad core). 

- Unusual behavior I noticed:
works most of the time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff04f0e7a20 (LWP 3487))]

Thread 7 (Thread 0x7ff02bbcd700 (LWP 3490)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ff0477a782b in wait (this=<value optimized out>, mutex=0x1889ab8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1889ab8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000000005b64a8 in Digikam::ScanController::run (this=0x18a4420) at /build/buildd/digikam2-2.0.0~beta6/core/digikam/database/scancontroller.cpp:618
#4  0x00007ff0477a7175 in QThreadPrivate::start (arg=0x18a4420) at thread/qthread_unix.cpp:320
#5  0x00007ff04647ed8c in start_thread (arg=0x7ff02bbcd700) at pthread_create.c:304
#6  0x00007ff04677c04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7ff02b3cc700 (LWP 3491)):
#0  postEventSourcePrepare (s=0x18be760, timeout=0x7ff02b3cb9ac) at kernel/qeventdispatcher_glib.cpp:253
#1  0x00007ff0406ad0a2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff0406adf9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff0406ae639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ff0478b9446 in QEventDispatcherGlib::processEvents (this=0x1831100, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007ff04788d882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007ff04788dabc in QEventLoop::exec (this=0x7ff02b3cbb30, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007ff0477a4924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007ff04786fc2f in QInotifyFileSystemWatcherEngine::run (this=0x18c43e0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007ff0477a7175 in QThreadPrivate::start (arg=0x18c43e0) at thread/qthread_unix.cpp:320
#10 0x00007ff04647ed8c in start_thread (arg=0x7ff02b3cc700) at pthread_create.c:304
#11 0x00007ff04677c04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7ff02abcb700 (LWP 3496)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ff0477a782b in wait (this=<value optimized out>, mutex=0x1bd9f98, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1bd9f98, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007ff04bc08f77 in Digikam::ParkingThread::run (this=0x1bd9f80) at /build/buildd/digikam2-2.0.0~beta6/core/libs/threads/threadmanager.cpp:119
#4  0x00007ff0477a7175 in QThreadPrivate::start (arg=0x1bd9f80) at thread/qthread_unix.cpp:320
#5  0x00007ff04647ed8c in start_thread (arg=0x7ff02abcb700) at pthread_create.c:304
#6  0x00007ff04677c04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7ff029dac700 (LWP 3497)):
#0  0x00007ff0464813c4 in __pthread_mutex_lock (mutex=0x7ff024047ec8) at pthread_mutex_lock.c:61
#1  0x00007ff0406ad87f in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff0406ae122 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff0406ae639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ff0478b9446 in QEventDispatcherGlib::processEvents (this=0x1d2b470, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007ff04788d882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007ff04788dabc in QEventLoop::exec (this=0x7ff029dabb30, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007ff0477a4924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007ff04786fc2f in QInotifyFileSystemWatcherEngine::run (this=0x1d2a930) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007ff0477a7175 in QThreadPrivate::start (arg=0x1d2a930) at thread/qthread_unix.cpp:320
#10 0x00007ff04647ed8c in start_thread (arg=0x7ff029dac700) at pthread_create.c:304
#11 0x00007ff04677c04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ff0162b9700 (LWP 15607)):
#0  0x00007ff04676ef03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff0406ae104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff0406ae639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff0478b9446 in QEventDispatcherGlib::processEvents (this=0x4fba5e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff04788d882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff04788dabc in QEventLoop::exec (this=0x7ff0162b8b00, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff04bc0861f in Digikam::WorkerObjectRunnable::run (this=0x2e2fe70) at /build/buildd/digikam2-2.0.0~beta6/core/libs/threads/threadmanager.cpp:196
#7  0x00007ff04779c188 in QThreadPoolThread::run (this=0x4d2f170) at concurrent/qthreadpool.cpp:106
#8  0x00007ff0477a7175 in QThreadPrivate::start (arg=0x4d2f170) at thread/qthread_unix.cpp:320
#9  0x00007ff04647ed8c in start_thread (arg=0x7ff0162b9700) at pthread_create.c:304
#10 0x00007ff04677c04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff01b744700 (LWP 15608)):
#0  0x00007ff04676ef03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff0406ae104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff0406ae639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff0478b9446 in QEventDispatcherGlib::processEvents (this=0x3536260, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff04788d882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff04788dabc in QEventLoop::exec (this=0x7ff01b743b00, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff04bc0861f in Digikam::WorkerObjectRunnable::run (this=0x43a2330) at /build/buildd/digikam2-2.0.0~beta6/core/libs/threads/threadmanager.cpp:196
#7  0x00007ff04779c188 in QThreadPoolThread::run (this=0x34bbec0) at concurrent/qthreadpool.cpp:106
#8  0x00007ff0477a7175 in QThreadPrivate::start (arg=0x34bbec0) at thread/qthread_unix.cpp:320
#9  0x00007ff04647ed8c in start_thread (arg=0x7ff01b744700) at pthread_create.c:304
#10 0x00007ff04677c04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff04f0e7a20 (LWP 3487)):
[KCrash Handler]
#6  0x00007ff04d0b4737 in KFaceIface::Image::toQImage() const () from /usr/lib/libkface.so.1
#7  0x0000000000504b54 in Digikam::BatchFaceDetector::slotShowOneDetected (this=0x6f7f4b0, package=...) at /build/buildd/digikam2-2.0.0~beta6/core/utilities/batch/batchfacedetector.cpp:370
#8  0x00000000005059f1 in Digikam::BatchFaceDetector::qt_metacall (this=0x6f7f4b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff5c145ce0) at /build/buildd/digikam2-2.0.0~beta6/obj-x86_64-linux-gnu/core/digikam/batchfacedetector.moc:91
#9  0x00007ff0478a35f8 in QMetaObject::activate (sender=0x45b3eb0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff5c145ce0) at kernel/qobject.cpp:3287
#10 0x0000000000677400 in Digikam::FacePipeline::processed (this=<value optimized out>, _t1=<value optimized out>) at /build/buildd/digikam2-2.0.0~beta6/obj-x86_64-linux-gnu/core/digikam/facepipeline.moc:155
#11 0x000000000067fdac in Digikam::FacePipeline::FacePipelinePriv::finishProcess (this=0x6099b70, package=...) at /build/buildd/digikam2-2.0.0~beta6/core/utilities/facedetection/facepipeline.cpp:956
#12 0x0000000000680252 in Digikam::FacePipeline::FacePipelinePriv::qt_metacall (this=0x6099b70, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x4f49520) at /build/buildd/digikam2-2.0.0~beta6/obj-x86_64-linux-gnu/core/digikam/facepipeline_p.moc:668
#13 0x00007ff0478a249a in QObject::event (this=0x6099b70, e=<value optimized out>) at kernel/qobject.cpp:1226
#14 0x00007ff0484a59e4 in QApplicationPrivate::notify_helper (this=0x17c5070, receiver=0x6099b70, e=0x5d9dbd0) at kernel/qapplication.cpp:4462
#15 0x00007ff0484aa3aa in QApplication::notify (this=<value optimized out>, receiver=0x6099b70, e=0x5d9dbd0) at kernel/qapplication.cpp:4341
#16 0x00007ff0491c4866 in KApplication::notify (this=0x7fff5c146850, receiver=0x6099b70, event=0x5d9dbd0) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x00007ff04788e49c in QCoreApplication::notifyInternal (this=0x7fff5c146850, receiver=0x6099b70, event=0x5d9dbd0) at kernel/qcoreapplication.cpp:731
#18 0x00007ff047891c25 in sendEvent (receiver=0x0, event_type=0, data=0x1740170) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1740170) at kernel/qcoreapplication.cpp:1372
#20 0x00007ff0478b9253 in sendPostedEvents (s=0x17c79c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=0x17c79c0) at kernel/qeventdispatcher_glib.cpp:277
#22 0x00007ff0406adbcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007ff0406ae3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007ff0406ae639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007ff0478b93ef in QEventDispatcherGlib::processEvents (this=0x173f910, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#26 0x00007ff04854cdfe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007ff04788d882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007ff04788dabc in QEventLoop::exec (this=0x7fff5c1466a0, flags=...) at kernel/qeventloop.cpp:201
#29 0x00007ff047891ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#30 0x000000000068ae34 in main (argc=5, argv=0x7fff5c1470a8) at /build/buildd/digikam2-2.0.0~beta6/core/digikam/main/main.cpp:232

This bug may be a duplicate of or related to bug 274660.

Possible duplicates by query: bug 274660.

Reported using DrKonqi
Comment 1 Ed 2011-06-02 10:11:09 UTC

*** This bug has been marked as a duplicate of bug 274660 ***
Comment 2 caulier.gilles 2019-12-23 06:22:05 UTC
Problem is fixed with new 7.0.0-beta1 through this long story from this bug

https://bugs.kde.org/show_bug.cgi?id=399923

You can test digiKam 7.0.0-beta1 with bundle available here:

https://download.kde.org/unstable/digikam/

Don't hesitate to give us a fresh feedback about his entry.

Thanks in advance

Gilles Caulier