Bug 274177 - maximized windows have shadow
Summary: maximized windows have shadow
Status: RESOLVED FIXED
Alias: None
Product: Oxygen
Classification: Unclassified
Component: win deco (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
: 274470 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-26 10:23 UTC by Antonio Rojas
Modified: 2011-05-31 17:33 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
unmaximized window (75.37 KB, image/png)
2011-05-27 18:15 UTC, Antonio Rojas
Details
maximized window (37.11 KB, image/png)
2011-05-27 18:16 UTC, Antonio Rojas
Details
full desktop (227.15 KB, image/png)
2011-05-27 19:21 UTC, Antonio Rojas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Rojas 2011-05-26 10:23:11 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Using KDE 4.7 beta 1.
Shadows of maximized windows are visible behind the panel. This doesn't look good, maximized windows shouldn't have shadows.

Reproducible: Always
Comment 1 Martin Flöser 2011-05-27 16:13:30 UTC
Could you please provide a screenshot? My windows don't do that.
Comment 2 Antonio Rojas 2011-05-27 18:15:29 UTC
Created attachment 60390 [details]
unmaximized window
Comment 3 Antonio Rojas 2011-05-27 18:16:27 UTC
Created attachment 60391 [details]
maximized window

notice the red glow visible behind the panel
Comment 4 Martin Flöser 2011-05-27 18:54:15 UTC
which window decoration are you using? Could you please provide a screenshot of the complete desktop, that would help to identify anything "strange".
Comment 5 Antonio Rojas 2011-05-27 19:21:18 UTC
Created attachment 60399 [details]
full desktop

I'm using oxygen (with ridiculously large shadows to make the bug more obvious)
Comment 6 Thomas Lübking 2011-05-30 00:54:06 UTC
*** Bug 274470 has been marked as a duplicate of this bug. ***
Comment 7 Hugo Pereira Da Costa 2011-05-30 00:56:58 UTC
@Martin
Should this be dealt with by Oxygen, or by KWin ? 
(I would have expected kwin, since oxygen would need to change its metrics etc. on maximize state in order not to do that) ... 

And if kwin ? Then should be re-assigned, I guess ...
Comment 8 Martin Flöser 2011-05-30 16:44:41 UTC
I am not sure whether this can be handled in kwin correctly. Sure we can ignore the padding for maximized windows but it could look strange. I think it makes more sense to adjust the decorations to have 0 padding and adjusted rendering.
Comment 9 Hugo Pereira Da Costa 2011-05-30 16:50:18 UTC
Martin, 
I actually was thinking that the easiest is just ... Keep padding, etc. unchanged, and well, not to paint the shadow when the client is maximized.
Makes sense ? 
If you agree, I'll push and close.
Comment 10 Martin Flöser 2011-05-30 17:16:47 UTC
if possible try to adjust the padding calculations as having it just translucent means that we have 
to render more
Comment 11 Hugo Pereira Da Costa 2011-05-30 17:58:09 UTC
Git commit 6c2d50208a62bd070df06b3c7cfe95c75d6dd74e by Hugo Pereira Da Costa.
Committed on 30/05/2011 at 16:51.
Pushed by hpereiradacosta into branch 'master'.

do not render shadows when maximized.
CCBUG: 274177

M  +1    -1    kwin/clients/oxygen/oxygenclient.cpp     

http://commits.kde.org/kde-workspace/6c2d50208a62bd070df06b3c7cfe95c75d6dd74e
Comment 12 Hugo Pereira Da Costa 2011-05-30 17:58:09 UTC
Git commit 91d35f36372671d38d558a48df914adc87d134ab by Hugo Pereira Da Costa.
Committed on 30/05/2011 at 17:56.
Pushed by hpereiradacosta into branch 'master'.

Set padding to 0 when client is maximized.
CCBUG: 274177

M  +2    -1    kwin/clients/oxygen/oxygenclient.cpp     

http://commits.kde.org/kde-workspace/91d35f36372671d38d558a48df914adc87d134ab
Comment 13 Hugo Pereira Da Costa 2011-05-31 17:33:19 UTC
Commits above fix it. 
So closing.