Bug 273926 - KGPG don't support unicode in editor mode
Summary: KGPG don't support unicode in editor mode
Status: RESOLVED DUPLICATE of bug 269501
Alias: None
Product: kgpg
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR major with 10 votes (vote)
Target Milestone: ---
Assignee: Rolf Eike Beer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-23 01:46 UTC by Vadim A. Misbakh-Soloviov (mva)
Modified: 2011-05-23 09:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vadim A. Misbakh-Soloviov (mva) 2011-05-23 01:46:12 UTC
Version:           unspecified (using KDE 4.6.3) 
OS:                Linux

When I try to encrypt any unicode characters in editor mode ("file->open editor"), they all become an "?" symbols.
Moreover, I try to encrypt different unicode symbols few times, but I get identical hashes with any of them. In other way, when i try the same in terminal:
echo '<some unicode symbols>'|gpg --no-secmem-warning --no-tty --debug-level none --status-fd=1 --command-fd=0 --armor -e --recipient <MYKEY>|gpg --decrypt
All goes fine (without converting unicode chars to "?".

Reproducible: Always

Steps to Reproduce:
1. Run KGPG.
2. Press "File" menu. Then press "Open editor" item.
3. Type some unicode (possibly, not-ascii at all) text.
4. Press "Encrypt".
5. Select your open key.
6. Copy result and try to decrypt it (anywhere).
7. You wil see "?" symbols instead of unicode symbols.

Actual Results:  
I see "?" symbols.

Expected Results:  
I should see unicode text.
Comment 1 Rolf Eike Beer 2011-05-23 09:20:15 UTC

*** This bug has been marked as a duplicate of bug 269501 ***