Bug 269501 - Text decryption fails on extended characters
Summary: Text decryption fails on extended characters
Status: RESOLVED FIXED
Alias: None
Product: kgpg
Classification: Unclassified
Component: general (show other bugs)
Version: 1.0
Platform: openSUSE RPMs Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Rolf Eike Beer
URL:
Keywords:
: 273926 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-27 00:13 UTC by Christopher Yeleighton
Modified: 2012-03-07 19:13 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Yeleighton 2011-03-27 00:13:38 UTC
Version:           1.0 (using KDE 4.6.0) 
OS:                Linux

Text decryption in KGPG editor window fails on extended characters

Reproducible: Always

Steps to Reproduce:
  1. Tell KGPG to encrypt text "Zażółć gęślą jaźń" in the editor.
  2. Tell KGPG to decrypt the editor.

Actual Results:  
  2. Za?�?? g??l? ja??[GNUPG:] DECRYPTION_OKAY

Expected Results:  
  2. Zażółć gęślą jaźń

OS: Linux (x86_64) release 2.6.37.1-1.2-desktop
Compiler: gcc
Comment 1 Burkhard Lück 2011-05-06 08:54:43 UTC
Confirmed with Version 2.5.0 KDE 4.6.3 compiled from sources
Comment 2 Rolf Eike Beer 2011-05-06 17:04:52 UTC
SVN commit 1230717 by dakon:

don't destroy 8bit characters when encrypting text

CCBUG:269501

 M  +2 -2      kgpgtextinterface.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1230717
Comment 3 Rolf Eike Beer 2011-05-06 17:05:58 UTC
It would be helpful if anyone with a non-UTF8 locale could test if that works there too.
Comment 4 Rolf Eike Beer 2011-05-23 09:20:15 UTC
*** Bug 273926 has been marked as a duplicate of this bug. ***
Comment 5 Rolf Eike Beer 2012-03-07 19:13:18 UTC
Seems all good meanwhile.