Bug 273611 - problemas con kopete
Summary: problemas con kopete
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-19 06:17 UTC by marcos
Modified: 2011-05-19 21:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marcos 2011-05-19 06:17:53 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
el escritorio de kde se cae al cerrar sesion con kopete usando  servisio messenger aun asi no provoca cuelgue del sistema

-- Backtrace:
Application: Shell de escritorio Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7780ad0 (LWP 1476))]

Thread 3 (Thread 0xb0137b70 (LWP 1477)):
#0  0x050003c0 in pthread_getspecific () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x0097ed75 in ?? () from /usr/lib/i386-linux-gnu/libgthread-2.0.so.0
#2  0x0230a482 in g_thread_self () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x022de572 in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x022dfdde in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x022e0524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0x01c2f577 in QEventDispatcherGlib::processEvents (this=0x854e038, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#7  0x01c01289 in QEventLoop::processEvents (this=0xb0137280, flags=...) at kernel/qeventloop.cpp:149
#8  0x01c01522 in QEventLoop::exec (this=0xb0137280, flags=...) at kernel/qeventloop.cpp:201
#9  0x01b0b2a0 in QThread::exec (this=0x854b5c8) at thread/qthread.cpp:492
#10 0x01be2fdb in QInotifyFileSystemWatcherEngine::run (this=0x854b5c8) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x01b0dda2 in QThreadPrivate::start (arg=0x854b5c8) at thread/qthread_unix.cpp:320
#12 0x04ffae99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0x004c673e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xadebeb70 (LWP 1531)):
#0  0x00e4d416 in __kernel_vsyscall ()
#1  0x004b7f76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x022f084b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x022e01af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x022e0524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x01c2f577 in QEventDispatcherGlib::processEvents (this=0x81b1148, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x01c01289 in QEventLoop::processEvents (this=0xadebe280, flags=...) at kernel/qeventloop.cpp:149
#7  0x01c01522 in QEventLoop::exec (this=0xadebe280, flags=...) at kernel/qeventloop.cpp:201
#8  0x01b0b2a0 in QThread::exec (this=0x886c6a0) at thread/qthread.cpp:492
#9  0x01be2fdb in QInotifyFileSystemWatcherEngine::run (this=0x886c6a0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01b0dda2 in QThreadPrivate::start (arg=0x886c6a0) at thread/qthread_unix.cpp:320
#11 0x04ffae99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x004c673e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7780ad0 (LWP 1476)):
[KCrash Handler]
#7  0x00fd0454 in QString (this=0x8e40061, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#8  KIconEffect::fingerprint (this=0x8e40061, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0x00fd6352 in KIconLoaderPrivate::makeCacheKey (this=0x8e4004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0x00fdd398 in KIconLoader::loadIcon (this=0x92bcc88, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0x00fd4d76 in KIconEngine::pixmap (this=0x918b070, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x071e7ca2 in QIcon::pixmap (this=0x91fb04c, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0x002aa969 in Plasma::IconWidgetPrivate::decoration (this=0x91fafa8, option=0x8136c20, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#14 0x002b121d in Plasma::IconWidget::paint (this=0x92d4400, painter=0xbfe0feac, option=0x8136c20, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1128
#15 0x07f940dd in SystemTray::DBusSystemTrayWidget::paint (this=0x92d4400, painter=0xbfe0feac, option=0x8136c20, widget=0x0) at ../../../../../plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#16 0x077909ec in _q_paintItem (item=<value optimized out>, painter=0xbfe0feac, option=0x8136c20, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#17 0x07790cf2 in _q_paintIntoCache (pix=0xbfe1037c, item=0x92d4408, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x8136c20, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#18 0x077a4a00 in QGraphicsScenePrivate::drawItemHelper (this=0x8136ad0, item=0x92d4408, painter=0xbfe11b64, option=0x8136c20, widget=0x8936a10, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#19 0x077a56c2 in QGraphicsScenePrivate::draw (this=0x8136ad0, item=0x92d4408, painter=0xbfe11b64, viewTransform=0xbfe1194c, transformPtr=0xbfe10760, exposedRegion=0x8bc9118, widget=0x8936a10, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#20 0x077a6402 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8136ad0, item=0x92d4408, painter=0xbfe11b64, viewTransform=0xbfe1194c, exposedRegion=0x8bc9118, widget=0x8936a10, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#21 0x077a54ec in QGraphicsScenePrivate::draw (this=0x8136ad0, item=0x82b58f0, painter=0xbfe11b64, viewTransform=0xbfe1194c, transformPtr=0xbfe10c00, exposedRegion=0x8bc9118, widget=0x8936a10, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#22 0x077a6402 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8136ad0, item=0x82b58f0, painter=0xbfe11b64, viewTransform=0xbfe1194c, exposedRegion=0x8bc9118, widget=0x8936a10, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#23 0x077a54ec in QGraphicsScenePrivate::draw (this=0x8136ad0, item=0x831bba8, painter=0xbfe11b64, viewTransform=0xbfe1194c, transformPtr=0xbfe110a0, exposedRegion=0x8bc9118, widget=0x8936a10, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#24 0x077a6402 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8136ad0, item=0x831bba8, painter=0xbfe11b64, viewTransform=0xbfe1194c, exposedRegion=0x8bc9118, widget=0x8936a10, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#25 0x077a54ec in QGraphicsScenePrivate::draw (this=0x8136ad0, item=0x81ace90, painter=0xbfe11b64, viewTransform=0xbfe1194c, transformPtr=0xbfe11540, exposedRegion=0x8bc9118, widget=0x8936a10, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#26 0x077a6402 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8136ad0, item=0x81ace90, painter=0xbfe11b64, viewTransform=0xbfe1194c, exposedRegion=0x8bc9118, widget=0x8936a10, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#27 0x077a6c06 in QGraphicsScenePrivate::drawItems (this=0x8136ad0, painter=0xbfe11b64, viewTransform=0xbfe1194c, exposedRegion=0x8bc9118, widget=0x8936a10) at graphicsview/qgraphicsscene.cpp:4735
#28 0x077c5ea1 in QGraphicsView::paintEvent (this=0x8c396d8, event=0xbfe12274) at graphicsview/qgraphicsview.cpp:3469
#29 0x00a2f484 in PanelView::paintEvent (this=0x8c396d8, event=0xbfe12274) at ../../../../plasma/desktop/shell/panelview.cpp:1593
#30 0x0718a18e in QWidget::event (this=0x8c396d8, event=0xbfe12274) at kernel/qwidget.cpp:8405
#31 0x0757bf63 in QFrame::event (this=0x8c396d8, e=0xbfe12274) at widgets/qframe.cpp:557
#32 0x0760a5d2 in QAbstractScrollArea::viewportEvent (this=0x8c396d8, e=0xbfe12274) at widgets/qabstractscrollarea.cpp:1043
#33 0x077c736f in QGraphicsView::viewportEvent (this=0x8c396d8, event=0xbfe12274) at graphicsview/qgraphicsview.cpp:2864
#34 0x0760ced5 in viewportEvent (this=0x8b44a30, o=0x8936a10, e=0xbfe12274) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x8b44a30, o=0x8936a10, e=0xbfe12274) at widgets/qabstractscrollarea_p.h:116
#36 0x01c0225a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x80e42f0, receiver=0x8936a10, event=0xbfe12274) at kernel/qcoreapplication.cpp:846
#37 0x07131d00 in QApplicationPrivate::notify_helper (this=0x80e42f0, receiver=0x8936a10, e=0xbfe12274) at kernel/qapplication.cpp:4458
#38 0x0713697b in QApplication::notify (this=0x80d97f8, receiver=0x8936a10, e=0xbfe12274) at kernel/qapplication.cpp:4427
#39 0x0102f3ca in KApplication::notify (this=0x80d97f8, receiver=0x8936a10, event=0xbfe12274) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x01c020bb in QCoreApplication::notifyInternal (this=0x80d97f8, receiver=0x8936a10, event=0xbfe12274) at kernel/qcoreapplication.cpp:731
#41 0x07186f0c in sendSpontaneousEvent (this=0x88b1938, pdev=0x8ba81d4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a455d8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x88b1938, pdev=0x8ba81d4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a455d8) at kernel/qwidget.cpp:5492
#43 0x07187b7c in QWidgetPrivate::paintSiblingsRecursive (this=0x8bc8dc8, pdev=0x8ba81d4, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a455d8) at kernel/qwidget.cpp:5699
#44 0x07186c80 in QWidgetPrivate::drawWidget (this=0x8bc8dc8, pdev=0x8ba81d4, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x8a455d8) at kernel/qwidget.cpp:5545
#45 0x07362908 in QWidgetBackingStore::sync (this=0x8a455d8) at painting/qbackingstore.cpp:1333
#46 0x0717c843 in QWidgetPrivate::syncBackingStore (this=0x8bc8dc8) at kernel/qwidget.cpp:1842
#47 0x0718a7e5 in QWidget::event (this=0x8c396d8, event=0x92bcc88) at kernel/qwidget.cpp:8552
#48 0x0757bf63 in QFrame::event (this=0x8c396d8, e=0x92bcc88) at widgets/qframe.cpp:557
#49 0x0760c33f in QAbstractScrollArea::event (this=0x8c396d8, e=0x92bcc88) at widgets/qabstractscrollarea.cpp:996
#50 0x077ba686 in QGraphicsView::event (this=0x8c396d8, event=0x92bcc88) at graphicsview/qgraphicsview.cpp:2741
#51 0x00a2f7c3 in PanelView::event (this=0x8c396d8, event=0x92bcc88) at ../../../../plasma/desktop/shell/panelview.cpp:1604
#52 0x07131d24 in QApplicationPrivate::notify_helper (this=0x80e42f0, receiver=0x8c396d8, e=0x92bcc88) at kernel/qapplication.cpp:4462
#53 0x0713697b in QApplication::notify (this=0x80d97f8, receiver=0x8c396d8, e=0x92bcc88) at kernel/qapplication.cpp:4427
#54 0x0102f3ca in KApplication::notify (this=0x80d97f8, receiver=0x8c396d8, event=0x92bcc88) at ../../kdeui/kernel/kapplication.cpp:311
#55 0x01c020bb in QCoreApplication::notifyInternal (this=0x80d97f8, receiver=0x8c396d8, event=0x92bcc88) at kernel/qcoreapplication.cpp:731
#56 0x01c05c79 in sendEvent (receiver=0x8c396d8, event_type=77, data=0x80867e8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#57 QCoreApplicationPrivate::sendPostedEvents (receiver=0x8c396d8, event_type=77, data=0x80867e8) at kernel/qcoreapplication.cpp:1372
#58 0x01c05e0d in QCoreApplication::sendPostedEvents (receiver=0x8c396d8, event_type=77) at kernel/qcoreapplication.cpp:1265
#59 0x0779d1b6 in dispatchPendingUpdateRequests (this=0x8136ad0) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#60 QGraphicsScenePrivate::_q_processDirtyItems (this=0x8136ad0) at graphicsview/qgraphicsscene.cpp:510
#61 0x0779d596 in QGraphicsScene::qt_metacall (this=0x81836e8, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x9414a10) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#62 0x001eda9a in Plasma::Corona::qt_metacall (this=0x81836e8, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x9414a10) at ./corona.moc:109
#63 0x00a2220a in DesktopCorona::qt_metacall (this=0x81836e8, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x9414a10) at ./desktopcorona.moc:101
#64 0x01c086ba in QMetaObject::metacall (object=0x81836e8, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x9414a10) at kernel/qmetaobject.cpp:237
#65 0x01c12e16 in QMetaCallEvent::placeMetaCall (this=0x8ad4cf8, object=0x81836e8) at kernel/qobject.cpp:535
#66 0x01c173b7 in QObject::event (this=0x81836e8, e=0x8ad4cf8) at kernel/qobject.cpp:1226
#67 0x077aa3b4 in QGraphicsScene::event (this=0x81836e8, event=0x8ad4cf8) at graphicsview/qgraphicsscene.cpp:3544
#68 0x07131d24 in QApplicationPrivate::notify_helper (this=0x80e42f0, receiver=0x81836e8, e=0x8ad4cf8) at kernel/qapplication.cpp:4462
#69 0x071368ce in QApplication::notify (this=0x80d97f8, receiver=0x81836e8, e=0x8ad4cf8) at kernel/qapplication.cpp:3862
#70 0x0102f3ca in KApplication::notify (this=0x80d97f8, receiver=0x81836e8, event=0x8ad4cf8) at ../../kdeui/kernel/kapplication.cpp:311
#71 0x01c020bb in QCoreApplication::notifyInternal (this=0x80d97f8, receiver=0x81836e8, event=0x8ad4cf8) at kernel/qcoreapplication.cpp:731
#72 0x01c05c79 in sendEvent (receiver=0x0, event_type=0, data=0x80867e8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#73 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80867e8) at kernel/qcoreapplication.cpp:1372
#74 0x01c05e0d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#75 0x01c2f3c4 in sendPostedEvents (s=0x8086300) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#76 postEventSourceDispatch (s=0x8086300) at kernel/qeventdispatcher_glib.cpp:277
#77 0x022dfaa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#78 0x022e0270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#79 0x022e0524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#80 0x01c2f53c in QEventDispatcherGlib::processEvents (this=0x80e4038, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#81 0x071e5775 in QGuiEventDispatcherGlib::processEvents (this=0x80e4038, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#82 0x01c01289 in QEventLoop::processEvents (this=0xbfe13a64, flags=...) at kernel/qeventloop.cpp:149
#83 0x01c01522 in QEventLoop::exec (this=0xbfe13a64, flags=...) at kernel/qeventloop.cpp:201
#84 0x01c05ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#85 0x0712f8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#86 0x00a295a5 in kdemain (argc=1, argv=0xbfe13c74) at ../../../../plasma/desktop/shell/main.cpp:118
#87 0x080485cb in main (argc=1, argv=0xbfe13c74) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 273593, bug 273578, bug 273499, bug 273383, bug 273373.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-05-19 21:34:58 UTC

*** This bug has been marked as a duplicate of bug 258706 ***