Bug 273578 - Plasma crash after killing amarok.
Summary: Plasma crash after killing amarok.
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-18 20:42 UTC by djod4556
Modified: 2011-05-20 09:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description djod4556 2011-05-18 20:42:29 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
I was watching a movie with VLC, using internet with Firefox and working with Vi into Konsole.
- Unusual behavior I noticed:
I was listening music with amarok then I close it. It's icon still remain in the notification plasmoide. So I decided to kill amarok with pkill -9 amarok. Then Plasma crashed. When it re-opens, the amarok icons disapeared.

-- Backtrace:
Application: Outil de gestion de fenêtres Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7a7df697c0 (LWP 2702))]

Thread 4 (Thread 0x7f7a5f4fe700 (LWP 2705)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f7a5f4fd9e0 in ?? ()
#2  0x00007fff4bb597b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 3 (Thread 0x7f7a52f86700 (LWP 2707)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f7a52f859e0 in ?? ()
#2  0x00007fff4bb597b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f7a5053c700 (LWP 2712)):
#0  0x00007f7a72b483ce in __pthread_mutex_lock (mutex=0x2e6cb08) at pthread_mutex_lock.c:62
#1  0x00007f7a72241461 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7a7224200a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7a722429f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7a51653c44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#5  0x00007f7a722693e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f7a702c7853 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#7  0x00007f7a72b45d8c in start_thread (arg=0x7f7a5053c700) at pthread_create.c:304
#8  0x00007f7a7d86d04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7a7df697c0 (LWP 2702)):
[KCrash Handler]
#6  0x00007f7a7b6a25df in QString (this=0x4940075, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x4940075, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007f7a7b6a7feb in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007f7a7b6aed03 in KIconLoader::loadIcon (this=0x2749630, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007f7a7b6a6c99 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
#11 0x00007f7a79eaddd5 in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:676
#12 0x00007f7a7d44f099 in Plasma::IconWidgetPrivate::decoration (this=0x4789960, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#13 0x00007f7a7d454e51 in Plasma::IconWidget::paint (this=0x4723f50, painter=0x7fff4bab7a70, option=0x25b3838, widget=<value optimized out>) at ../../plasma/widgets/iconwidget.cpp:1128
#14 0x00007f7a61fbf3e9 in SystemTray::DBusSystemTrayWidget::paint (this=0x4723f50, painter=0x7fff4bab7a70, option=0x25b3838, widget=<value optimized out>) at ../../../../../plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#15 0x00007f7a7a3f419d in _q_paintItem (item=<value optimized out>, painter=0x7fff4bab7a70, option=0x25b3838, widget=0x0, useWindowOpacity=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#16 0x00007f7a7a3f44b0 in _q_paintIntoCache (pix=0x7fff4bab7fa0, item=0x4723f60, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x25b3838, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#17 0x00007f7a7a407ce8 in QGraphicsScenePrivate::drawItemHelper (this=0x25b3610, item=0x4723f60, painter=0x7fff4bab9fb0, option=0x25b3838, widget=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#18 0x00007f7a7a4088ba in QGraphicsScenePrivate::draw (this=0x25b3610, item=0x4723f60, painter=0x7fff4bab9fb0, viewTransform=0x7fff4bab9d40, transformPtr=0x7fff4bab8660, exposedRegion=0x34540c0, widget=0x32a1e40, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#19 0x00007f7a7a409565 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x25b3610, item=0x4723f60, painter=0x7fff4bab9fb0, viewTransform=0x7fff4bab9d40, exposedRegion=0x34540c0, widget=0x32a1e40, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#20 0x00007f7a7a408730 in QGraphicsScenePrivate::draw (this=0x25b3610, item=0x2754600, painter=0x7fff4bab9fb0, viewTransform=0x7fff4bab9d40, transformPtr=0x7fff4bab8c60, exposedRegion=0x34540c0, widget=0x32a1e40, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#21 0x00007f7a7a409565 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x25b3610, item=0x2754600, painter=0x7fff4bab9fb0, viewTransform=0x7fff4bab9d40, exposedRegion=0x34540c0, widget=0x32a1e40, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0x00007f7a7a408730 in QGraphicsScenePrivate::draw (this=0x25b3610, item=0x2779d20, painter=0x7fff4bab9fb0, viewTransform=0x7fff4bab9d40, transformPtr=0x7fff4bab9260, exposedRegion=0x34540c0, widget=0x32a1e40, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#23 0x00007f7a7a409565 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x25b3610, item=0x2779d20, painter=0x7fff4bab9fb0, viewTransform=0x7fff4bab9d40, exposedRegion=0x34540c0, widget=0x32a1e40, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0x00007f7a7a408730 in QGraphicsScenePrivate::draw (this=0x25b3610, item=0x2664f40, painter=0x7fff4bab9fb0, viewTransform=0x7fff4bab9d40, transformPtr=0x7fff4bab9860, exposedRegion=0x34540c0, widget=0x32a1e40, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#25 0x00007f7a7a409565 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x25b3610, item=0x2664f40, painter=0x7fff4bab9fb0, viewTransform=0x7fff4bab9d40, exposedRegion=0x34540c0, widget=0x32a1e40, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#26 0x00007f7a7a409d94 in QGraphicsScenePrivate::drawItems (this=0x25b3610, painter=0x7fff4bab9fb0, viewTransform=0x7fff4bab9d40, exposedRegion=0x34540c0, widget=0x32a1e40) at graphicsview/qgraphicsscene.cpp:4735
#27 0x00007f7a7a426bd2 in QGraphicsView::paintEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3469
#28 0x00007f7a79e55c6a in QWidget::event (this=0x3281190, event=0x7fff4baba8d0) at kernel/qwidget.cpp:8405
#29 0x00007f7a7a205a66 in QFrame::event (this=0x3281190, e=0x7fff4baba8d0) at widgets/qframe.cpp:557
#30 0x00007f7a7a427e8b in QGraphicsView::viewportEvent (this=0x3281190, event=0x7fff4baba8d0) at graphicsview/qgraphicsview.cpp:2864
#31 0x00007f7a7aa43627 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x32a1e40, event=0x7fff4baba8d0) at kernel/qcoreapplication.cpp:846
#32 0x00007f7a79e049b1 in QApplicationPrivate::notify_helper (this=0x24a05b0, receiver=0x32a1e40, e=0x7fff4baba8d0) at kernel/qapplication.cpp:4458
#33 0x00007f7a79e093aa in QApplication::notify (this=<value optimized out>, receiver=0x32a1e40, e=0x7fff4baba8d0) at kernel/qapplication.cpp:4341
#34 0x00007f7a7b6fb866 in KApplication::notify (this=0x2490270, receiver=0x32a1e40, event=0x7fff4baba8d0) at ../../kdeui/kernel/kapplication.cpp:311
#35 0x00007f7a7aa4349c in QCoreApplication::notifyInternal (this=0x2490270, receiver=0x32a1e40, event=0x7fff4baba8d0) at kernel/qcoreapplication.cpp:731
#36 0x00007f7a79e52abd in sendSpontaneousEvent (this=0x3467ae0, pdev=0x329a618, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x321c2a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#37 QWidgetPrivate::drawWidget (this=0x3467ae0, pdev=0x329a618, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x321c2a0) at kernel/qwidget.cpp:5492
#38 0x00007f7a79e536d2 in QWidgetPrivate::paintSiblingsRecursive (this=0x3453c30, pdev=0x329a618, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x321c2a0) at kernel/qwidget.cpp:5699
#39 0x00007f7a79e5358a in QWidgetPrivate::paintSiblingsRecursive (this=0x3453c30, pdev=0x329a618, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x321c2a0) at kernel/qwidget.cpp:5686
#40 0x00007f7a79e527fc in QWidgetPrivate::drawWidget (this=0x3453c30, pdev=0x329a618, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x321c2a0) at kernel/qwidget.cpp:5545
#41 0x00007f7a7a0172fb in QWidgetBackingStore::sync (this=0x321c2a0) at painting/qbackingstore.cpp:1333
#42 0x00007f7a79e48f50 in QWidgetPrivate::syncBackingStore (this=0x3453c30) at kernel/qwidget.cpp:1842
#43 0x00007f7a79e56184 in QWidget::event (this=0x3281190, event=0x2749630) at kernel/qwidget.cpp:8552
#44 0x00007f7a7a205a66 in QFrame::event (this=0x3281190, e=0x2749630) at widgets/qframe.cpp:557
#45 0x00007f7a7a2871fb in QAbstractScrollArea::event (this=0x3281190, e=0x2749630) at widgets/qabstractscrollarea.cpp:996
#46 0x00007f7a7db5efe6 in PanelView::event (this=0x3281190, event=0x2749630) at ../../../../plasma/desktop/shell/panelview.cpp:1604
#47 0x00007f7a79e049e4 in QApplicationPrivate::notify_helper (this=0x24a05b0, receiver=0x3281190, e=0x2749630) at kernel/qapplication.cpp:4462
#48 0x00007f7a79e093aa in QApplication::notify (this=<value optimized out>, receiver=0x3281190, e=0x2749630) at kernel/qapplication.cpp:4341
#49 0x00007f7a7b6fb866 in KApplication::notify (this=0x2490270, receiver=0x3281190, event=0x2749630) at ../../kdeui/kernel/kapplication.cpp:311
#50 0x00007f7a7aa4349c in QCoreApplication::notifyInternal (this=0x2490270, receiver=0x3281190, event=0x2749630) at kernel/qcoreapplication.cpp:731
#51 0x00007f7a7aa46c25 in sendEvent (receiver=0x3281190, event_type=77, data=0x23e3b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#52 QCoreApplicationPrivate::sendPostedEvents (receiver=0x3281190, event_type=77, data=0x23e3b60) at kernel/qcoreapplication.cpp:1372
#53 0x00007f7a7a40088a in dispatchPendingUpdateRequests (this=0x25b3610) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#54 QGraphicsScenePrivate::_q_processDirtyItems (this=0x25b3610) at graphicsview/qgraphicsscene.cpp:510
#55 0x00007f7a7a400caa in QGraphicsScene::qt_metacall (this=0x25b2110, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x4c49750) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#56 0x00007f7a7d3a2b65 in Plasma::Corona::qt_metacall (this=0x25b2110, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x4c49750) at ./corona.moc:109
#57 0x00007f7a7db53065 in DesktopCorona::qt_metacall (this=0x25b2110, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x4c49750) at ./desktopcorona.moc:101
#58 0x00007f7a7aa5749a in QObject::event (this=0x25b2110, e=<value optimized out>) at kernel/qobject.cpp:1226
#59 0x00007f7a7a40d58b in QGraphicsScene::event (this=0x25b2110, event=0x4435920) at graphicsview/qgraphicsscene.cpp:3544
#60 0x00007f7a79e049e4 in QApplicationPrivate::notify_helper (this=0x24a05b0, receiver=0x25b2110, e=0x4435920) at kernel/qapplication.cpp:4462
#61 0x00007f7a79e093aa in QApplication::notify (this=<value optimized out>, receiver=0x25b2110, e=0x4435920) at kernel/qapplication.cpp:4341
#62 0x00007f7a7b6fb866 in KApplication::notify (this=0x2490270, receiver=0x25b2110, event=0x4435920) at ../../kdeui/kernel/kapplication.cpp:311
#63 0x00007f7a7aa4349c in QCoreApplication::notifyInternal (this=0x2490270, receiver=0x25b2110, event=0x4435920) at kernel/qcoreapplication.cpp:731
#64 0x00007f7a7aa46c25 in sendEvent (receiver=0x0, event_type=0, data=0x23e3b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#65 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x23e3b60) at kernel/qcoreapplication.cpp:1372
#66 0x00007f7a7aa6e253 in sendPostedEvents (s=0x24a31c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#67 postEventSourceDispatch (s=0x24a31c0) at kernel/qeventdispatcher_glib.cpp:277
#68 0x00007f7a72241bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#69 0x00007f7a722423a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#70 0x00007f7a72242639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#71 0x00007f7a7aa6e3ef in QEventDispatcherGlib::processEvents (this=0x23e3340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#72 0x00007f7a79eabdfe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#73 0x00007f7a7aa42882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#74 0x00007f7a7aa42abc in QEventLoop::exec (this=0x7fff4babca30, flags=...) at kernel/qeventloop.cpp:201
#75 0x00007f7a7aa46ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#76 0x00007f7a7db59897 in kdemain (argc=1, argv=0x7fff4babcdf8) at ../../../../plasma/desktop/shell/main.cpp:118
#77 0x00007f7a7d7a5eff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=1, ubp_av=0x7fff4babcdf8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff4babcde8) at libc-start.c:226
#78 0x0000000000400669 in _start ()

Possible duplicates by query: bug 273499, bug 273383, bug 273373, bug 273310, bug 273297.

Reported using DrKonqi
Comment 1 Nicolas L. 2011-05-20 09:11:50 UTC

*** This bug has been marked as a duplicate of bug 258706 ***