Bug 273310 - plasma crash segmentation failed
Summary: plasma crash segmentation failed
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-15 00:35 UTC by Debo
Modified: 2011-05-15 00:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Debo 2011-05-15 00:35:00 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.3 (4.6.3) "release 4"
Qt Version: 4.7.3
Operating System: Linux 2.6.37.6-0.5-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

this time plasma crashed, when I closed Kopete

sometimes plasma crashed by opening a website

misstake: kde4init ... segmentation fault ....

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma-Desktop-Umgebung (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb580a710 (LWP 2395))]

Thread 2 (Thread 0xa7474b70 (LWP 2400)):
#0  0xb5b2822b in clock_gettime () from /lib/librt.so.1
#1  0xb6d340b5 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6e06f36 in updateCurrentTime (this=0xa6b01a74, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xa6b01a74, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6e0577b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xa747411c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6e0581d in timerSourcePrepare (source=0xa6b01a40, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5a72a70 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb5a738e2 in ?? () from /lib/libglib-2.0.so.0
#9  0xb5a73fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb6e05fc7 in QEventDispatcherGlib::processEvents (this=0x8a73208, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6dd6a6d in QEventLoop::processEvents (this=0xa74742b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6dd6c99 in QEventLoop::exec (this=0xa74742b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6cd7d49 in QThread::exec (this=0x8a743e8) at thread/qthread.cpp:492
#14 0xb6db67fd in QInotifyFileSystemWatcherEngine::run (this=0x8a743e8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6cda993 in QThreadPrivate::start (arg=0x8a743e8) at thread/qthread_unix.cpp:320
#16 0xb6c5db05 in start_thread () from /lib/libpthread.so.0
#17 0xb6017d5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb580a710 (LWP 2395)):
[KCrash Handler]
#7  0xb7418e03 in QString (this=0x9140061, group=0, state=0) at /usr/include/QtCore/qstring.h:728
#8  KIconEffect::fingerprint (this=0x9140061, group=0, state=0) at /usr/src/debug/kdelibs-4.6.3/kdeui/icons/kiconeffect.cpp:169
#9  0xb741a708 in KIconLoaderPrivate::makeCacheKey (this=0x914004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at /usr/src/debug/kdelibs-4.6.3/kdeui/icons/kiconloader.cpp:782
#10 0xb7571dfc in KIconLoader::loadIcon (this=0x8a95cd8, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kdelibs-4.6.3/kdeui/icons/kiconloader.cpp:1226
#11 0xb75730f4 in KIconEngine::pixmap (this=0x972fa38, size=..., mode=QIcon::Normal, state=QIcon::Off) at /usr/src/debug/kdelibs-4.6.3/kdeui/icons/kiconengine.cpp:93
#12 0xb63986c4 in QIcon::pixmap (this=0x9470214, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0xb4c81c81 in Plasma::IconWidgetPrivate::decoration (this=0x9470170, option=0x8106a58, useHoverEffect=false, usePressedEffect=false) at /usr/src/debug/kdelibs-4.6.3/plasma/widgets/iconwidget.cpp:812
#14 0xb4c88d54 in Plasma::IconWidget::paint (this=0x946bb18, painter=0xbff2da4c, option=0x8106a58, widget=0x0) at /usr/src/debug/kdelibs-4.6.3/plasma/widgets/iconwidget.cpp:1128
#15 0xae26129a in SystemTray::DBusSystemTrayWidget::paint (this=0x946bb18, painter=0xbff2da4c, option=0x8106a58, widget=0x0) at /usr/src/debug/kdebase-workspace-4.6.3/plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#16 0xb6972375 in _q_paintItem (item=<value optimized out>, painter=0xbff2da4c, option=0x8106a58, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#17 0xb69726ca in _q_paintIntoCache (pix=0xbff2df2c, item=0x946bb20, pixmapExposed=..., itemToPixmap=..., renderHints=) at graphicsview/qgraphicsscene.cpp:4352
#18 0xb69877d8 in QGraphicsScenePrivate::drawItemHelper (this=0x8106908, item=0x946bb20, painter=0xbff2f764, option=0x8106a58, widget=0x8a9eba8, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#19 0xb6988482 in QGraphicsScenePrivate::draw (this=0x8106908, item=0x946bb20, painter=0xbff2f764, viewTransform=0xbff2f54c, transformPtr=0xbff2e320, exposedRegion=0x89bd350, widget=0x8a9eba8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#20 0xb698921e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8106908, item=0x946bb20, painter=0xbff2f764, viewTransform=0xbff2f54c, exposedRegion=0x89bd350, widget=0x8a9eba8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#21 0xb69882af in QGraphicsScenePrivate::draw (this=0x8106908, item=0x8257440, painter=0xbff2f764, viewTransform=0xbff2f54c, transformPtr=0xbff2e7d0, exposedRegion=0x89bd350, widget=0x8a9eba8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#22 0xb698921e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8106908, item=0x8257440, painter=0xbff2f764, viewTransform=0xbff2f54c, exposedRegion=0x89bd350, widget=0x8a9eba8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#23 0xb69882af in QGraphicsScenePrivate::draw (this=0x8106908, item=0x82b14f0, painter=0xbff2f764, viewTransform=0xbff2f54c, transformPtr=0xbff2ec80, exposedRegion=0x89bd350, widget=0x8a9eba8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#24 0xb698921e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8106908, item=0x82b14f0, painter=0xbff2f764, viewTransform=0xbff2f54c, exposedRegion=0x89bd350, widget=0x8a9eba8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#25 0xb69882af in QGraphicsScenePrivate::draw (this=0x8106908, item=0x8260c18, painter=0xbff2f764, viewTransform=0xbff2f54c, transformPtr=0xbff2f130, exposedRegion=0x89bd350, widget=0x8a9eba8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#26 0xb698921e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8106908, item=0x8260c18, painter=0xbff2f764, viewTransform=0xbff2f54c, exposedRegion=0x89bd350, widget=0x8a9eba8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#27 0xb6989ac7 in QGraphicsScenePrivate::drawItems (this=0x8106908, painter=0xbff2f764, viewTransform=0xbff2f54c, exposedRegion=0x89bd350, widget=0x8a9eba8) at graphicsview/qgraphicsscene.cpp:4735
#28 0xb69aa9be in QGraphicsView::paintEvent (this=0x8ab53c8, event=0x0) at graphicsview/qgraphicsview.cpp:3469
#29 0xb0cee1b3 in PanelView::paintEvent (this=0x8ab53c8, event=0xbff2fe44) at /usr/src/debug/kdebase-workspace-4.6.3/plasma/desktop/shell/panelview.cpp:1593
#30 0xb633ab4a in QWidget::event (this=0x8ab53c8, event=0xbff2fe44) at kernel/qwidget.cpp:8405
#31 0xb674a0f5 in QFrame::event (this=0x8ab53c8, e=0xbff2fe44) at widgets/qframe.cpp:557
#32 0xb67dbb91 in QAbstractScrollArea::viewportEvent (this=0x8ab53c8, e=0xbff2fe44) at widgets/qabstractscrollarea.cpp:1043
#33 0xb69abddc in QGraphicsView::viewportEvent (this=0x8ab53c8, event=0xbff2fe44) at graphicsview/qgraphicsview.cpp:2864
#34 0xb67de486 in viewportEvent (this=0x8ab90f8, o=0x8a9eba8, e=0xbff2fe44) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x8ab90f8, o=0x8a9eba8, e=0xbff2fe44) at widgets/qabstractscrollarea_p.h:116
#36 0xb6dd7926 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x80fb690, receiver=0x8a9eba8, event=0xbff2fe44) at kernel/qcoreapplication.cpp:846
#37 0xb62df654 in QApplicationPrivate::notify_helper (this=0x80fb690, receiver=0x8a9eba8, e=0xbff2fe44) at kernel/qapplication.cpp:4458
#38 0xb62e84d4 in QApplication::notify (this=0x80ecba0, receiver=0x8a9eba8, e=0xbff2fe44) at kernel/qapplication.cpp:4341
#39 0xb7433901 in KApplication::notify (this=0x80ecba0, receiver=0x8a9eba8, event=0xbff2fe44) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#40 0xb6dd778e in QCoreApplication::notifyInternal (this=0x80ecba0, receiver=0x8a9eba8, event=0xbff2fe44) at kernel/qcoreapplication.cpp:731
#41 0xb63377e2 in sendSpontaneousEvent (this=0x8a9ebc0, pdev=0x8a77c3c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8ae53b0) at ../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x8a9ebc0, pdev=0x8a77c3c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8ae53b0) at kernel/qwidget.cpp:5492
#43 0xb6338537 in QWidgetPrivate::paintSiblingsRecursive (this=0x89bd000, pdev=0x8a77c3c, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8ae53b0) at kernel/qwidget.cpp:5699
#44 0xb6337538 in QWidgetPrivate::drawWidget (this=0x89bd000, pdev=0x8a77c3c, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x8ae53b0) at kernel/qwidget.cpp:5545
#45 0xb6526198 in QWidgetBackingStore::sync (this=0x8ae53b0) at painting/qbackingstore.cpp:1333
#46 0xb632c45b in QWidgetPrivate::syncBackingStore (this=0x89bd000) at kernel/qwidget.cpp:1842
#47 0xb633b61a in QWidget::event (this=0x8ab53c8, event=0x8a95cd8) at kernel/qwidget.cpp:8552
#48 0xb674a0f5 in QFrame::event (this=0x8ab53c8, e=0x8a95cd8) at widgets/qframe.cpp:557
#49 0xb67dd914 in QAbstractScrollArea::event (this=0x8ab53c8, e=0x8a95cd8) at widgets/qabstractscrollarea.cpp:996
#50 0xb699e5c8 in QGraphicsView::event (this=0x8ab53c8, event=0x8a95cd8) at graphicsview/qgraphicsview.cpp:2741
#51 0xb0cee409 in PanelView::event (this=0x8ab53c8, event=0x8a95cd8) at /usr/src/debug/kdebase-workspace-4.6.3/plasma/desktop/shell/panelview.cpp:1604
#52 0xb62df684 in QApplicationPrivate::notify_helper (this=0x80fb690, receiver=0x8ab53c8, e=0x8a95cd8) at kernel/qapplication.cpp:4462
#53 0xb62e84d4 in QApplication::notify (this=0x80ecba0, receiver=0x8ab53c8, e=0x8a95cd8) at kernel/qapplication.cpp:4341
#54 0xb7433901 in KApplication::notify (this=0x80ecba0, receiver=0x8ab53c8, event=0x8a95cd8) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#55 0xb6dd778e in QCoreApplication::notifyInternal (this=0x80ecba0, receiver=0x8ab53c8, event=0x8a95cd8) at kernel/qcoreapplication.cpp:731
#56 0xb6ddb51c in sendEvent (receiver=0x8ab53c8, event_type=77, data=0x80582a0) at kernel/qcoreapplication.h:215
#57 QCoreApplicationPrivate::sendPostedEvents (receiver=0x8ab53c8, event_type=77, data=0x80582a0) at kernel/qcoreapplication.cpp:1372
#58 0xb6ddb66c in QCoreApplication::sendPostedEvents (receiver=0x8ab53c8, event_type=77) at kernel/qcoreapplication.cpp:1265
#59 0xb697f79e in dispatchPendingUpdateRequests (this=0x8106908) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#60 QGraphicsScenePrivate::_q_processDirtyItems (this=0x8106908) at graphicsview/qgraphicsscene.cpp:510
#61 0xb697fbb3 in QGraphicsScene::qt_metacall (this=0x81a30f8, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x93aa708) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#62 0xb4bbe7b2 in Plasma::Corona::qt_metacall (this=0x81a30f8, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x93aa708) at /usr/src/debug/kdelibs-4.6.3/build/plasma/corona.moc:109
#63 0xb0ce02e2 in DesktopCorona::qt_metacall (this=0x81a30f8, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x93aa708) at /usr/src/debug/kdebase-workspace-4.6.3/build/plasma/desktop/shell/desktopcorona.moc:101
#64 0xb6dde07d in QMetaObject::metacall (object=0x81a30f8, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x93aa708) at kernel/qmetaobject.cpp:237
#65 0xb6de8b55 in QMetaCallEvent::placeMetaCall (this=0x94f3378, object=0x81a30f8) at kernel/qobject.cpp:535
#66 0xb6decdbf in QObject::event (this=0x81a30f8, e=0x94f3378) at kernel/qobject.cpp:1217
#67 0xb698d7a0 in QGraphicsScene::event (this=0x81a30f8, event=0x94f3378) at graphicsview/qgraphicsscene.cpp:3544
#68 0xb62df684 in QApplicationPrivate::notify_helper (this=0x80fb690, receiver=0x81a30f8, e=0x94f3378) at kernel/qapplication.cpp:4462
#69 0xb62e8427 in QApplication::notify (this=0x80ecba0, receiver=0x81a30f8, e=0x94f3378) at kernel/qapplication.cpp:3862
#70 0xb7433901 in KApplication::notify (this=0x80ecba0, receiver=0x81a30f8, event=0x94f3378) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#71 0xb6dd778e in QCoreApplication::notifyInternal (this=0x80ecba0, receiver=0x81a30f8, event=0x94f3378) at kernel/qcoreapplication.cpp:731
#72 0xb6ddb51c in sendEvent (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.h:215
#73 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.cpp:1372
#74 0xb6ddb66c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#75 0xb6e05df4 in sendPostedEvents (s=0x81012b0) at kernel/qcoreapplication.h:220
#76 postEventSourceDispatch (s=0x81012b0) at kernel/qeventdispatcher_glib.cpp:277
#77 0xb5a73509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#78 0xb5a73d10 in ?? () from /lib/libglib-2.0.so.0
#79 0xb5a73fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#80 0xb6e05f7b in QEventDispatcherGlib::processEvents (this=0x80c7ea8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#81 0xb63961da in QGuiEventDispatcherGlib::processEvents (this=0x80c7ea8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#82 0xb6dd6a6d in QEventLoop::processEvents (this=0xbff31624, flags=...) at kernel/qeventloop.cpp:149
#83 0xb6dd6c99 in QEventLoop::exec (this=0xbff31624, flags=...) at kernel/qeventloop.cpp:201
#84 0xb6ddb740 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#85 0xb62dd3d4 in QApplication::exec () at kernel/qapplication.cpp:3736
#86 0xb0ce7d0b in kdemain (argc=1, argv=0x80d01c8) at /usr/src/debug/kdebase-workspace-4.6.3/plasma/desktop/shell/main.cpp:120
#87 0x0804e514 in _start ()

Possible duplicates by query: bug 273218, bug 273211, bug 273157, bug 273053, bug 272989.

Reported using DrKonqi
Comment 1 Dario Andres 2011-05-15 00:50:26 UTC
[Comment from a bug triager]
The bug is fixed in KDE SC 4.6.4 (and may be backported to 4.6.3 by
distributions). The issue was being tracked at bug 258706, merging.
Thanks

*** This bug has been marked as a duplicate of bug 258706 ***