Bug 273467 - Assign each single activity with a hotkey
Summary: Assign each single activity with a hotkey
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: activities (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-17 10:39 UTC by Weng Xuetian
Modified: 2012-04-15 15:18 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Weng Xuetian 2011-05-17 10:39:04 UTC
Version:           unspecified (using KDE 4.6.2) 
OS:                Linux

It would be convinient if we can switch to specific activity by keyboard, not only by switch to "previous" / "next". Just like we can switch to a specific virtual desktop.

Reproducible: Didn't try
Comment 1 Will Stephenson 2011-10-10 20:37:06 UTC
Dupe

*** This bug has been marked as a duplicate of bug 265069 ***
Comment 2 Lamarque V. Souza 2012-04-15 15:18:52 UTC
Git commit f0983fa9a3a1f4466b7d4fa19cfa55914c0cea8a by Lamarque V. Souza, on behalf of Makis Marimpis.
Committed on 15/04/2012 at 17:18.
Pushed by lvsouza into branch 'KDE/4.8'.

GlobalShortcuts Plugin for ActivityManager (kamd).
Thanks to makis marimpis for this patch.

REVIEW: 104428
Related: bug 265069
FIXED-IN: 4.8.3

M  +1    -0    service/plugins/CMakeLists.txt

http://commits.kde.org/kactivities/f0983fa9a3a1f4466b7d4fa19cfa55914c0cea8a
Comment 3 Lamarque V. Souza 2012-04-15 15:18:58 UTC
Git commit 7e2ef3c7f0a6584a040b4fe70e1012de9b1511d8 by Lamarque V. Souza, on behalf of Makis Marimpis.
Committed on 15/04/2012 at 17:14.
Pushed by lvsouza into branch 'master'.

GlobalShortcuts Plugin for ActivityManager (kamd).
Thanks to makis marimpis for this patch.

REVIEW: 104428
Related: bug 265069
FIXED-IN: 4.8.3

M  +1    -0    service/plugins/CMakeLists.txt

http://commits.kde.org/kactivities/7e2ef3c7f0a6584a040b4fe70e1012de9b1511d8