Bug 265069 - please support shortcuts for selecting activities
Summary: please support shortcuts for selecting activities
Status: RESOLVED FIXED
Alias: None
Product: kactivitymanagerd
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-01 10:52 UTC by RSB
Modified: 2012-04-15 15:18 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RSB 2011-02-01 10:52:37 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

It would be very usefull if shortcuts for changing the activities will be supportet. 

One possible solutionen: After open the activity window (Meta + Q) changing could happens with pressing 0-9 to change between the first 10 activities



Reproducible: Didn't try
Comment 1 Will Stephenson 2011-10-10 20:37:06 UTC
*** Bug 273467 has been marked as a duplicate of this bug. ***
Comment 2 Ivan Čukić 2012-03-21 17:52:35 UTC
I'm not opposed to this, so if there are people willing to work on it... you have a green light.

In the mean time, you can set a custom keyboard short-cut to run a specific application (in the sys settings). And you can run
qdbus org.kde.ActivityManager /ActivityManager setCurrentActivity <UUID-of-activity>

Not an easy solution, but it works.
Comment 3 Lamarque V. Souza 2012-04-15 15:18:52 UTC
Git commit f0983fa9a3a1f4466b7d4fa19cfa55914c0cea8a by Lamarque V. Souza, on behalf of Makis Marimpis.
Committed on 15/04/2012 at 17:18.
Pushed by lvsouza into branch 'KDE/4.8'.

GlobalShortcuts Plugin for ActivityManager (kamd).
Thanks to makis marimpis for this patch.

REVIEW: 104428
Related: bug 273467
FIXED-IN: 4.8.3

M  +1    -0    service/plugins/CMakeLists.txt

http://commits.kde.org/kactivities/f0983fa9a3a1f4466b7d4fa19cfa55914c0cea8a
Comment 4 Lamarque V. Souza 2012-04-15 15:18:58 UTC
Git commit 7e2ef3c7f0a6584a040b4fe70e1012de9b1511d8 by Lamarque V. Souza, on behalf of Makis Marimpis.
Committed on 15/04/2012 at 17:14.
Pushed by lvsouza into branch 'master'.

GlobalShortcuts Plugin for ActivityManager (kamd).
Thanks to makis marimpis for this patch.

REVIEW: 104428
Related: bug 273467
FIXED-IN: 4.8.3

M  +1    -0    service/plugins/CMakeLists.txt

http://commits.kde.org/kactivities/7e2ef3c7f0a6584a040b4fe70e1012de9b1511d8