Bug 273342 - No way to refresh a comic once fetching it failed just once
Summary: No way to refresh a comic once fetching it failed just once
Status: RESOLVED WORKSFORME
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Matthias Fuchs
URL:
Keywords:
: 291488 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-15 15:03 UTC by Benjamin M
Modified: 2012-04-05 06:36 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin M 2011-05-15 15:03:18 UTC
Version:           unspecified (using Devel) 
OS:                Linux

It is impossible to refresh a comic that has failed to be loaded one time. The widget also doesn't retry. This even happens if I hibernate and then restart somewhere I have internet. You can't even go back to the last comic before that and then go to the comic that failed to load again. The currently displayed strips are loaded just once. 

Reproducible: Always


Actual Results:  
No way to refresh a strip that has failed to load. 

Expected Results:  
The widget should either remember failed attempts and retry every so often - or there should be an option in the context menu to refresh the strip. 

This is not a big problem if you always display the current strip, because if that one fails to load, you can select "go to current strip" (retranslation from German) from the context menu - that will reload the current strip. But for any others, there seems no way.
Comment 1 Matthias Fuchs 2011-05-15 15:10:01 UTC

*** This bug has been marked as a duplicate of bug 272799 ***
Comment 2 Benjamin M 2011-05-15 15:44:19 UTC
This isn't directly a duplicate of bug 272799. Can I conclude that there is going to be a way to refresh in 4.6.3? 
Becuase I am using an svn version ("4.6.3 (4.6.3) "release 4"" according to sysinfo:/. This is supposed to be a stable repo - oh well) and I still don't see a way to refresh.
Comment 3 Benjamin M 2011-05-15 15:48:56 UTC
(Ok it is 4.6.3 stable. I'm out of the loop.)
Comment 4 Matthias Fuchs 2011-05-15 17:26:15 UTC
You can go backwards and then forward again.
Though you are right there should be a reload option.
Comment 5 Benjamin M 2011-05-25 08:57:17 UTC
The going backwards and then forward again hasn't been working recently (though it did at first). The comic doesn't reload. 
This might have to do with not using Networkmanager, but WICD.
Comment 6 Argy M 2011-09-16 11:08:37 UTC
True, and exists on 4.6.2 (Kubuntu 11.04) as well. It's fine when I'm on Ethernet, but when I'm on WiFi, because it attempts to load the comic before I have entered the wallet password to connect, it stays there, and going back and forth usually works, but sometimes it simply hangs on loading the latest one. Bothers me because it didn't happen on 10.10 (can't remember the KDE version).
Comment 7 Anne-Marie Mahfouf 2011-12-29 17:23:52 UTC
The code is there in Comic to refresh whenever you are connected again to the internet. It does not work because of WICD or ntrack or whatever.

I talked for 2 hours today to the network and Solid developer to try to see what's happening but the code is there fo rit to work if you have the proper version of KDE and the proper version of NetworkManger which I do not for example...

Reassigning to Network Management
Comment 8 Lamarque V. Souza 2012-01-09 13:09:37 UTC
If you use Wicd you ust use KDE SC >= 4.7.2 for the network status work properly.

Which SC version do you use?
Comment 9 Benjamin M 2012-01-09 13:48:12 UTC
Idk if this question was for me or for Argyris, but it's been a while and I'm using Networkmanager now, so the bug doesn't apply to me anymore. Maybe he can help with that.
Comment 10 Lamarque V. Souza 2012-01-09 13:51:53 UTC
(In reply to comment #9)
> Idk if this question was for me or for Argyris, but it's been a while and I'm
> using Networkmanager now, so the bug doesn't apply to me anymore. Maybe he can
> help with that.

Yes, the question was for both of you. I just want to know if the bug is still valid. For Wicd you should test with KDE SC >= 4.7.2, since you do not use Wicd anymore than I just want to know if you still can reproduce the bug.
Comment 11 Benjamin M 2012-01-09 14:00:07 UTC
No, I cannot reproduce at all times in KDE 4.7.4 and with Networkmanager. I do sometimes have problems sometimes (i.e. up until recently, but only for a few weeks), but not at the moment. And I'm not sure from memory what exactly didn't work a week back or so, I think I had to go back 2 comics and then back forward so that it would reload, but I'm not sure.
Comment 12 Lamarque V. Souza 2012-01-09 16:00:10 UTC
Git commit 310dc1ce652d506b7cb11111ecca40e6849d2cfe by Lamarque V. Souza.
Committed on 09/01/2012 at 16:55.
Pushed by lvsouza into branch 'KDE/4.8'.

Delay statusChanged(Solid::Networking::Connected) signal a bit. It looks
like networking is not really connected right after networkstatus module
receives the "Connected" signal from backend (tested with NetworkManager).
(cherry picked from commit d0ce3b783382016a0b6049a78066a5fdb089043b)

M  +12   -3    solid-networkstatus/kded/networkstatus.cpp
M  +1    -0    solid-networkstatus/kded/networkstatus.h

http://commits.kde.org/kde-runtime/310dc1ce652d506b7cb11111ecca40e6849d2cfe
Comment 13 Lamarque V. Souza 2012-01-09 16:00:11 UTC
Git commit d0ce3b783382016a0b6049a78066a5fdb089043b by Lamarque V. Souza.
Committed on 09/01/2012 at 16:55.
Pushed by lvsouza into branch 'master'.

Delay statusChanged(Solid::Networking::Connected) signal a bit. It looks
like networking is not really connected right after networkstatus module
receives the "Connected" signal from backend (tested with NetworkManager).

M  +12   -3    solid-networkstatus/kded/networkstatus.cpp
M  +1    -0    solid-networkstatus/kded/networkstatus.h

http://commits.kde.org/kde-runtime/d0ce3b783382016a0b6049a78066a5fdb089043b
Comment 14 Lamarque V. Souza 2012-01-09 16:07:20 UTC
the last commit solved most of the problems with Comic plasmoid here. The plasmoid still does not automatically reload the strip if it had failed before. You need to got back and forward until it realises the computer is connected to the Internet. Someone needs to fix that in the Comic plasmoid.
Comment 15 Lamarque V. Souza 2012-01-14 03:47:51 UTC
*** Bug 291488 has been marked as a duplicate of this bug. ***
Comment 16 Benjamin M 2012-01-14 12:41:39 UTC
Jfyi: The thing that I had mentioned that I had noticed is that "Jump to current" (paraphrazing, sorry) from the context menu doesn't if loading has failed before. Suppose the comic that did not load successfully because the internet connection wasn't set up at the time is the most recent one. Then, if I wanted to reload the most recent comic, I could not only go back and forward, but also use the reload button through the context menu. But recently, I would have to use the back button, because the function in the context menu doesn't work. 

I know this is a different problem. Sorry. :-)
Comment 17 Matthias Fuchs 2012-01-14 13:12:21 UTC
I'll look into it as soon as I find some time.
Unfortunately I have absolutely no free time at the moment, thus it might take till february before I can give you an update on this.
Comment 18 Lamarque V. Souza 2012-04-01 21:55:34 UTC
What the status of the bug? Does it still happen with 4.8.1?
Comment 19 Benjamin M 2012-04-04 18:37:49 UTC
This works fine for me now. Thanks!
Comment 20 Anne-Marie Mahfouf 2012-04-05 06:36:36 UTC
Closing