Bug 273053 - desktop crashes on *killing* amarok (which did not respond anymore)
Summary: desktop crashes on *killing* amarok (which did not respond anymore)
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-11 18:09 UTC by Christian Parpart
Modified: 2011-05-12 00:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Parpart 2011-05-11 18:09:06 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.3 (4.6.3) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-gentoo-r3 x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:
I came back after being a ~ 90 minutes afk, found amarok freezed, and eating up 100% cpu load, so I killed it via kwin (right click on X, wait, klick on terminate).
This termination also killed the plasma desktop, and this behaviour is something I get recently quite often.

Please note, I am on kde 4.6.3 and the possible duplicate I marked is from far earlier, however, the infos looked similar.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f8b99b03760 (LWP 31745))]

Thread 2 (Thread 0x7f8b72976700 (LWP 31749)):
#0  0xffffffffff600136 in ?? ()
#1  0x00007f8b72975a40 in ?? ()
#2  0x00007fff6735f6de in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f8b99b03760 (LWP 31745)):
[KCrash Handler]
#6  0x00007f8b993ca864 in QString::QString (this=0x7fff6732eac0, other=...) at /usr/include/qt4/QtCore/qstring.h:728
#7  0x00007f8b9944cca7 in KIconEffect::fingerprint (this=0x3140075, group=0, state=0) at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3/kdeui/icons/kiconeffect.cpp:169
#8  0x00007f8b994564a1 in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=<value optimized out>, state=0) at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3/kdeui/icons/kiconloader.cpp:782
#9  0x00007f8b994568e8 in KIconLoader::loadIcon (this=0x1b75c10, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3/kdeui/icons/kiconloader.cpp:1226
#10 0x00007f8b99450987 in KIconEngine::pixmap (this=0x23ef4a0, size=..., mode=<value optimized out>, state=<value optimized out>) at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3/kdeui/icons/kiconengine.cpp:93
#11 0x00007f8b9798b82e in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:676
#12 0x00007f8b8850eb46 in Plasma::IconWidgetPrivate::decoration (this=0x2c2fca0, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3/plasma/widgets/iconwidget.cpp:812
#13 0x00007f8b8851297d in Plasma::IconWidget::paint (this=0x22eafb0, painter=0x7fff6732f830, option=0x74cc08, widget=<value optimized out>) at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3/plasma/widgets/iconwidget.cpp:1128
#14 0x00007f8b78d32598 in SystemTray::DBusSystemTrayWidget::paint (this=0x22eafb0, painter=0x7fff6732f830, option=0x74cc08, widget=<value optimized out>) at /usr/src/debug/kde-base/plasma-workspace-4.6.3/plasma-workspace-4.6.3/plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#15 0x00007f8b97e9a76d in _q_paintItem (item=<value optimized out>, painter=0x7fff6732f830, option=0x74cc08, widget=0x0, useWindowOpacity=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#16 0x00007f8b97e9b35a in _q_paintIntoCache (pix=0x7fff6732fdc0, item=0x22eafc0, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x74cc08, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#17 0x00007f8b97eb316f in QGraphicsScenePrivate::drawItemHelper (this=0x74c9e0, item=0x22eafc0, painter=0x7fff67331dc0, option=0x74cc08, widget=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#18 0x00007f8b97eb3bd7 in QGraphicsScenePrivate::draw (this=0x74c9e0, item=0x22eafc0, painter=0x7fff67331dc0, viewTransform=0x7fff67331a90, transformPtr=0x7fff67330360, exposedRegion=0x2003d70, widget=0x980e30, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#19 0x00007f8b97eb49b5 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x74c9e0, item=0x22eafc0, painter=0x7fff67331dc0, viewTransform=0x7fff67331a90, exposedRegion=0x2003d70, widget=0x980e30, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#20 0x00007f8b97eb3c80 in QGraphicsScenePrivate::draw (this=0x74c9e0, item=0x71af20, painter=0x7fff67331dc0, viewTransform=0x7fff67331a90, transformPtr=0x7fff67330960, exposedRegion=0x2003d70, widget=0x980e30, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#21 0x00007f8b97eb49b5 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x74c9e0, item=0x71af20, painter=0x7fff67331dc0, viewTransform=0x7fff67331a90, exposedRegion=0x2003d70, widget=0x980e30, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0x00007f8b97eb3c80 in QGraphicsScenePrivate::draw (this=0x74c9e0, item=0xc52530, painter=0x7fff67331dc0, viewTransform=0x7fff67331a90, transformPtr=0x7fff67330f60, exposedRegion=0x2003d70, widget=0x980e30, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#23 0x00007f8b97eb49b5 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x74c9e0, item=0xc52530, painter=0x7fff67331dc0, viewTransform=0x7fff67331a90, exposedRegion=0x2003d70, widget=0x980e30, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0x00007f8b97eb3c80 in QGraphicsScenePrivate::draw (this=0x74c9e0, item=0x894690, painter=0x7fff67331dc0, viewTransform=0x7fff67331a90, transformPtr=0x7fff67331560, exposedRegion=0x2003d70, widget=0x980e30, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#25 0x00007f8b97eb49b5 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x74c9e0, item=0x894690, painter=0x7fff67331dc0, viewTransform=0x7fff67331a90, exposedRegion=0x2003d70, widget=0x980e30, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#26 0x00007f8b97eb51b1 in QGraphicsScenePrivate::drawItems (this=0x74c9e0, painter=0x7fff67331dc0, viewTransform=0x7fff67331a90, exposedRegion=0x2003d70, widget=0x980e30) at graphicsview/qgraphicsscene.cpp:4735
#27 0x00007f8b97ecd91f in QGraphicsView::paintEvent (this=0x1b7fb00, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3469
#28 0x00007f8b97937497 in QWidget::event (this=0x1b7fb00, event=0x7fff67332780) at kernel/qwidget.cpp:8405
#29 0x00007f8b97cb16b6 in QFrame::event (this=0x1b7fb00, e=0x7fff67332780) at widgets/qframe.cpp:557
#30 0x00007f8b97ecec93 in QGraphicsView::viewportEvent (this=0x1b7fb00, event=0x7fff67332780) at graphicsview/qgraphicsview.cpp:2864
#31 0x00007f8b986f64c7 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x980e30, event=0x7fff67332780) at kernel/qcoreapplication.cpp:846
#32 0x00007f8b978e7b4f in notify_helper (this=0x735c50, receiver=0x980e30, e=0x7fff67332780) at kernel/qapplication.cpp:4458
#33 QApplicationPrivate::notify_helper (this=0x735c50, receiver=0x980e30, e=0x7fff67332780) at kernel/qapplication.cpp:4434
#34 0x00007f8b978ec901 in QApplication::notify (this=0x714a20, receiver=0x980e30, e=0x7fff67332780) at kernel/qapplication.cpp:4341
#35 0x00007f8b994a676f in KApplication::notify (this=0x714a20, receiver=0x980e30, event=0x7fff67332780) at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#36 0x00007f8b986f6353 in QCoreApplication::notifyInternal (this=0x714a20, receiver=0x980e30, event=0x7fff67332780) at kernel/qcoreapplication.cpp:731
#37 0x00007f8b979343ee in sendSpontaneousEvent (this=0x1a11a60, pdev=0x1a15688, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1fa7f70) at ../../src/corelib/kernel/qcoreapplication.h:218
#38 QWidgetPrivate::drawWidget (this=0x1a11a60, pdev=0x1a15688, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1fa7f70) at kernel/qwidget.cpp:5492
#39 0x00007f8b97934fc5 in QWidgetPrivate::paintSiblingsRecursive (this=0x20038e0, pdev=0x1a15688, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1fa7f70) at kernel/qwidget.cpp:5699
#40 0x00007f8b9793412b in QWidgetPrivate::drawWidget (this=0x20038e0, pdev=0x1a15688, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x1fa7f70) at kernel/qwidget.cpp:5545
#41 0x00007f8b97aec9c9 in QWidgetBackingStore::sync (this=0x1fa7f70) at painting/qbackingstore.cpp:1333
#42 0x00007f8b9792adb8 in QWidgetPrivate::syncBackingStore (this=0x20038e0) at kernel/qwidget.cpp:1842
#43 0x00007f8b979379ac in QWidget::event (this=0x1b7fb00, event=0x1b75c10) at kernel/qwidget.cpp:8552
#44 0x00007f8b97cb16b6 in QFrame::event (this=0x1b7fb00, e=0x1b75c10) at widgets/qframe.cpp:557
#45 0x00007f8b97d31513 in QAbstractScrollArea::event (this=0x1b7fb00, e=0x1b75c10) at widgets/qabstractscrollarea.cpp:996
#46 0x00007f8b8222213e in PanelView::event (this=0x1b7fb00, event=0x1b75c10) at /usr/src/debug/kde-base/plasma-workspace-4.6.3/plasma-workspace-4.6.3/plasma/desktop/shell/panelview.cpp:1604
#47 0x00007f8b978e7b84 in notify_helper (this=0x735c50, receiver=0x1b7fb00, e=0x1b75c10) at kernel/qapplication.cpp:4462
#48 QApplicationPrivate::notify_helper (this=0x735c50, receiver=0x1b7fb00, e=0x1b75c10) at kernel/qapplication.cpp:4434
#49 0x00007f8b978ec901 in QApplication::notify (this=0x714a20, receiver=0x1b7fb00, e=0x1b75c10) at kernel/qapplication.cpp:4341
#50 0x00007f8b994a676f in KApplication::notify (this=0x714a20, receiver=0x1b7fb00, event=0x1b75c10) at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#51 0x00007f8b986f6353 in QCoreApplication::notifyInternal (this=0x714a20, receiver=0x1b7fb00, event=0x1b75c10) at kernel/qcoreapplication.cpp:731
#52 0x00007f8b986f9603 in sendEvent (receiver=0x1b7fb00, event_type=77, data=0x613b00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#53 QCoreApplicationPrivate::sendPostedEvents (receiver=0x1b7fb00, event_type=77, data=0x613b00) at kernel/qcoreapplication.cpp:1372
#54 0x00007f8b97eaa372 in dispatchPendingUpdateRequests (this=0x74c9e0) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#55 QGraphicsScenePrivate::_q_processDirtyItems (this=0x74c9e0) at graphicsview/qgraphicsscene.cpp:510
#56 0x00007f8b97eaa772 in QGraphicsScene::qt_metacall (this=0x7e5690, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x2e682e0) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#57 0x00007f8b88462217 in Plasma::Corona::qt_metacall (this=0x7e5690, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2e682e0) at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3_build/plasma/corona.moc:109
#58 0x00007f8b82215f97 in DesktopCorona::qt_metacall (this=0x7e5690, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2e682e0) at /usr/src/debug/kde-base/plasma-workspace-4.6.3/plasma-workspace-4.6.3_build/plasma/desktop/shell/desktopcorona.moc:101
#59 0x00007f8b9870c69a in QObject::event (this=0x7e5690, e=<value optimized out>) at kernel/qobject.cpp:1217
#60 0x00007f8b97eb0e09 in QGraphicsScene::event (this=0x7e5690, event=0x2b080c0) at graphicsview/qgraphicsscene.cpp:3544
#61 0x00007f8b978e7b84 in notify_helper (this=0x735c50, receiver=0x7e5690, e=0x2b080c0) at kernel/qapplication.cpp:4462
#62 QApplicationPrivate::notify_helper (this=0x735c50, receiver=0x7e5690, e=0x2b080c0) at kernel/qapplication.cpp:4434
#63 0x00007f8b978ec901 in QApplication::notify (this=0x714a20, receiver=0x7e5690, e=0x2b080c0) at kernel/qapplication.cpp:4341
#64 0x00007f8b994a676f in KApplication::notify (this=0x714a20, receiver=0x7e5690, event=0x2b080c0) at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#65 0x00007f8b986f6353 in QCoreApplication::notifyInternal (this=0x714a20, receiver=0x7e5690, event=0x2b080c0) at kernel/qcoreapplication.cpp:731
#66 0x00007f8b986f9603 in sendEvent (receiver=0x0, event_type=0, data=0x613b00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#67 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x613b00) at kernel/qcoreapplication.cpp:1372
#68 0x00007f8b98720133 in sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#69 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#70 0x00007f8b93f66a24 in g_main_dispatch (context=0x7384e0) at gmain.c:2440
#71 g_main_context_dispatch (context=0x7384e0) at gmain.c:3013
#72 0x00007f8b93f671d0 in g_main_context_iterate (context=0x7384e0, block=<value optimized out>, dispatch=1, self=<value optimized out>) at gmain.c:3091
#73 0x00007f8b93f67469 in g_main_context_iteration (context=0x7384e0, may_block=1) at gmain.c:3154
#74 0x00007f8b9872056b in QEventDispatcherGlib::processEvents (this=0x714d10, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#75 0x00007f8b979898ce in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#76 0x00007f8b986f5582 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#77 0x00007f8b986f577f in QEventLoop::exec (this=0x7fff673346e0, flags=...) at kernel/qeventloop.cpp:201
#78 0x00007f8b986f9877 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#79 0x00007f8b8221c959 in kdemain (argc=1, argv=0x6ee480) at /usr/src/debug/kde-base/plasma-workspace-4.6.3/plasma-workspace-4.6.3/plasma/desktop/shell/main.cpp:120
#80 0x00000000004089bb in launch (argc=1, _name=0x68ffe8 "/usr/bin/plasma-desktop", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40c199 "0") at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3/kinit/kinit.cpp:734
#81 0x00000000004097b4 in handle_launcher_request (sock=7, who=<value optimized out>) at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3/kinit/kinit.cpp:1226
#82 0x0000000000409ccc in handle_requests (waitForPid=0) at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3/kinit/kinit.cpp:1419
#83 0x000000000040552d in main (argc=2, argv=0x7fff67335428, envp=0x7fff67335440) at /usr/src/debug/kde-base/kdelibs-4.6.3/kdelibs-4.6.3/kinit/kinit.cpp:1907

This bug may be a duplicate of or related to bug 258706.

Possible duplicates by query: bug 270186, bug 269672, bug 269199, bug 268171, bug 268157.

Reported using DrKonqi
Comment 1 Dario Andres 2011-05-12 00:56:18 UTC
[Comment from a bug report cleaner]
This is bug 258706. The fix was not included in 4.6.3 (it will be for 4.6.4) ; but some distributions may include it now.
Regards

*** This bug has been marked as a duplicate of bug 258706 ***