Bug 273096 - ? is displaying in the place of autoshapes, diagrams in Doc files
Summary: ? is displaying in the place of autoshapes, diagrams in Doc files
Status: VERIFIED FIXED
Alias: None
Product: calligrawords
Classification: Unclassified
Component: doc (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Matus Uzak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-12 07:52 UTC by swathi
Modified: 2011-07-26 12:30 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Test data (23.00 KB, application/octet-stream)
2011-05-12 07:52 UTC, swathi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description swathi 2011-05-12 07:52:07 UTC
Created attachment 59924 [details]
Test data

Version: git checkout 98c50cff00a121ef276357dabbaa5586ec121c39
        (Using KDE 4.5.5)                
     OS: Kubuntu 10.10
Test data is in MS Word 2003 format which has autoshapes in it.
Open the same document in calligra words .

Expected outcome:
? should not be displayed.
Actual outcome:
? is displaying.
Please check the screenshots attached.
Frequency:
Always.
Comment 1 swathi 2011-05-12 07:52:34 UTC
Same issue is observed with diagrams in Doc files also.
Comment 2 Matus Uzak 2011-05-31 21:04:22 UTC
Git commit 4fdcd7faa24bb9321c022736ebe729e519f16717 by Matus Uzak.
Committed on 31/05/2011 at 20:58.
Pushed by uzak into branch 'master'.

DOC: Improved processing of the msosptPictureFrame shape.

* Set the draw:z-index attribute of inline objects to ZERO.
* Check for diagram drawing canvas placed inline with surrounding text,
  which is of type msosptPictureFrame.
* Fixed the definition of DiagramBooleanProperties, which was identical
  to ProtectionBooleanProperties.

BUG:273096

M  +6    -0    filters/libmso/OPID     
M  +9    -0    filters/libmso/drawstyle.cpp     
M  +15   -8    filters/libmso/drawstyle.h     
M  +16   -22   filters/libmso/generated/simpleParser.cpp     
M  +16   -22   filters/libmso/generated/simpleParser.h     
M  +9    -9    filters/libmso/shapes.cpp     
M  +23   -12   filters/words/msword-odf/graphicshandler.cpp     

http://commits.kde.org/calligra/4fdcd7faa24bb9321c022736ebe729e519f16717
Comment 3 swathi 2011-06-10 09:15:48 UTC
Verified in  8288143b7c1f9f9005209b55b651875219b0e9d6.
Comment 4 Matus Uzak 2011-07-26 12:30:46 UTC
*** Bug 239569 has been marked as a duplicate of this bug. ***