Bug 239569 - In the place of pyramid diagram ? is displaying.
Summary: In the place of pyramid diagram ? is displaying.
Status: VERIFIED FIXED
Alias: None
Product: calligrastage
Classification: Applications
Component: filter/ppt (show other bugs)
Version: unspecified
Platform: unspecified All
: NOR normal (vote)
Target Milestone: ---
Assignee: Matus Uzak
URL:
Keywords: reproducible
Depends on:
Blocks:
 
Reported: 2009-12-03 10:46 UTC by Lassi Nieminen
Modified: 2011-08-23 11:59 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Test document to be tested in Kpresenter and Powerpoint 2003. (54.00 KB, application/vnd.ms-powerpoint)
2009-12-03 10:46 UTC, Lassi Nieminen
Details
Screenshot when viewed in Kpresenter. (156.04 KB, image/pjpeg)
2009-12-03 10:46 UTC, Lassi Nieminen
Details
Screenshot when viewed in Powerpoint 2003. (25.05 KB, image/pjpeg)
2009-12-03 10:48 UTC, Lassi Nieminen
Details
koconverter converted testdata (3.25 KB, application/x-zip-compressed)
2010-03-02 13:22 UTC, Lassi Nieminen
Details
pyodconverter converted testdata (15.30 KB, application/x-zip-compressed)
2010-03-02 13:23 UTC, Lassi Nieminen
Details
screenshot of pyodconverter converted testdata opened in koffice screenshot (138.45 KB, image/x-png)
2010-03-02 13:23 UTC, Lassi Nieminen
Details
screenshot of koconverter converted testdata opened in openoffice (120.94 KB, image/x-png)
2010-03-02 13:24 UTC, Lassi Nieminen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Faure 2010-05-28 03:24:05 UTC


---- Reported by lassi.ta.nieminen@nokia.com 2009-12-03 11:46:20 +0200 ----

Created an attachment
Test document to be tested in Kpresenter and Powerpoint 2003.

SOFTWARE VERSION:
Kubuntu version 9.04
KOffice Version 1056420
Test Document(MS Office 2003): mp03_3d_color_pyramid.ppt

STEPS LEADING TO PROBLEM: 

1.Open the PPT in MS Powerpoint 2003.
2.Open the same document in KPresenter.
3.Observe the first slide.


EXPECTED OUTCOME:
The 3d color pyramid graph should be displayed.See
attachment(mp03_3d_color_pyramid.jpeg)

ACTUAL OUTCOME:
The 3d color pyramid graph is not displayed.See attachment(kp03_3d_color_pyramid.jpeg)

FREQUENCY OF OCCURRENCE: 
Always



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-12-03 11:46:51 +0200 ----

Created an attachment
Screenshot when viewed in Kpresenter.



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-12-03 11:48:31 +0200 ----

Created an attachment
Screenshot when viewed in Powerpoint 2003.



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-03-02 14:22:35 +0200 ----

Created an attachment
koconverter converted testdata



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-03-02 14:23:05 +0200 ----

Created an attachment
pyodconverter converted testdata



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-03-02 14:23:41 +0200 ----

Created an attachment
screenshot of pyodconverter converted testdata opened in koffice screenshot



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-03-02 14:24:34 +0200 ----

Created an attachment
screenshot of koconverter converted testdata opened in openoffice



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-03-02 14:37:21 +0200 ----

Observation in version 1096327 for MSOffice 2000
OpenOffice loads KO converted document better.(color does not match)



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-03-12 16:13:26 +0200 ----

This one is probably a lot of work.



--- Bug imported by faure@kde.org 2010-05-28 03:24  ---

This bug was previously known as _bug_ 149243.

Imported an attachment (id=46361)
Imported an attachment (id=46362)
Imported an attachment (id=46363)
Imported an attachment (id=46364)
Imported an attachment (id=46365)
Imported an attachment (id=46366)
Imported an attachment (id=46367)

Unknown bug field "example" encountered while moving bug
   <example>2010-03-12 16:13:26</example>

Comment 1 swathi 2011-04-27 14:42:39 UTC
IN  text-layoutrestructure-boemann  branch,in the place of pyramid diagram "?" is displaying.
Comment 2 LukasT 2011-07-13 10:37:59 UTC
It is displaying diagram now, but it is not 3D
Comment 3 Matus Uzak 2011-07-26 12:30:46 UTC
Please report the cycle diagram related issue as a separate bug.

*** This bug has been marked as a duplicate of bug 273096 ***
Comment 4 swathi 2011-08-23 10:51:50 UTC
Reopening the bug.bug 273096  is for doc format,where as the current bug is for ppt format.
Comment 5 swathi 2011-08-23 10:53:03 UTC
In revision  bf7bf12d4548e039e80e0dc863d3f4039745f8bd,Pyramid diagram is displaying fine.
Comment 6 Matus Uzak 2011-08-23 11:46:50 UTC
It's the same issue as reported for bug 273096, which was fixed in libmso.

commit 4fdcd7faa24bb9321c022736ebe729e519f16717
Comment 7 swathi 2011-08-23 11:59:44 UTC
Verified in bf7bf12d4548e039e80e0dc863d3f4039745f8bd.