Bug 272690 - KWin crash viewing bbc iplayer in fullscreen on kubuntu
Summary: KWin crash viewing bbc iplayer in fullscreen on kubuntu
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-07 12:09 UTC by email
Modified: 2011-05-09 03:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (11.52 KB, text/plain)
2011-05-09 03:57 UTC, sergio.realybodas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description email 2011-05-07 12:09:13 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.35-25-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

Playing a video on http://www.bbc.co.uk/iplayer/. During playing on fullscreen mode, in firefox 4.0, I periodically had this KWin crash afterwhich fullscreen mode was terminated. The video continued playing though, and I could return to fullscreen again. After around 5 minutes the crash occured again. When not in fullscreen mode I did not get any crashes after 15 minutes of viewing.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7801720 (LWP 5287))]

Thread 3 (Thread 0xb2e11b70 (LWP 5342)):
#0  0x00ae6416 in __kernel_vsyscall ()
#1  0x001d9681 in select () from /lib/i386-linux-gnu/libc.so.6
#2  0x011fc38b in qt_safe_select (nfds=20, fdread=0x8ba1838, fdwrite=0x8ba1a4c, fdexcept=0x8ba1c60, orig_timeout=0x0) at kernel/qcore_unix.cpp:82
#3  0x012006e9 in QEventDispatcherUNIX::select (this=0x8e19d28, nfds=20, readfds=0x8ba1838, writefds=0x8ba1a4c, exceptfds=0x8ba1c60, timeout=0x0) at kernel/qeventdispatcher_unix.cpp:632
#4  0x0120166b in QEventDispatcherUNIXPrivate::doSelect (this=0x8ba1740, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#5  0x01202326 in QEventDispatcherUNIX::processEvents (this=0x8e19d28, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#6  0x011d1289 in QEventLoop::processEvents (this=0xb2e11280, flags=...) at kernel/qeventloop.cpp:149
#7  0x011d1522 in QEventLoop::exec (this=0xb2e11280, flags=...) at kernel/qeventloop.cpp:201
#8  0x010db2a0 in QThread::exec (this=0x8dc3ce0) at thread/qthread.cpp:492
#9  0x011b2fdb in QInotifyFileSystemWatcherEngine::run (this=0x8dc3ce0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x010ddda2 in QThreadPrivate::start (arg=0x8dc3ce0) at thread/qthread_unix.cpp:320
#11 0x06a3ee99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb2608b70 (LWP 5343)):
#0  0x00ae6416 in __kernel_vsyscall ()
#1  0x06a4348c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x001ee3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x00f63817 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x10771c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x00f63851 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x10771c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x06a3ee99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7801720 (LWP 5287)):
[KCrash Handler]
#7  intel_region_buffer (intel=0x87e53c0, region=0x0, flag=2) at intel_regions.c:514
#8  0x04147ce2 in intelClearWithBlit (ctx=0x87e53c0, mask=2) at intel_blit.c:262
#9  0x0414a4c0 in intelClear (ctx=0x87e53c0, mask=2) at intel_clear.c:177
#10 0x04afb512 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0x00d9184b in KWin::SceneOpenGL::paintBackground (this=0x881aeb0, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x00d88562 in KWin::Scene::paintGenericScreen (this=0x881aeb0, orig_mask=40) at ../../kwin/scene.cpp:188
#13 0x00d91a31 in KWin::SceneOpenGL::paintGenericScreen (this=0x881aeb0, mask=40, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x00d857c0 in KWin::Scene::finalPaintScreen (this=0x881aeb0, mask=40, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x00da70fc in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=40, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x04d470e9 in KWin::StartupFeedbackEffect::paintScreen (this=0x8d5b580, mask=40, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x006c6256 in KWin::Effect::paintScreen (this=0x8d5ee98, mask=40, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x04ce907f in KWin::LogoutEffect::paintScreen (this=0x8c394c8, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x04d04b10 in KWin::ShadowEffect::paintScreen (this=0x8d46360, mask=40, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x04d19013 in KWin::BlurEffect::paintScreen (this=0x8b77108, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x04cede6f in KWin::PresentWindowsEffect::paintScreen (this=0x8b77b00, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x006c6256 in KWin::Effect::paintScreen (this=0x8c917d8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x006c6256 in KWin::Effect::paintScreen (this=0x8c62910, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x006c6256 in KWin::Effect::paintScreen (this=0x8c3f7e0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x006c6256 in KWin::Effect::paintScreen (this=0x8bcdec0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x04cd47e9 in KWin::DesktopGridEffect::paintScreen (this=0x8b6f7b8, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#37 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x006c6256 in KWin::Effect::paintScreen (this=0x8b7b6b0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#39 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x04ccd799 in KWin::BoxSwitchEffect::paintScreen (this=0x8d5a370, mask=8, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#41 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x04d27bcc in KWin::CubeEffect::paintScreen (this=0x8c39590, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#43 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x006c6256 in KWin::Effect::paintScreen (this=0x8cc4b18, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#45 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x006c6256 in KWin::Effect::paintScreen (this=0x8cb1d10, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#47 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x006c6256 in KWin::Effect::paintScreen (this=0x8bd5e98, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#49 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x04d20a0c in KWin::CoverSwitchEffect::paintScreen (this=0x8c38e68, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#51 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x006c6256 in KWin::Effect::paintScreen (this=0x8b53cf0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#53 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0x006c6256 in KWin::Effect::paintScreen (this=0x8b7abd0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#55 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#56 0x04d160c1 in KWin::ZoomEffect::paintScreen (this=0x8d44ab0, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#57 0x00da7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8b236f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#58 0x00d8698c in KWin::Scene::paintScreen (this=0x881aeb0, mask=0xbfe11b18, region=0xbfe11ba0) at ../../kwin/scene.cpp:137
#59 0x00d9d962 in KWin::SceneOpenGL::paint (this=0x881aeb0, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#60 0x00d82886 in KWin::Workspace::performCompositing (this=0x8b15300) at ../../kwin/composite.cpp:448
#61 0x011e7214 in QObject::event (this=0x8b15300, e=0xbfe120cc) at kernel/qobject.cpp:1190
#62 0x02190d24 in QApplicationPrivate::notify_helper (this=0x872ac58, receiver=0x8b15300, e=0xbfe120cc) at kernel/qapplication.cpp:4462
#63 0x021958ce in QApplication::notify (this=0xbfe123e4, receiver=0x8b15300, e=0xbfe120cc) at kernel/qapplication.cpp:3862
#64 0x004523ca in KApplication::notify (this=0xbfe123e4, receiver=0x8b15300, event=0xbfe120cc) at ../../kdeui/kernel/kapplication.cpp:311
#65 0x00d11abf in KWin::Application::notify (this=0xbfe123e4, o=0x8b15300, e=0xbfe120cc) at ../../kwin/main.cpp:376
#66 0x011d20bb in QCoreApplication::notifyInternal (this=0xbfe123e4, receiver=0x8b15300, event=0xbfe120cc) at kernel/qcoreapplication.cpp:731
#67 0x012021e4 in sendEvent (this=0x872bd58) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#68 QTimerInfoList::activateTimers (this=0x872bd58) at kernel/qeventdispatcher_unix.cpp:604
#69 0x01202338 in QEventDispatcherUNIX::processEvents (this=0x86e9aa8, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#70 0x022457ea in QEventDispatcherX11::processEvents (this=0x86e9aa8, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#71 0x011d1289 in QEventLoop::processEvents (this=0xbfe12324, flags=...) at kernel/qeventloop.cpp:149
#72 0x011d1522 in QEventLoop::exec (this=0xbfe12324, flags=...) at kernel/qeventloop.cpp:201
#73 0x011d5ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#74 0x0218e8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#75 0x00d145b2 in kdemain (argc=3, argv=0xbfe12664) at ../../kwin/main.cpp:542
#76 0x080485bb in main (argc=3, argv=0xbfe12664) at kwin_dummy.cpp:3

Possible duplicates by query: bug 272646, bug 272524, bug 272506, bug 272484, bug 272448.

Reported using DrKonqi
Comment 1 Martin Flöser 2011-05-07 12:15:20 UTC
driver bug

*** This bug has been marked as a duplicate of bug 252817 ***
Comment 2 sergio.realybodas 2011-05-09 03:57:18 UTC
Created attachment 59787 [details]
New crash information added by DrKonqi

kwin (4.6.2 (4.6.2)) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:
when i want to minimize the full screen, when i was watching a movie

-- Backtrace (Reduced):
#7  intel_region_buffer (intel=0x94abfc0, region=0x0, flag=2) at intel_regions.c:514
#8  0x08f8bce2 in intelClearWithBlit (ctx=0x94abfc0, mask=2) at intel_blit.c:262
#9  0x08f8e4c0 in intelClear (ctx=0x94abfc0, mask=2) at intel_clear.c:177
#10 0x045ca512 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0x00b8d84b in KWin::SceneOpenGL::paintBackground (this=0x93d5340, region=...) at ../../kwin/scene_opengl.cpp:921