Bug 272646 - Close Full SCreen
Summary: Close Full SCreen
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-06 20:33 UTC by subcoolent
Modified: 2011-05-08 23:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (10.55 KB, text/plain)
2011-05-08 23:26 UTC, abadmanx
Details

Note You need to log in before you can comment on or make changes to this bug.
Description subcoolent 2011-05-06 20:33:00 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
When i closed the full screen view of a streaming video, the Kwin crashed. Again....

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78c7720 (LWP 1927))]

Thread 3 (Thread 0xb1a04b70 (LWP 1933)):
#0  0x00dddd41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x039c9dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x03a964f2 in updateCurrentTime (this=0x963a460, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x963a460, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x03a983a3 in QEventDispatcherUNIX::processEvents (this=0x96394b0, flags=...) at kernel/qeventdispatcher_unix.cpp:906
#6  0x03a67289 in QEventLoop::processEvents (this=0xb1a04280, flags=...) at kernel/qeventloop.cpp:149
#7  0x03a67522 in QEventLoop::exec (this=0xb1a04280, flags=...) at kernel/qeventloop.cpp:201
#8  0x039712a0 in QThread::exec (this=0x963fd10) at thread/qthread.cpp:492
#9  0x03a48fdb in QInotifyFileSystemWatcherEngine::run (this=0x963fd10) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x03973da2 in QThreadPrivate::start (arg=0x963fd10) at thread/qthread_unix.cpp:320
#11 0x00dbce99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb11fbb70 (LWP 1934)):
#0  0x00de5416 in __kernel_vsyscall ()
#1  0x00dc148c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x001ee3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x00f6d817 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x10811c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x00f6d851 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x10811c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x00dbce99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb78c7720 (LWP 1927)):
[KCrash Handler]
#7  intel_region_buffer (intel=0x8fd4dd8, region=0x0, flag=2) at intel_regions.c:514
#8  0x04555ce2 in intelClearWithBlit (ctx=0x8fd4dd8, mask=2) at intel_blit.c:262
#9  0x045584c0 in intelClear (ctx=0x8fd4dd8, mask=2) at intel_clear.c:177
#10 0x02586512 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0x009a184b in KWin::SceneOpenGL::paintBackground (this=0x9012da0, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x00998562 in KWin::Scene::paintGenericScreen (this=0x9012da0, orig_mask=32) at ../../kwin/scene.cpp:188
#13 0x009a1a31 in KWin::SceneOpenGL::paintGenericScreen (this=0x9012da0, mask=32, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x009957c0 in KWin::Scene::finalPaintScreen (this=0x9012da0, mask=32, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x009b70fc in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=32, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x027d20e9 in KWin::StartupFeedbackEffect::paintScreen (this=0x9489490, mask=32, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x002a0256 in KWin::Effect::paintScreen (this=0x9542f18, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x0277407f in KWin::LogoutEffect::paintScreen (this=0x94541d0, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x0278fb10 in KWin::ShadowEffect::paintScreen (this=0x94b68a0, mask=32, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x027a4013 in KWin::BlurEffect::paintScreen (this=0x936a760, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x02778e6f in KWin::PresentWindowsEffect::paintScreen (this=0x94403f8, mask=0, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x002a0256 in KWin::Effect::paintScreen (this=0x93f2610, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x002a0256 in KWin::Effect::paintScreen (this=0x93a7e00, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x002a0256 in KWin::Effect::paintScreen (this=0x94ba8c8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x002a0256 in KWin::Effect::paintScreen (this=0x94257d0, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x002a0256 in KWin::Effect::paintScreen (this=0x93cbdc0, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#37 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x002a0256 in KWin::Effect::paintScreen (this=0x93d5e68, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#39 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x002a0256 in KWin::Effect::paintScreen (this=0x9345918, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#41 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x0275f7e9 in KWin::DesktopGridEffect::paintScreen (this=0x94446a8, mask=0, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#43 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x002a0256 in KWin::Effect::paintScreen (this=0x943a2c0, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#45 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x02758799 in KWin::BoxSwitchEffect::paintScreen (this=0x9386508, mask=0, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#47 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x027b2bcc in KWin::CubeEffect::paintScreen (this=0x957ccd0, mask=0, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#49 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x002a0256 in KWin::Effect::paintScreen (this=0x95a9560, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#51 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x002a0256 in KWin::Effect::paintScreen (this=0x9426670, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#53 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0x002a0256 in KWin::Effect::paintScreen (this=0x9453e40, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#55 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#56 0x027aba0c in KWin::CoverSwitchEffect::paintScreen (this=0x9516b78, mask=0, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#57 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#58 0x002a0256 in KWin::Effect::paintScreen (this=0x9448fb0, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#59 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#60 0x002a0256 in KWin::Effect::paintScreen (this=0x93698e8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#61 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#62 0x002a0256 in KWin::Effect::paintScreen (this=0x954b2a8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#63 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#64 0x002a0256 in KWin::Effect::paintScreen (this=0x936b870, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#65 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#66 0x027a10c1 in KWin::ZoomEffect::paintScreen (this=0x9516e00, mask=0, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#67 0x009b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x916ad60, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#68 0x0099698c in KWin::Scene::paintScreen (this=0x9012da0, mask=0xbfe071e8, region=0xbfe07270) at ../../kwin/scene.cpp:137
#69 0x009ad962 in KWin::SceneOpenGL::paint (this=0x9012da0, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#70 0x00992886 in KWin::Workspace::performCompositing (this=0x9304cc0) at ../../kwin/composite.cpp:448
#71 0x03a7d214 in QObject::event (this=0x9304cc0, e=0xbfe0779c) at kernel/qobject.cpp:1190
#72 0x074ccd24 in QApplicationPrivate::notify_helper (this=0x8f2ecf0, receiver=0x9304cc0, e=0xbfe0779c) at kernel/qapplication.cpp:4462
#73 0x074d18ce in QApplication::notify (this=0xbfe07ab4, receiver=0x9304cc0, e=0xbfe0779c) at kernel/qapplication.cpp:3862
#74 0x005663ca in KApplication::notify (this=0xbfe07ab4, receiver=0x9304cc0, event=0xbfe0779c) at ../../kdeui/kernel/kapplication.cpp:311
#75 0x00921abf in KWin::Application::notify (this=0xbfe07ab4, o=0x9304cc0, e=0xbfe0779c) at ../../kwin/main.cpp:376
#76 0x03a680bb in QCoreApplication::notifyInternal (this=0xbfe07ab4, receiver=0x9304cc0, event=0xbfe0779c) at kernel/qcoreapplication.cpp:731
#77 0x03a981e4 in sendEvent (this=0x8f31118) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#78 QTimerInfoList::activateTimers (this=0x8f31118) at kernel/qeventdispatcher_unix.cpp:604
#79 0x03a98338 in QEventDispatcherUNIX::processEvents (this=0x8eeeaa8, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#80 0x075817ea in QEventDispatcherX11::processEvents (this=0x8eeeaa8, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#81 0x03a67289 in QEventLoop::processEvents (this=0xbfe079f4, flags=...) at kernel/qeventloop.cpp:149
#82 0x03a67522 in QEventLoop::exec (this=0xbfe079f4, flags=...) at kernel/qeventloop.cpp:201
#83 0x03a6becc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#84 0x074ca8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#85 0x009245b2 in kdemain (argc=3, argv=0xbfe07d34) at ../../kwin/main.cpp:542
#86 0x080485bb in main (argc=3, argv=0xbfe07d34) at kwin_dummy.cpp:3

Possible duplicates by query: bug 272524, bug 272506, bug 272484, bug 272448, bug 272331.

Reported using DrKonqi
Comment 1 Martin Flöser 2011-05-06 20:51:50 UTC
driver bug

*** This bug has been marked as a duplicate of bug 252817 ***
Comment 2 abadmanx 2011-05-08 23:26:25 UTC
Created attachment 59783 [details]
New crash information added by DrKonqi

kwin (4.6.2 (4.6.2)) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:
I was watching a video on G4TV with the fullscreen mode, Skyrim baby! I had installed the Smooth tasks plasma KDE plasmoid a few days ago from here: 

https://bitbucket.org/jimi312/smooth-tasks-kde-sc-4.6

After the video finished, I hit the escape button and Kwin crashed.

- Unusual behavior I noticed:
While watching the video, the video flickered in the beginning and then when I raised the volume with the Function + Volume increase keys.

-- Backtrace (Reduced):
#7  intel_region_buffer (intel=0x8ebe800, region=0x0, flag=2) at intel_regions.c:514
#8  0xafcface2 in intelClearWithBlit (ctx=0x8ebe800, mask=2) at intel_blit.c:262
#9  0xafcfd4c0 in intelClear (ctx=0x8ebe800, mask=2) at intel_clear.c:177
#10 0xafb27512 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0xb77f984b in KWin::SceneOpenGL::paintBackground (this=0x8efaad8, region=...) at ../../kwin/scene_opengl.cpp:921