Bug 27212 - It should be possible to set maximum speed of the ftp transfer
Summary: It should be possible to set maximum speed of the ftp transfer
Status: RESOLVED DUPLICATE of bug 50898
Alias: None
Product: kio
Classification: Unclassified
Component: ftp (show other bugs)
Version: unspecified
Platform: RedHat RPMs Linux
: NOR wishlist with 60 votes (vote)
Target Milestone: ---
Assignee: Thiago Macieira
URL:
Keywords:
: 77932 (view as bug list)
Depends on:
Blocks:
 
Reported: 2001-06-14 14:33 UTC by krzyko
Modified: 2012-03-05 16:34 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description krzyko 2001-06-14 14:26:07 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kio-ftp
Version:           unknown (using KDE 2.1.2 )
Severity:          wishlist
Installed from:    Red Hat Linux 6.2
Compiler:          gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)
OS:                Linux 2.4.4 i686
OS/Compiler notes: 

Hi

It should be possible to set limits for the incoming ftp transfer. What this is for ? 

Yesterday I've started to download iso's of my linux distro (I'm preparing to an upgrade). 
The transfer was about 100-150 kB/s (byte) (this was more than half of our bandwidth). 
After downloading 500 MB my network's admin disconnected me from the network because I was generating too much traffic (and other people couldn't use the internet - the network is designed for the 100 people). 

If I could set the maximum speed of the connection (to not annoy my network's admin and to let other use the internet) life would be easier :)

regards
Krzysztof Kosz


(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 David Anderson 2005-03-29 16:19:31 UTC
Yes please - or maybe a more generic implementation so that it could be applied to any kioslave? (Or at least any kioslave that pops up a 'progress' dialogue).

Often I'm downloading some big bit of software (e.g. KDE 3.4!) and it uses all my bandwidth - which means I have to stop the transfer if someone rings me on Skype or if I want to ring out on VOIP, etc. Rather than stopping and restarting, it would be nice to be able to scale down the bandwidth. At the moment I "solve" this problem by opening up a terminal and using wget.

Maybe the kio dialogue could have a little link text "reduce" next to where it shows the current speed. The kio dialogue could remember the maximum speed so far attained - and when you click on "reduce" it would bring up a little window with a little slider where you could select a smaller speed.

Obviously it's not just the dialogue, but the underlying kio process, which needs somehow to be able to control its speed.... is that difficult? Presumably it can be done somewhere in the shared code, with micro-sleeps?!? Or would every kioslave have to be hacked? (I'm no expert here!).
Comment 2 Thiago Macieira 2005-03-29 17:17:42 UTC
I'm sorry, but if you run bandwidth sensitive applications, you should add QoS rules to your network. To not do so would be a grave problem on your part.

This does not negate the wish, though. But it doesn't make it any more a priority.
Comment 3 Thiago Macieira 2005-03-30 02:33:18 UTC
< dfaure> thiago: for 27212 - if wget can do it, shouldn't we be able to do it too, in a similar way? :/

Yes, we can do it. I meant that having bandwidth limiter in our FTP, or in all kioslaves, doesn't mean a proper QoS isn't necessary for bandwidth-sensitive applications. Therefore, it isn't an argument for implementing it.

Reassigning to myself.
Comment 4 David Anderson 2005-03-30 21:40:11 UTC
You're right, it's not a great example. A better example would be a common one that I have at work. The office shares 512kbps. Say I want to download a big bit of software via HTTP during the course of the day, but slowly so as not to slow down other users of HTTP (including myself). I can't use QoS to distinguish between one Konqueror download and another, so this would be a place where the feature would be useful in KDE. (As I say, currently I just drop down to the shell and wget).

Of course, not everyone knows how to do QoS! e.g. Home networks with ADSL modems - not everyone's a network technician!
Comment 5 madman 2006-03-25 17:27:41 UTC
My vote for it also. It's quite hard to implement QoS on a desktop computer connected directly to an ADSL modem or a simple wireless router. Bandwidth limiting would be great for <1Mbps connections used by more than one device, where downloading a file at full speed causes total network jam.
Best idea, IMHO, would be to add a limiter slider to every kioslave download dialog. It would be also a good idea to support a global per-download limit in KDE Control Center.
Comment 6 Martin Koller 2006-11-04 22:02:56 UTC
*** Bug 77932 has been marked as a duplicate of this bug. ***
Comment 7 Miguel De Anda 2008-12-19 06:51:48 UTC
this seems very similar to
https://bugs.kde.org/show_bug.cgi?id=134821
Comment 8 BRULE Herman 2009-12-12 20:11:07 UTC
Same for all protocol via the KDE API (sftp, ftp, ...) for KDE 4.4 or more
Comment 9 Dawit Alemayehu 2012-03-05 16:34:45 UTC

*** This bug has been marked as a duplicate of bug 50898 ***