Bug 271927 - plasma-desktop crashed when quitting knote (in systray)
Summary: plasma-desktop crashed when quitting knote (in systray)
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-28 17:10 UTC by Greg Metcalfe
Modified: 2011-05-01 14:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Metcalfe 2011-04-28 17:10:59 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.35.12-88.fc14.i686.PAE i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
Right-click, Quit on knote, which was in the system tray.
- Unusual behavior I noticed:
For several days I've found plasma-desktop CPU usage climbing to 100%. Last time I looked at hidden icons, and closed the printer applet, which  fixed it. This time the crash of knote reduced it to backgound levels (top is reporting .01-.02 I type this).

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[KCrash Handler]
#7  ref (this=0x9050048, group=0, state=0) at /usr/include/QtCore/qatomic_i386.h:120
#8  QString (this=0x9050048, group=0, state=0) at /usr/include/QtCore/qstring.h:729
#9  KIconEffect::fingerprint (this=0x9050048, group=0, state=0) at /usr/src/debug/kdelibs-4.6.2/kdeui/icons/kiconeffect.cpp:169
#10 0x061eb2f3 in KIconLoaderPrivate::makeCacheKey (this=0x9050034, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at /usr/src/debug/kdelibs-4.6.2/kdeui/icons/kiconloader.cpp:782
#11 0x061f2811 in KIconLoader::loadIcon (this=0x9504f38, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kdelibs-4.6.2/kdeui/icons/kiconloader.cpp:1226
#12 0x061e9ce7 in KIconEngine::pixmap (this=0x99f0dc8, size=..., mode=QIcon::Normal, state=QIcon::Off) at /usr/src/debug/kdelibs-4.6.2/kdeui/icons/kiconengine.cpp:93
#13 0x42286803 in QIcon::pixmap (this=0x994fb74, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#14 0x030ebdb9 in Plasma::IconWidgetPrivate::decoration (this=0x994fad0, option=0x9036cd0, useHoverEffect=true, usePressedEffect=false) at /usr/src/debug/kdelibs-4.6.2/plasma/widgets/iconwidget.cpp:812
#15 0x030f27a0 in Plasma::IconWidget::paint (this=0x995fa68, painter=0xbfb6744c, option=0x9036cd0, widget=0x0) at /usr/src/debug/kdelibs-4.6.2/plasma/widgets/iconwidget.cpp:1128
#16 0x0107a78e in ?? () from /usr/lib/kde4/plasma_applet_systemtray.so
#17 0x4284673c in _q_paintItem (item=<value optimized out>, painter=0xbfb6744c, option=0x9036cd0, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#18 0x42846a6d in _q_paintIntoCache (pix=0xbfb6792c, item=0x995fa70, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x9036cd0, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#19 0x4285afd5 in QGraphicsScenePrivate::drawItemHelper (this=0x9036b80, item=0x995fa70, painter=0xbfb69124, option=0x9036cd0, widget=0x951d798, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#20 0x4285bc72 in QGraphicsScenePrivate::draw (this=0x9036b80, item=0x995fa70, painter=0xbfb69124, viewTransform=0xbfb68f0c, transformPtr=0xbfb67d10, exposedRegion=0x9505b20, widget=0x951d798, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#21 0x4285c9ba in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9036b80, item=0x995fa70, painter=0xbfb69124, viewTransform=0xbfb68f0c, exposedRegion=0x9505b20, widget=0x951d798, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0x4285ba9c in QGraphicsScenePrivate::draw (this=0x9036b80, item=0x9252238, painter=0xbfb69124, viewTransform=0xbfb68f0c, transformPtr=0xbfb681b0, exposedRegion=0x9505b20, widget=0x951d798, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#23 0x4285c9ba in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9036b80, item=0x9252238, painter=0xbfb69124, viewTransform=0xbfb68f0c, exposedRegion=0x9505b20, widget=0x951d798, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0x4285ba9c in QGraphicsScenePrivate::draw (this=0x9036b80, item=0x9118580, painter=0xbfb69124, viewTransform=0xbfb68f0c, transformPtr=0xbfb68650, exposedRegion=0x9505b20, widget=0x951d798, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#25 0x4285c9ba in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9036b80, item=0x9118580, painter=0xbfb69124, viewTransform=0xbfb68f0c, exposedRegion=0x9505b20, widget=0x951d798, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#26 0x4285ba9c in QGraphicsScenePrivate::draw (this=0x9036b80, item=0x90ed0f8, painter=0xbfb69124, viewTransform=0xbfb68f0c, transformPtr=0xbfb68af0, exposedRegion=0x9505b20, widget=0x951d798, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#27 0x4285c9ba in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9036b80, item=0x90ed0f8, painter=0xbfb69124, viewTransform=0xbfb68f0c, exposedRegion=0x9505b20, widget=0x951d798, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#28 0x4285d20e in QGraphicsScenePrivate::drawItems (this=0x9036b80, painter=0xbfb69124, viewTransform=0xbfb68f0c, exposedRegion=0x9505b20, widget=0x951d798) at graphicsview/qgraphicsscene.cpp:4735
#29 0x4287ccaf in QGraphicsView::paintEvent (this=0x9513418, event=0xbfb69824) at graphicsview/qgraphicsview.cpp:3469
#30 0x05738095 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#31 0x42229e1f in QWidget::event (this=0x9513418, event=0xbfb69824) at kernel/qwidget.cpp:8405
#32 0x42628724 in QFrame::event (this=0x9513418, e=0xbfb69824) at widgets/qframe.cpp:557
#33 0x426b86f3 in QAbstractScrollArea::viewportEvent (this=0x9513418, e=0xbfb69824) at widgets/qabstractscrollarea.cpp:1043
#34 0x4287e247 in QGraphicsView::viewportEvent (this=0x9513418, event=0xbfb69824) at graphicsview/qgraphicsview.cpp:2864
#35 0x426bb065 in viewportEvent (this=0x96ab448, o=0x951d798, e=0xbfb69824) at widgets/qabstractscrollarea_p.h:100
#36 QAbstractScrollAreaFilter::eventFilter (this=0x96ab448, o=0x951d798, e=0xbfb69824) at widgets/qabstractscrollarea_p.h:116
#37 0x0256b11a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8f85f18, receiver=0x951d798, event=0xbfb69824) at kernel/qcoreapplication.cpp:846
#38 0x421d0521 in QApplicationPrivate::notify_helper (this=0x8f85f18, receiver=0x951d798, e=0xbfb69824) at kernel/qapplication.cpp:4458
#39 0x421d52ff in QApplication::notify (this=0x8f733e8, receiver=0x951d798, e=0xbfb69824) at kernel/qapplication.cpp:4427
#40 0x062474bb in KApplication::notify (this=0x8f733e8, receiver=0x951d798, event=0xbfb69824) at /usr/src/debug/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:311
#41 0x0256af63 in QCoreApplication::notifyInternal (this=0x8f733e8, receiver=0x951d798, event=0xbfb69824) at kernel/qcoreapplication.cpp:731
#42 0x42226a2d in sendSpontaneousEvent (this=0x953f000, pdev=0x96ade84, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94fe1e8) at ../../src/corelib/kernel/qcoreapplication.h:218
#43 QWidgetPrivate::drawWidget (this=0x953f000, pdev=0x96ade84, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94fe1e8) at kernel/qwidget.cpp:5492
#44 0x4222773d in QWidgetPrivate::paintSiblingsRecursive (this=0x95057d0, pdev=0x96ade84, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94fe1e8) at kernel/qwidget.cpp:5699
#45 0x42227603 in QWidgetPrivate::paintSiblingsRecursive (this=0x95057d0, pdev=0x96ade84, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94fe1e8) at kernel/qwidget.cpp:5686
#46 0x42227603 in QWidgetPrivate::paintSiblingsRecursive (this=0x95057d0, pdev=0x96ade84, siblings=..., index=5, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94fe1e8) at kernel/qwidget.cpp:5686
#47 0x42226781 in QWidgetPrivate::drawWidget (this=0x95057d0, pdev=0x96ade84, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x94fe1e8) at kernel/qwidget.cpp:5545
#48 0x424068c1 in QWidgetBackingStore::sync (this=0x94fe1e8) at painting/qbackingstore.cpp:1333
#49 0x4221c053 in QWidgetPrivate::syncBackingStore (this=0x95057d0) at kernel/qwidget.cpp:1842
#50 0x4222a47d in QWidget::event (this=0x9513418, event=0x94f1570) at kernel/qwidget.cpp:8552
#51 0x42628724 in QFrame::event (this=0x9513418, e=0x94f1570) at widgets/qframe.cpp:557
#52 0x426ba4af in QAbstractScrollArea::event (this=0x9513418, e=0x94f1570) at widgets/qabstractscrollarea.cpp:996
#53 0x42871147 in QGraphicsView::event (this=0x9513418, event=0x94f1570) at graphicsview/qgraphicsview.cpp:2741
#54 0x057383e4 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#55 0x421d054c in QApplicationPrivate::notify_helper (this=0x8f85f18, receiver=0x9513418, e=0x94f1570) at kernel/qapplication.cpp:4462
#56 0x421d52ff in QApplication::notify (this=0x8f733e8, receiver=0x9513418, e=0x94f1570) at kernel/qapplication.cpp:4427
#57 0x062474bb in KApplication::notify (this=0x8f733e8, receiver=0x9513418, event=0x94f1570) at /usr/src/debug/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:311
#58 0x0256af63 in QCoreApplication::notifyInternal (this=0x8f733e8, receiver=0x9513418, event=0x94f1570) at kernel/qcoreapplication.cpp:731
#59 0x0256ecb5 in sendEvent (receiver=0x9513418, event_type=77, data=0x8f420e8) at kernel/qcoreapplication.h:215
#60 QCoreApplicationPrivate::sendPostedEvents (receiver=0x9513418, event_type=77, data=0x8f420e8) at kernel/qcoreapplication.cpp:1372
#61 0x0256ee8e in QCoreApplication::sendPostedEvents (receiver=0x9513418, event_type=77) at kernel/qcoreapplication.cpp:1265
#62 0x428533be in dispatchPendingUpdateRequests (this=0x9036b80) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#63 QGraphicsScenePrivate::_q_processDirtyItems (this=0x9036b80) at graphicsview/qgraphicsscene.cpp:510
#64 0x428537a6 in QGraphicsScene::qt_metacall (this=0x8f84ff0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x983a560) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#65 0x0302aceb in Plasma::Corona::qt_metacall (this=0x8f84ff0, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x983a560) at /usr/src/debug/kdelibs-4.6.2/i686-redhat-linux-gnu/plasma/corona.moc:109
#66 0x0572aa0b in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#67 0x0257179b in QMetaObject::metacall (object=0x8f84ff0, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x983a560) at kernel/qmetaobject.cpp:237
#68 0x0257c137 in QMetaCallEvent::placeMetaCall (this=0xa030df0, object=0x8f84ff0) at kernel/qobject.cpp:535
#69 0x025807cf in QObject::event (this=0x8f84ff0, e=0xa030df0) at kernel/qobject.cpp:1217
#70 0x42860bdc in QGraphicsScene::event (this=0x8f84ff0, event=0xa030df0) at graphicsview/qgraphicsscene.cpp:3544
#71 0x421d054c in QApplicationPrivate::notify_helper (this=0x8f85f18, receiver=0x8f84ff0, e=0xa030df0) at kernel/qapplication.cpp:4462
#72 0x421d5252 in QApplication::notify (this=0x8f733e8, receiver=0x8f84ff0, e=0xa030df0) at kernel/qapplication.cpp:3862
#73 0x062474bb in KApplication::notify (this=0x8f733e8, receiver=0x8f84ff0, event=0xa030df0) at /usr/src/debug/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:311
#74 0x0256af63 in QCoreApplication::notifyInternal (this=0x8f733e8, receiver=0x8f84ff0, event=0xa030df0) at kernel/qcoreapplication.cpp:731
#75 0x0256ecb5 in sendEvent (receiver=0x0, event_type=0, data=0x8f420e8) at kernel/qcoreapplication.h:215
#76 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8f420e8) at kernel/qcoreapplication.cpp:1372
#77 0x0256ee8e in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#78 0x02598b35 in sendPostedEvents (s=0x8f87500) at kernel/qcoreapplication.h:220
#79 postEventSourceDispatch (s=0x8f87500) at kernel/qeventdispatcher_glib.cpp:277
#80 0x008bc192 in g_main_dispatch (context=0x8f861d8) at gmain.c:2149
#81 g_main_context_dispatch (context=0x8f861d8) at gmain.c:2702
#82 0x008bc978 in g_main_context_iterate (context=0x8f861d8, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#83 0x008bcc35 in g_main_context_iteration (context=0x8f861d8, may_block=1) at gmain.c:2843
#84 0x02598cad in QEventDispatcherGlib::processEvents (this=0x8f41e50, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#85 0x422841c6 in QGuiEventDispatcherGlib::processEvents (this=0x8f41e50, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#86 0x0256a0fa in QEventLoop::processEvents (this=0xbfb6b314, flags=...) at kernel/qeventloop.cpp:149
#87 0x0256a3aa in QEventLoop::exec (this=0xbfb6b314, flags=...) at kernel/qeventloop.cpp:201
#88 0x0256ef57 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#89 0x421ce358 in QApplication::exec () at kernel/qapplication.cpp:3736
#90 0x057320e1 in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#91 0x0804883c in _start ()

Possible duplicates by query: bug 271923, bug 271876, bug 271845, bug 271801, bug 271782.

Reported using DrKonqi
Comment 1 Dario Andres 2011-05-01 14:53:42 UTC
[Comment from a bug triager]
This issue is a common crash and it is being tracked at bug 258706, merging.
Thanks

*** This bug has been marked as a duplicate of bug 258706 ***