Bug 271801 - Plasma crash when Ctl-Q out of Amarok
Summary: Plasma crash when Ctl-Q out of Amarok
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-26 19:45 UTC by Christopher Heiny
Modified: 2011-04-30 18:36 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (15.38 KB, text/plain)
2011-04-27 16:44 UTC, mjb
Details
New crash information added by DrKonqi (14.48 KB, text/plain)
2011-04-28 16:38 UTC, Alexander Ponyatikh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Heiny 2011-04-26 19:45:38 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.12-88.fc14.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
Playing music with Amarok. Time to power down, so I Ctl-Q'ed Amarok.  Plasma crashed.  Probably this is a duplicate, but maybe it isn't.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x0000003829be500f in QString (this=0x2840075, group=0, state=0) at /usr/include/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x2840075, group=0, state=0) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconeffect.cpp:169
#8  0x0000003829beab4b in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:782
#9  0x0000003829bf1c21 in KIconLoader::loadIcon (this=0x1575360, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:1226
#10 0x0000003829be97f0 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconengine.cpp:93
#11 0x000000382bc5e585 in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:676
#12 0x0000003835be67c1 in Plasma::IconWidgetPrivate::decoration (this=0x28fe8e0, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at /usr/src/debug/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:812
#13 0x0000003835bec65b in Plasma::IconWidget::paint (this=0x2833c00, painter=0x7fff0d640280, option=0x1403ad8, widget=<value optimized out>) at /usr/src/debug/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:1128
#14 0x00007ff744803719 in ?? () from /usr/lib64/kde4/plasma_applet_systemtray.so
#15 0x000000382c1a2f3d in _q_paintItem (item=<value optimized out>, painter=0x7fff0d640280, option=0x1403ad8, widget=0x0, useWindowOpacity=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#16 0x000000382c1a3250 in _q_paintIntoCache (pix=0x7fff0d6407d0, item=0x2833c10, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x1403ad8, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#17 0x000000382c1b71a2 in QGraphicsScenePrivate::drawItemHelper (this=0x14038b0, item=0x2833c10, painter=0x7fff0d6426d0, option=<value optimized out>, widget=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#18 0x000000382c1b78c1 in QGraphicsScenePrivate::draw (this=0x14038b0, item=0x2833c10, painter=0x7fff0d6426d0, viewTransform=0x7fff0d642460, transformPtr=0x7fff0d640e40, exposedRegion=0x228c690, widget=0x1acc760, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4931
#19 0x000000382c1b84b7 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x14038b0, item=0x2833c10, painter=0x7fff0d6426d0, viewTransform=0x7fff0d642460, exposedRegion=0x228c690, widget=0x1acc760, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#20 0x000000382c1b7958 in QGraphicsScenePrivate::draw (this=0x14038b0, item=0x18144e0, painter=0x7fff0d6426d0, viewTransform=0x7fff0d642460, transformPtr=0x7fff0d6413f0, exposedRegion=0x228c690, widget=0x1acc760, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4945
#21 0x000000382c1b84b7 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x14038b0, item=0x18144e0, painter=0x7fff0d6426d0, viewTransform=0x7fff0d642460, exposedRegion=0x228c690, widget=0x1acc760, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0x000000382c1b7958 in QGraphicsScenePrivate::draw (this=0x14038b0, item=0x183f910, painter=0x7fff0d6426d0, viewTransform=0x7fff0d642460, transformPtr=0x7fff0d6419a0, exposedRegion=0x228c690, widget=0x1acc760, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4945
#23 0x000000382c1b84b7 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x14038b0, item=0x183f910, painter=0x7fff0d6426d0, viewTransform=0x7fff0d642460, exposedRegion=0x228c690, widget=0x1acc760, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0x000000382c1b7958 in QGraphicsScenePrivate::draw (this=0x14038b0, item=0x1688730, painter=0x7fff0d6426d0, viewTransform=0x7fff0d642460, transformPtr=0x7fff0d641f50, exposedRegion=0x228c690, widget=0x1acc760, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4945
#25 0x000000382c1b84b7 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x14038b0, item=0x1688730, painter=0x7fff0d6426d0, viewTransform=0x7fff0d642460, exposedRegion=0x228c690, widget=0x1acc760, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#26 0x000000382c1b8d6c in QGraphicsScenePrivate::drawItems (this=0x14038b0, painter=0x7fff0d6426d0, viewTransform=0x7fff0d642460, exposedRegion=0x228c690, widget=0x1acc760) at graphicsview/qgraphicsscene.cpp:4735
#27 0x000000382c1d5e2c in QGraphicsView::paintEvent (this=0x1acca70, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3469
#28 0x000000382bc08f9a in QWidget::event (this=0x1acca70, event=0x7fff0d643020) at kernel/qwidget.cpp:8346
#29 0x000000382bfb3906 in QFrame::event (this=0x1acca70, e=0x7fff0d643020) at widgets/qframe.cpp:557
#30 0x000000382c1d70bb in QGraphicsView::viewportEvent (this=0x1acca70, event=0x7fff0d643020) at graphicsview/qgraphicsview.cpp:2864
#31 0x000000327955b937 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1acc760, event=0x7fff0d643020) at kernel/qcoreapplication.cpp:847
#32 0x000000382bbb7891 in QApplicationPrivate::notify_helper (this=0x1401840, receiver=0x1acc760, e=0x7fff0d643020) at kernel/qapplication.cpp:4441
#33 0x000000382bbbc3da in QApplication::notify (this=<value optimized out>, receiver=0x1acc760, e=0x7fff0d643020) at kernel/qapplication.cpp:4324
#34 0x0000003829c40466 in KApplication::notify (this=0x13f0cc0, receiver=0x1acc760, event=0x7fff0d643020) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#35 0x000000327955b7ac in QCoreApplication::notifyInternal (this=0x13f0cc0, receiver=0x1acc760, event=0x7fff0d643020) at kernel/qcoreapplication.cpp:732
#36 0x000000382bc05e68 in sendSpontaneousEvent (this=0x229e870, pdev=0x216b1d8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1f64fd0) at ../../src/corelib/kernel/qcoreapplication.h:218
#37 QWidgetPrivate::drawWidget (this=0x229e870, pdev=0x216b1d8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1f64fd0) at kernel/qwidget.cpp:5433
#38 0x000000382bc06a2f in QWidgetPrivate::paintSiblingsRecursive (this=0x228c200, pdev=0x216b1d8, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1f64fd0) at kernel/qwidget.cpp:5640
#39 0x000000382bc05baa in QWidgetPrivate::drawWidget (this=0x228c200, pdev=0x216b1d8, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x1f64fd0) at kernel/qwidget.cpp:5486
#40 0x000000382bdc8fe9 in QWidgetBackingStore::sync (this=0x1f64fd0) at painting/qbackingstore.cpp:1333
#41 0x000000382bbfc1b0 in QWidgetPrivate::syncBackingStore (this=0x228c200) at kernel/qwidget.cpp:1816
#42 0x000000382bc094a2 in QWidget::event (this=0x1acca70, event=0x1575360) at kernel/qwidget.cpp:8493
#43 0x000000382bfb3906 in QFrame::event (this=0x1acca70, e=0x1575360) at widgets/qframe.cpp:557
#44 0x000000382c034cab in QAbstractScrollArea::event (this=0x1acca70, e=0x1575360) at widgets/qabstractscrollarea.cpp:996
#45 0x0000003ea2043f30 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#46 0x000000382bbb78c4 in QApplicationPrivate::notify_helper (this=0x1401840, receiver=0x1acca70, e=0x1575360) at kernel/qapplication.cpp:4445
#47 0x000000382bbbc3da in QApplication::notify (this=<value optimized out>, receiver=0x1acca70, e=0x1575360) at kernel/qapplication.cpp:4324
#48 0x0000003829c40466 in KApplication::notify (this=0x13f0cc0, receiver=0x1acca70, event=0x1575360) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#49 0x000000327955b7ac in QCoreApplication::notifyInternal (this=0x13f0cc0, receiver=0x1acca70, event=0x1575360) at kernel/qcoreapplication.cpp:732
#50 0x000000327955ef95 in sendEvent (receiver=0x1acca70, event_type=77, data=0x13ab540) at kernel/qcoreapplication.h:215
#51 QCoreApplicationPrivate::sendPostedEvents (receiver=0x1acca70, event_type=77, data=0x13ab540) at kernel/qcoreapplication.cpp:1373
#52 0x000000382c1afaaa in dispatchPendingUpdateRequests (this=0x14038b0) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#53 QGraphicsScenePrivate::_q_processDirtyItems (this=0x14038b0) at graphicsview/qgraphicsscene.cpp:510
#54 0x000000382c1afeba in QGraphicsScene::qt_metacall (this=0x13ffce0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x289ffb0) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#55 0x0000003835b39815 in Plasma::Corona::qt_metacall (this=0x13ffce0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x289ffb0) at /usr/src/debug/kdelibs-4.6.1/x86_64-redhat-linux-gnu/plasma/corona.moc:109
#56 0x0000003ea2038255 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#57 0x000000327956fb4a in QObject::event (this=0x13ffce0, e=<value optimized out>) at kernel/qobject.cpp:1211
#58 0x000000382c1bc5f0 in QGraphicsScene::event (this=0x13ffce0, event=0x242b070) at graphicsview/qgraphicsscene.cpp:3544
#59 0x000000382bbb78c4 in QApplicationPrivate::notify_helper (this=0x1401840, receiver=0x13ffce0, e=0x242b070) at kernel/qapplication.cpp:4445
#60 0x000000382bbbc3da in QApplication::notify (this=<value optimized out>, receiver=0x13ffce0, e=0x242b070) at kernel/qapplication.cpp:4324
#61 0x0000003829c40466 in KApplication::notify (this=0x13f0cc0, receiver=0x13ffce0, event=0x242b070) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#62 0x000000327955b7ac in QCoreApplication::notifyInternal (this=0x13f0cc0, receiver=0x13ffce0, event=0x242b070) at kernel/qcoreapplication.cpp:732
#63 0x000000327955ef95 in sendEvent (receiver=0x0, event_type=0, data=0x13ab540) at kernel/qcoreapplication.h:215
#64 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x13ab540) at kernel/qcoreapplication.cpp:1373
#65 0x0000003279586723 in sendPostedEvents (s=0x14097b0) at kernel/qcoreapplication.h:220
#66 postEventSourceDispatch (s=0x14097b0) at kernel/qeventdispatcher_glib.cpp:277
#67 0x0000003271841e33 in g_main_dispatch (context=0x1408120) at gmain.c:2149
#68 g_main_context_dispatch (context=0x1408120) at gmain.c:2702
#69 0x0000003271842610 in g_main_context_iterate (context=0x1408120, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#70 0x00000032718428ad in g_main_context_iteration (context=0x1408120, may_block=1) at gmain.c:2843
#71 0x00000032795868bf in QEventDispatcherGlib::processEvents (this=0x13aac30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#72 0x000000382bc5c59e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#73 0x000000327955ab42 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#74 0x000000327955ad8c in QEventLoop::exec (this=0x7fff0d645090, flags=...) at kernel/qeventloop.cpp:201
#75 0x000000327955f24b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#76 0x0000003ea203ebd8 in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#77 0x000000326e81ee5d in __libc_start_main (main=0x400990 <_start+256>, argc=1, ubp_av=0x7fff0d645488, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff0d645478) at libc-start.c:226
#78 0x00000000004008b9 in _start ()

This bug may be a duplicate of or related to bug 258706.

Possible duplicates by query: bug 271782, bug 271550, bug 271256, bug 271223, bug 270801.

Reported using DrKonqi
Comment 1 mjb 2011-04-27 16:44:55 UTC
Created attachment 59367 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:

Quitting Amarok prior to a system shutdown; plasma desktop crashes

-- Backtrace (Reduced):
#6  0x00007fd69d55ca7a in QString (this=0x3640075, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:727
#7  KIconEffect::fingerprint (this=0x3640075, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007fd69d5604be in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007fd69d568544 in KIconLoader::loadIcon (this=0x24c6750, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007fd69d55f070 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
Comment 2 Alexander Ponyatikh 2011-04-28 16:38:00 UTC
Created attachment 59395 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

I've just installed Kubuntu 11.04. Started Amarok, it asked to install some plugins, I agreed. After installion I tried to play music, but it didn't work. I quit Amarok (via menu), the windows freezed for 5 second, and at the same moment as it disappeared the Plasma crashed.

-- Backtrace (Reduced):
#6  0x00007fdd2ea885df in QString (this=0x2e40075, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x2e40075, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007fdd2ea8dfeb in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007fdd2ea94d03 in KIconLoader::loadIcon (this=0x20f6060, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007fdd2ea8cc99 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
Comment 3 Aaron J. Seigo 2011-04-30 18:36:39 UTC

*** This bug has been marked as a duplicate of bug 258706 ***