Bug 271550 - Plasma crash (segfault) on quit almost every time
Summary: Plasma crash (segfault) on quit almost every time
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-23 13:05 UTC by Belomir
Modified: 2011-05-03 16:53 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (15.04 KB, text/plain)
2011-04-24 18:30 UTC, sam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Belomir 2011-04-23 13:05:17 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-29-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Clicked on shutdown and waited for countdown for automatic shutdown.
Dureing closeing applications and panels plasma crashed.
Amarok and firefox 4 were opened when shutdown.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Оболочка Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76f8ad0 (LWP 1877))]

Thread 2 (Thread 0xae1ffb70 (LWP 1880)):
#0  0x00cd5416 in __kernel_vsyscall ()
#1  0x001d1df6 in poll () from /lib/libc.so.6
#2  0x04494a1b in g_poll (fds=0xae2020b0, nfds=1, timeout=-1) at /build/buildd/glib2.0-2.26.1/glib/gpoll.c:132
#3  0x0448743c in g_main_context_poll (context=0x9e19680, block=<value optimized out>, dispatch=1, self=0xae202088) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:3093
#4  g_main_context_iterate (context=0x9e19680, block=<value optimized out>, dispatch=1, self=0xae202088) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2775
#5  0x04487848 in g_main_context_iteration (context=0x9e19680, may_block=1) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2843
#6  0x0287b59f in QEventDispatcherGlib::processEvents (this=0x9e19410, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#7  0x0284b609 in QEventLoop::processEvents (this=0xae1ff280, flags=) at kernel/qeventloop.cpp:149
#8  0x0284ba8a in QEventLoop::exec (this=0xae1ff280, flags=...) at kernel/qeventloop.cpp:201
#9  0x02747b7e in QThread::exec (this=0x9e18d10) at thread/qthread.cpp:490
#10 0x0282a35b in QInotifyFileSystemWatcherEngine::run (this=0x9e18d10) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x0274adf9 in QThreadPrivate::start (arg=0x9e18d10) at thread/qthread_unix.cpp:266
#12 0x07f87cc9 in start_thread () from /lib/libpthread.so.0
#13 0x001e069e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb76f8ad0 (LWP 1877)):
[KCrash Handler]
#7  0x010b8ba7 in QString (this=0xac40061, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:727
#8  KIconEffect::fingerprint (this=0xac40061, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0x010bcad8 in KIconLoaderPrivate::makeCacheKey (this=0xac4004d, name=..., group=KIconLoader::Desktop, overlays=..., size=22, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0x010c4f08 in KIconLoader::loadIcon (this=0xac257f0, _name=..., group=KIconLoader::Desktop, size=22, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0x010bb3f6 in KIconEngine::pixmap (this=0xa2dcc38, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x06fe6626 in QIcon::pixmap (this=0xa33c4dc, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0x006f2442 in Plasma::IconWidgetPrivate::decoration (this=0xa33c438, option=0x948b9e8, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#14 0x006f4ed7 in Plasma::IconWidget::paint (this=0x96c07f8, painter=0xbfc9ac4c, option=0x948b9e8, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1128
#15 0x0694619d in SystemTray::DBusSystemTrayWidget::paint (this=0x96c07f8, painter=0xbfc9ac4c, option=0x948b9e8, widget=0x0) at ../../../../../plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#16 0x075eb52c in _q_paintItem (item=<value optimized out>, painter=0xbfc9ac4c, option=0x948b9e8, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4318
#17 0x075edeaa in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x948b9e8, painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4356
#18 0x075f5718 in QGraphicsScenePrivate::drawItemHelper (this=0x948b898, item=0x96c0800, painter=0xbfc9c924, option=0x948b9e8, widget=0x9efcfe8, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4654
#19 0x075f97d8 in QGraphicsScenePrivate::draw (this=0x948b898, item=0x96c0800, painter=0xbfc9c924, viewTransform=0xbfc9c70c, transformPtr=0xbfc9b580, exposedRegion=0x9ef98f0, widget=0x9efcfe8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4895
#20 0x075fa4a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x948b898, item=0x96c0800, painter=0xbfc9c924, viewTransform=0xbfc9c70c, exposedRegion=0x9ef98f0, widget=0x9efcfe8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#21 0x075f9874 in QGraphicsScenePrivate::draw (this=0x948b898, item=0x996f8f8, painter=0xbfc9c924, viewTransform=0xbfc9c70c, transformPtr=0xbfc9b9f0, exposedRegion=0x9ef98f0, widget=0x9efcfe8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#22 0x075fa4a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x948b898, item=0x996f8f8, painter=0xbfc9c924, viewTransform=0xbfc9c70c, exposedRegion=0x9ef98f0, widget=0x9efcfe8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#23 0x075f9874 in QGraphicsScenePrivate::draw (this=0x948b898, item=0x9922470, painter=0xbfc9c924, viewTransform=0xbfc9c70c, transformPtr=0xbfc9be60, exposedRegion=0x9ef98f0, widget=0x9efcfe8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#24 0x075fa4a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x948b898, item=0x9922470, painter=0xbfc9c924, viewTransform=0xbfc9c70c, exposedRegion=0x9ef98f0, widget=0x9efcfe8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#25 0x075f9874 in QGraphicsScenePrivate::draw (this=0x948b898, item=0x984da38, painter=0xbfc9c924, viewTransform=0xbfc9c70c, transformPtr=0xbfc9c2d0, exposedRegion=0x9ef98f0, widget=0x9efcfe8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#26 0x075fa4a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x948b898, item=0x984da38, painter=0xbfc9c924, viewTransform=0xbfc9c70c, exposedRegion=0x9ef98f0, widget=0x9efcfe8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#27 0x075facce in QGraphicsScenePrivate::drawItems (this=0x948b898, painter=0xbfc9c924, viewTransform=0xbfc9c70c, exposedRegion=0x9ef98f0, widget=0x9efcfe8) at graphicsview/qgraphicsscene.cpp:4699
#28 0x07626bb9 in QGraphicsView::paintEvent (this=0x9e8d3c8, event=0xbfc9d044) at graphicsview/qgraphicsview.cpp:3467
#29 0x00ee0904 in PanelView::paintEvent (this=0x9e8d3c8, event=0xbfc9d044) at ../../../../plasma/desktop/shell/panelview.cpp:1593
#30 0x06f7fcc6 in QWidget::event (this=0x9e8d3c8, event=0xbfc9d044) at kernel/qwidget.cpp:8333
#31 0x073a1763 in QFrame::event (this=0x9e8d3c8, e=0xbfc9d044) at widgets/qframe.cpp:557
#32 0x0743ea82 in QAbstractScrollArea::viewportEvent (this=0x107ece65, e=0x0) at widgets/qabstractscrollarea.cpp:1043
#33 0x07622ccb in QGraphicsView::viewportEvent (this=0x9e8d3c8, event=0xbfc9d044) at graphicsview/qgraphicsview.cpp:2862
#34 0x074414d5 in viewportEvent (this=0xa018698, o=0x9efcfe8, e=0xbfc9d044) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0xa018698, o=0x9efcfe8, e=0xbfc9d044) at widgets/qabstractscrollarea_p.h:116
#36 0x0284c29a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9486380, receiver=0x9efcfe8, event=0xbfc9d044) at kernel/qcoreapplication.cpp:847
#37 0x06f21fb9 in QApplicationPrivate::notify_helper (this=0x9486380, receiver=0x9efcfe8, e=0xbfc9d044) at kernel/qapplication.cpp:4392
#38 0x06f280e9 in QApplication::notify (this=0x9474ca8, receiver=0x9efcfe8, e=0xbfc9d044) at kernel/qapplication.cpp:4361
#39 0x0112082a in KApplication::notify (this=0x9474ca8, receiver=0x9efcfe8, event=0xbfc9d044) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x0284cb3b in QCoreApplication::notifyInternal (this=0x9474ca8, receiver=0x9efcfe8, event=0xbfc9d044) at kernel/qcoreapplication.cpp:732
#41 0x06f86ee6 in sendSpontaneousEvent (this=0x9f5ac88, pdev=0x9efd0d4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xa24b210) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x9f5ac88, pdev=0x9efd0d4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xa24b210) at kernel/qwidget.cpp:5420
#43 0x06f87cff in QWidgetPrivate::paintSiblingsRecursive (this=0x9ef95a0, pdev=0x9efd0d4, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa24b210) at kernel/qwidget.cpp:5627
#44 0x06f87b38 in QWidgetPrivate::paintSiblingsRecursive (this=0x9ef95a0, pdev=0x9efd0d4, siblings=..., index=5, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa24b210) at kernel/qwidget.cpp:5614
#45 0x06f87b38 in QWidgetPrivate::paintSiblingsRecursive (this=0x9ef95a0, pdev=0x9efd0d4, siblings=..., index=6, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa24b210) at kernel/qwidget.cpp:5614
#46 0x06f87b38 in QWidgetPrivate::paintSiblingsRecursive (this=0x9ef95a0, pdev=0x9efd0d4, siblings=..., index=7, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa24b210) at kernel/qwidget.cpp:5614
#47 0x06f87b38 in QWidgetPrivate::paintSiblingsRecursive (this=0x9ef95a0, pdev=0x9efd0d4, siblings=..., index=8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa24b210) at kernel/qwidget.cpp:5614
#48 0x06f86c35 in QWidgetPrivate::drawWidget (this=0x9ef95a0, pdev=0x9efd0d4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xa24b210) at kernel/qwidget.cpp:5473
#49 0x07177c74 in QWidgetBackingStore::sync (this=0xa24b210) at painting/qbackingstore.cpp:1328
#50 0x06f792b3 in QWidgetPrivate::syncBackingStore (this=0x9ef95a0) at kernel/qwidget.cpp:1805
#51 0x06f80466 in QWidget::event (this=0x9e8d3c8, event=0xac257f0) at kernel/qwidget.cpp:8480
#52 0x073a1763 in QFrame::event (this=0x9e8d3c8, e=0xac257f0) at widgets/qframe.cpp:557
#53 0x0743f487 in QAbstractScrollArea::event (this=0x9e8d3c8, e=0xac257f0) at widgets/qabstractscrollarea.cpp:996
#54 0x07624ea6 in QGraphicsView::event (this=0x9e8d3c8, event=0xac257f0) at graphicsview/qgraphicsview.cpp:2739
#55 0x00ee3aa3 in PanelView::event (this=0x9e8d3c8, event=0xac257f0) at ../../../../plasma/desktop/shell/panelview.cpp:1604
#56 0x06f21fdc in QApplicationPrivate::notify_helper (this=0x9486380, receiver=0x9e8d3c8, e=0xac257f0) at kernel/qapplication.cpp:4396
#57 0x06f280e9 in QApplication::notify (this=0x9474ca8, receiver=0x9e8d3c8, e=0xac257f0) at kernel/qapplication.cpp:4361
#58 0x0112082a in KApplication::notify (this=0x9474ca8, receiver=0x9e8d3c8, event=0xac257f0) at ../../kdeui/kernel/kapplication.cpp:311
#59 0x0284cb3b in QCoreApplication::notifyInternal (this=0x9474ca8, receiver=0x9e8d3c8, event=0xac257f0) at kernel/qcoreapplication.cpp:732
#60 0x0284fd8b in sendEvent (receiver=0x9e8d3c8, event_type=77, data=0x9443300) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#61 QCoreApplicationPrivate::sendPostedEvents (receiver=0x9e8d3c8, event_type=77, data=0x9443300) at kernel/qcoreapplication.cpp:1373
#62 0x0284ff4d in QCoreApplication::sendPostedEvents (receiver=0x9e8d3c8, event_type=77) at kernel/qcoreapplication.cpp:1266
#63 0x0760ac3e in dispatchPendingUpdateRequests (this=0x948b898) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#64 QGraphicsScenePrivate::_q_processDirtyItems (this=0x948b898) at graphicsview/qgraphicsscene.cpp:510
#65 0x0760b116 in QGraphicsScene::qt_metacall (this=0x9485248, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xa3afa78) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#66 0x0061ea1a in Plasma::Corona::qt_metacall (this=0x9485248, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xa3afa78) at ./corona.moc:109
#67 0x00ecf1ca in DesktopCorona::qt_metacall (this=0x9485248, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xa3afa78) at ./desktopcorona.moc:101
#68 0x028528ca in QMetaObject::metacall (object=0x9485248, cl=276745829, idx=18, argv=0xa3afa78) at kernel/qmetaobject.cpp:237
#69 0x0285ddf6 in QMetaCallEvent::placeMetaCall (this=0x9f70e68, object=0x9485248) at kernel/qobject.cpp:534
#70 0x0285f6a2 in QObject::event (this=0x9485248, e=0x0) at kernel/qobject.cpp:1219
#71 0x07607374 in QGraphicsScene::event (this=0x9485248, event=0x9f70e68) at graphicsview/qgraphicsscene.cpp:3548
#72 0x06f21fdc in QApplicationPrivate::notify_helper (this=0x9486380, receiver=0x9485248, e=0x9f70e68) at kernel/qapplication.cpp:4396
#73 0x06f2804e in QApplication::notify (this=0x9474ca8, receiver=0x9485248, e=0x9f70e68) at kernel/qapplication.cpp:3798
#74 0x0112082a in KApplication::notify (this=0x9474ca8, receiver=0x9485248, event=0x9f70e68) at ../../kdeui/kernel/kapplication.cpp:311
#75 0x0284cb3b in QCoreApplication::notifyInternal (this=0x9474ca8, receiver=0x9485248, event=0x9f70e68) at kernel/qcoreapplication.cpp:732
#76 0x0284fd8b in sendEvent (receiver=0x0, event_type=0, data=0x9443300) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#77 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9443300) at kernel/qcoreapplication.cpp:1373
#78 0x0284ff4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#79 0x0287ba74 in sendPostedEvents (s=0x9488710) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#80 postEventSourceDispatch (s=0x9488710) at kernel/qeventdispatcher_glib.cpp:277
#81 0x04483855 in g_main_dispatch (context=0x9488690) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2149
#82 g_main_context_dispatch (context=0x9488690) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2702
#83 0x04487668 in g_main_context_iterate (context=0x9488690, block=<value optimized out>, dispatch=1, self=0x948f1c0) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2780
#84 0x04487848 in g_main_context_iteration (context=0x9488690, may_block=1) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2843
#85 0x0287b565 in QEventDispatcherGlib::processEvents (this=0x9442fc0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#86 0x06fe3be5 in QGuiEventDispatcherGlib::processEvents (this=0x9442fc0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#87 0x0284b609 in QEventLoop::processEvents (this=0xbfc9ee04, flags=) at kernel/qeventloop.cpp:149
#88 0x0284ba8a in QEventLoop::exec (this=0xbfc9ee04, flags=...) at kernel/qeventloop.cpp:201
#89 0x0285000f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#90 0x06f20e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#91 0x00ed81e7 in kdemain (argc=1, argv=0xbfc9f014) at ../../../../plasma/desktop/shell/main.cpp:118
#92 0x080485bb in main (argc=1, argv=0xbfc9f014) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 269118.

Possible duplicates by query: bug 271256, bug 271223, bug 270801, bug 270780, bug 270352.

Reported using DrKonqi
Comment 1 sam 2011-04-24 18:30:11 UTC
Created attachment 59277 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:

Was playing music with Amarok, stopped and closed Amarok

Plasma desktop crashed.

-- Backtrace (Reduced):
#6  0x00007fbc5bea55df in QString (this=0x30c0075, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x30c0075, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007fbc5beaafeb in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007fbc5beb1d03 in KIconLoader::loadIcon (this=0x31ab870, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007fbc5bea9c99 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
Comment 2 Dario Andres 2011-05-01 14:56:00 UTC
[Comment from a bug report cleaner]
This is likely to be related to a common crash being tracked at bug 258706.
Regards
Comment 3 Christoph Feck 2011-05-03 16:53:55 UTC

*** This bug has been marked as a duplicate of bug 258706 ***