Bug 271254 - kde4init crashes frequently
Summary: kde4init crashes frequently
Status: RESOLVED DUPLICATE of bug 256712
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-19 00:00 UTC by Wonko
Modified: 2011-04-24 18:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wonko 2011-04-19 00:00:37 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.6.2 (4.6.2) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-ck x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
kde4init crashes 1-4 times per day here.  I did not care much about it, because I did not notice any negative impact. I also thought it was related to plasma crashing all the time (see bugs 226596/258706), as both kde4init and plasma-desktop sometimes crashed at the same time. But now that I disabled the system tray, plasma no longer crashes. Still, kde4init does sometimes.

Drkonqui suggests this may be a duplicate of 248004, but the backtrace looks quite different to me, so I filed a new bug. If you like, I can build stuff with debug information.

Not sure if this is related in any way, but sometimes I also have

The crash can be reproduced some of the time.

-- Backtrace:
Application: KDE-Dienst (kdeinit4), signal: Aborted
[Current thread is 1 (Thread 0x7fbb2393c760 (LWP 13123))]

Thread 5 (Thread 0x7fbb0c23e700 (LWP 13131)):
#0  0x00007fbb210296be in __lll_lock_wait_private () from /lib64/libc.so.6
#1  0x00007fbb20fc053a in _L_lock_6626 () from /lib64/libc.so.6
#2  0x00007fbb20fbe941 in free () from /lib64/libc.so.6
#3  0x00007fbb1e042a13 in g_source_unref_internal () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fbb225f2e5a in QEventDispatcherGlib::~QEventDispatcherGlib() () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007fbb225f2fa9 in QEventDispatcherGlib::~QEventDispatcherGlib() () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007fbb224e1e84 in QThreadPrivate::finish(void*) () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007fbb224e2b1d in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#8  0x00007fbb22252d1c in start_thread () from /lib64/libpthread.so.0
#9  0x00007fbb2101c8ad in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fbb0b5ef700 (LWP 13139)):
#0  0x00007fbb210296be in __lll_lock_wait_private () from /lib64/libc.so.6
#1  0x00007fbb20fc053a in _L_lock_6626 () from /lib64/libc.so.6
#2  0x00007fbb20fbe941 in free () from /lib64/libc.so.6
#3  0x00007fbb225f2537 in socketNotifierSourceCheck(_GSource*) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007fbb1e046953 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#5  0x00007fbb1e04721a in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#6  0x00007fbb1e04771d in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#7  0x00007fbb225f2aaf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#8  0x00007fbb225c78a2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#9  0x00007fbb225c7ae4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#10 0x00007fbb224e033c in QThread::exec() () from /usr/lib64/qt4/libQtCore.so.4
#11 0x00007fbb225a99b8 in QInotifyFileSystemWatcherEngine::run() () from /usr/lib64/qt4/libQtCore.so.4
#12 0x00007fbb224e2b15 in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#13 0x00007fbb22252d1c in start_thread () from /lib64/libpthread.so.0
#14 0x00007fbb2101c8ad in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fbb09dd1700 (LWP 13146)):
#0  0x00007fbb0a2545f0 in socket_source_prepare () from /usr/lib64/libgio-2.0.so.0
#1  0x00007fbb0a2546be in socket_source_check () from /usr/lib64/libgio-2.0.so.0
#2  0x00007fbb1e046953 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fbb1e04721a in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fbb1e047ae2 in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#5  0x00007fbb0a2a3054 in gdbus_shared_thread_func () from /usr/lib64/libgio-2.0.so.0
#6  0x00007fbb1e06d946 in g_thread_create_proxy () from /usr/lib64/libglib-2.0.so.0
#7  0x00007fbb22252d1c in start_thread () from /lib64/libpthread.so.0
#8  0x00007fbb2101c8ad in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fbb01bef700 (LWP 14731)):
#0  0x00007fbb210296be in __lll_lock_wait_private () from /lib64/libc.so.6
#1  0x00007fbb20fc053a in _L_lock_6626 () from /lib64/libc.so.6
#2  0x00007fbb20fbe941 in free () from /lib64/libc.so.6
#3  0x00007fbb2100a0d8 in getaddrinfo () from /lib64/libc.so.6
#4  0x00007fbb203c1602 in QHostInfoAgent::fromName(QString const&) () from /usr/lib64/qt4/libQtNetwork.so.4
#5  0x00007fbb203b6d99 in QHostInfo::fromName(QString const&) () from /usr/lib64/qt4/libQtNetwork.so.4
#6  0x00007fbb1bb45d3b in QtConcurrent::StoredFunctorCall1<QHostInfo, QHostInfo (*)(QString const&), QString>::runFunctor() () from /usr/lib64/libkio.so.5
#7  0x00007fbb1bb45ddc in QtConcurrent::RunFunctionTask<QHostInfo>::run() () from /usr/lib64/libkio.so.5
#8  0x00007fbb224d7c1e in QThreadPoolThread::run() () from /usr/lib64/qt4/libQtCore.so.4
#9  0x00007fbb224e2b15 in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#10 0x00007fbb22252d1c in start_thread () from /lib64/libpthread.so.0
#11 0x00007fbb2101c8ad in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fbb2393c760 (LWP 13123)):
[KCrash Handler]
#6  0x00007fbb20f7a495 in raise () from /lib64/libc.so.6
#7  0x00007fbb20f7b73a in abort () from /lib64/libc.so.6
#8  0x00007fbb20fb4882 in __libc_message () from /lib64/libc.so.6
#9  0x00007fbb20fb9bb5 in malloc_printerr () from /lib64/libc.so.6
#10 0x00007fbb20fbe94c in free () from /lib64/libc.so.6
#11 0x00007fbb1ba5ec7d in KIO::AuthInfo::~AuthInfo() () from /usr/lib64/libkio.so.5
#12 0x00007fbafffc93be in KPasswdServer::findAuthInfoItem(QString const&, KIO::AuthInfo const&) () from /usr/lib64/kde4/kded_kpasswdserver.so
#13 0x00007fbafffc9584 in KPasswdServer::checkAuthInfoAsync(KIO::AuthInfo, long long, long long) () from /usr/lib64/kde4/kded_kpasswdserver.so
#14 0x00007fbafffcdd33 in KPasswdServerAdaptor::checkAuthInfoAsync(KIO::AuthInfo, long long, long long) () from /usr/lib64/kde4/kded_kpasswdserver.so
#15 0x00007fbafffce0d3 in KPasswdServerAdaptor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/kde4/kded_kpasswdserver.so
#16 0x00007fbb1f41c2e2 in QDBusConnectionPrivate::deliverCall(QObject*, int, QDBusMessage const&, QList<int> const&, int) () from /usr/lib64/qt4/libQtDBus.so.4
#17 0x00007fbb1f41d43d in QDBusConnectionPrivate::activateCall(QObject*, int, QDBusMessage const&) () from /usr/lib64/qt4/libQtDBus.so.4
#18 0x00007fbb1f41dbce in QDBusConnectionPrivate::activateObject(QDBusConnectionPrivate::ObjectTreeNode&, QDBusMessage const&, int) () from /usr/lib64/qt4/libQtDBus.so.4
#19 0x00007fbb1f41dde8 in QDBusActivateObjectEvent::placeMetaCall(QObject*) () from /usr/lib64/qt4/libQtDBus.so.4
#20 0x00007fbb225dc3a2 in QObject::event(QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#21 0x00007fbb217a1024 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#22 0x00007fbb217a5b0a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#23 0x00007fbb23358d06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#24 0x00007fbb225c8483 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#25 0x00007fbb225cbbcc in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/qt4/libQtCore.so.4
#26 0x00007fbb225f2923 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/qt4/libQtCore.so.4
#27 0x00007fbb1e046cd2 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#28 0x00007fbb1e047480 in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#29 0x00007fbb1e04771d in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#30 0x00007fbb225f2aaf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#31 0x00007fbb218453ee in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtGui.so.4
#32 0x00007fbb225c78a2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#33 0x00007fbb225c7ae4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#34 0x00007fbb225cbe63 in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#35 0x00007fbb13ebaad5 in kdemain () from /usr/lib64/libkdeinit4_kded4.so
#36 0x00000000004075f3 in launch(int, char const*, char const*, char const*, int, char const*, bool, char const*, bool, char const*) ()
#37 0x0000000000409d6e in main ()

Possible duplicates by query: bug 256712, bug 248004, bug 242480.

Reported using DrKonqi
Comment 1 Wonko 2011-04-19 00:17:49 UTC
Argh, didn't want to send this yet, and wait at least until it happens again. I thought I had to press the 'Finish' button in Drkonqui to send the report, but apparently pressing 'Next' was enough. So now the bug is filed, sorry.

What I was about to write is that sometimes I have kded4 and knotify running at 100%, often there are two instances of both processes, which gives four processes eating all CPU time. Not sure if this is in any way related, but I think I always had kde4init crash somewhat earlier before this happens, so I thought I'd mention it. I simply kill them, then all is well for a while.
Comment 2 Christoph Feck 2011-04-24 18:59:26 UTC

*** This bug has been marked as a duplicate of bug 256712 ***