Bug 242480 - Multiple attempt to login a .htaccess protected site
Summary: Multiple attempt to login a .htaccess protected site
Status: RESOLVED DUPLICATE of bug 256712
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-22 14:38 UTC by Unknown
Modified: 2010-11-21 01:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2010-06-22 14:38:32 UTC
Application: kded4 ($Id: kded.cpp 1128583 2010-05-19 17:42:25Z aseigo $)
KDE Platform Version: 4.4.86 (KDE 4.4.86 (KDE 4.5 >= 20100616)) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.31.12-0.2-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I tried to log in to a .htaccess (AuthType Basic) protected site. After the third attempt something has crashed. Meanwhile I varied the AuthName, so it was changed after the first and after the second login.

-- Backtrace:
Application: KDE-szolgáltatás (kdeinit4), signal: Aborted
[KCrash Handler]
#6  0x00007fc208e2b4e5 in raise () from /lib64/libc.so.6
#7  0x00007fc208e2c9b0 in abort () from /lib64/libc.so.6
#8  0x00007fc208e6666d in ?? () from /lib64/libc.so.6
#9  0x00007fc208e6bc76 in ?? () from /lib64/libc.so.6
#10 0x00007fc1fc6b3a6b in ?? () from /usr/lib64/tls/libnvidia-tls.so.1
#11 0x00007fc203febb3d in KIO::AuthInfo::~AuthInfo (this=0xc7b7e0, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.4.86svn1138650/kio/kio/authinfo.cpp:128
#12 0x00007fc1ee097af4 in ~AuthInfoContainer (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.4.86svn1138650/kpasswdserver/kpasswdserver.h:81
#13 KPasswdServer::findAuthInfoItem (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.4.86svn1138650/kpasswdserver/kpasswdserver.cpp:749
#14 0x00007fc1ee09be64 in KPasswdServer::checkAuthInfoAsync (this=0xaee0d0, info=) at /usr/src/debug/kdebase-runtime-4.4.86svn1138650/kpasswdserver/kpasswdserver.cpp:306
#15 0x00007fc1ee09db42 in KPasswdServerAdaptor::checkAuthInfoAsync (this=0xa2a920, info=<value optimized out>, windowId=83886211, usertime=30166802)
    at /usr/src/debug/kdebase-runtime-4.4.86svn1138650/build/kpasswdserver/kpasswdserveradaptor.cpp:57
#16 0x00007fc1ee09de63 in KPasswdServerAdaptor::qt_metacall (this=0xa2a920, _c=<value optimized out>, _id=<value optimized out>, _a=0x7fff9fa11cc0)
    at /usr/src/debug/kdebase-runtime-4.4.86svn1138650/build/kpasswdserver/kpasswdserveradaptor.moc:151
#17 0x00007fc20789722e in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#18 0x00007fc20789804b in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0xa2a920, flags=497, msg=...) at qdbusintegrator.cpp:816
#19 0x00007fc207898acd in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1364
#20 0x00007fc207898d68 in QDBusActivateObjectEvent::placeMetaCall (this=0xa7a3f0) at qdbusintegrator.cpp:1477
#21 0x00007fc20a466489 in QObject::event (this=0xaee0d0, e=0xa7a3f0) at kernel/qobject.cpp:1240
#22 0x00007fc20961d35c in QApplicationPrivate::notify_helper (this=0x68e640, receiver=0xaee0d0, e=0xa7a3f0) at kernel/qapplication.cpp:4302
#23 0x00007fc20962393b in QApplication::notify (this=0x7fff9fa12a30, receiver=0xaee0d0, e=0xa7a3f0) at kernel/qapplication.cpp:4185
#24 0x00007fc20b1a5246 in KApplication::notify (this=0x7fff9fa12a30, receiver=0xaee0d0, event=0xa7a3f0) at /usr/src/debug/kdelibs-4.4.86svn1138650/kdeui/kernel/kapplication.cpp:302
#25 0x00007fc20a45667c in QCoreApplication::notifyInternal (this=0x7fff9fa12a30, receiver=0xaee0d0, event=0xa7a3f0) at kernel/qcoreapplication.cpp:726
#26 0x00007fc20a459d34 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:215
#27 QCoreApplicationPrivate::sendPostedEvents (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.cpp:1367
#28 0x00007fc20a480193 in sendPostedEvents () at kernel/qcoreapplication.h:220
#29 postEventSourceDispatch () at kernel/qeventdispatcher_glib.cpp:276
#30 0x00007fc205fe4dee in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#31 0x00007fc205fe87b8 in ?? () from /usr/lib64/libglib-2.0.so.0
#32 0x00007fc205fe88e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#33 0x00007fc20a47fcd3 in QEventDispatcherGlib::processEvents (this=0x617330, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#34 0x00007fc2096cbb2e in QGuiEventDispatcherGlib::processEvents (this=0xcf2, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007fc20a454f92 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007fc20a45536c in QEventLoop::exec (this=0x7fff9fa12980, flags=) at kernel/qeventloop.cpp:201
#37 0x00007fc20a45a01b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#38 0x00007fc1fb186f27 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdelibs-4.4.86svn1138650/kded/kded.cpp:894
#39 0x0000000000407a18 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40af23 "0") at /usr/src/debug/kdelibs-4.4.86svn1138650/kinit/kinit.cpp:723
#40 0x000000000040995c in main (argc=<value optimized out>, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/debug/kdelibs-4.4.86svn1138650/kinit/kinit.cpp:1835

Reported using DrKonqi
Comment 1 Christoph Feck 2010-06-22 17:39:52 UTC
> #10 0x00007fc1fc6b3a6b in ?? () from /usr/lib64/tls/libnvidia-tls.so.1

If you can reproduce the bug without using NVIDIA binary driver, please reopen with a new backtrace.
Comment 2 Christoph Feck 2010-11-21 01:44:20 UTC

*** This bug has been marked as a duplicate of bug 256712 ***