Bug 271088 - kwin crashes if I choose "i965 gallium" in ems-7.10.2
Summary: kwin crashes if I choose "i965 gallium" in ems-7.10.2
Status: RESOLVED DUPLICATE of bug 255094
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-16 10:25 UTC by Toralf Förster
Modified: 2011-05-06 13:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster 2011-04-16 10:25:24 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.38.3 i686
Distribution (Platform): Gentoo Packages

-- Information about the crash:
I've a ThinkPad T400 with i915 kernel module, with "classic" settings for mesa KDE 4.6.2 works fine. The intel driver is 2.15.0

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb2bd2720 (LWP 25081))]

Thread 2 (Thread 0xaf915b70 (LWP 25088)):
#0  0xb776c424 in __kernel_vsyscall ()
#1  0xb583b045 in pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0xb75b499d in __pthread_cond_wait (cond=0xb6da6290, mutex=0xb6da6278) at forward.c:139
#3  0xb6c9cf97 in ?? () from /usr/lib/qt4/libQtScript.so.4
#4  0xb6c9cfdf in ?? () from /usr/lib/qt4/libQtScript.so.4
#5  0xb58369ae in start_thread (arg=0xaf915b70) at pthread_create.c:297
#6  0xb75a79de in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb2bd2720 (LWP 25081)):
[KCrash Handler]
#7  0xafe244d5 in ?? () from /usr/lib/dri/i965_dri.so
#8  0xafe1fd0c in ?? () from /usr/lib/dri/i965_dri.so
#9  0xafe16807 in ?? () from /usr/lib/dri/i965_dri.so
#10 0xafe169d6 in ?? () from /usr/lib/dri/i965_dri.so
#11 0xafebbb89 in ?? () from /usr/lib/dri/i965_dri.so
#12 0xaff5ba5a in ?? () from /usr/lib/dri/i965_dri.so
#13 0xaff533cf in ?? () from /usr/lib/dri/i965_dri.so
#14 0xaff53418 in ?? () from /usr/lib/dri/i965_dri.so
#15 0xafe96e24 in ?? () from /usr/lib/dri/i965_dri.so
#16 0xafe96ef1 in ?? () from /usr/lib/dri/i965_dri.so
#17 0xb6a927cf in KWin::PaintClipper::Iterator::next (this=0xbf9195b4) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/lib/kwineffects.cpp:905
#18 0xb76fbc17 in KWin::SceneOpenGL::paintBackground (this=0x9720300, region=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/scene_opengl.cpp:929
#19 0xb76ef58f in KWin::Scene::paintSimpleScreen (this=0x9720300, orig_mask=<value optimized out>, region=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/scene.cpp:296
#20 0xb76eb6fa in KWin::Scene::finalPaintScreen (this=0x9720300, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/scene.cpp:180
#21 0xb770f48d in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:173
#22 0xafa1365a in KWin::StartupFeedbackEffect::paintScreen (this=0x9798490, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects/startupfeedback/startupfeedback.cpp:166
#23 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#24 0xb6a92b97 in KWin::Effect::paintScreen (this=0x9758e80, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/lib/kwineffects.cpp:227
#25 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#26 0xaf9a8037 in KWin::LogoutEffect::paintScreen (this=0x97c12e8, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects/logout/logout.cpp:207
#27 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#28 0xaf9cb668 in KWin::ShadowEffect::paintScreen (this=0x9775a08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects/shadow/shadow.cpp:189
#29 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#30 0xaf9ae550 in KWin::PresentWindowsEffect::paintScreen (this=0x9775938, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects/presentwindows/presentwindows.cpp:205
#31 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#32 0xb6a92b97 in KWin::Effect::paintScreen (this=0x97b7040, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/lib/kwineffects.cpp:227
#33 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#34 0xb6a92b97 in KWin::Effect::paintScreen (this=0x9762230, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/lib/kwineffects.cpp:227
#35 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#36 0xb6a92b97 in KWin::Effect::paintScreen (this=0x97926d0, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/lib/kwineffects.cpp:227
#37 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#38 0xb6a92b97 in KWin::Effect::paintScreen (this=0x97651b0, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/lib/kwineffects.cpp:227
#39 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#40 0xaf990a06 in KWin::DesktopGridEffect::paintScreen (this=0x9773218, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects/desktopgrid/desktopgrid.cpp:155
#41 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#42 0xaf9d114a in KWin::SlideEffect::paintScreen (this=0x97589f8, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects/slide/slide.cpp:86
#43 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#44 0xaf9878f0 in KWin::BoxSwitchEffect::paintScreen (this=0x9753138, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects/boxswitch/boxswitch.cpp:143
#45 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#46 0xb6a92b97 in KWin::Effect::paintScreen (this=0x978b880, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/lib/kwineffects.cpp:227
#47 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#48 0xb6a92b97 in KWin::Effect::paintScreen (this=0x9773968, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/lib/kwineffects.cpp:227
#49 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#50 0xb6a92b97 in KWin::Effect::paintScreen (this=0x978e0f0, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/lib/kwineffects.cpp:227
#51 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#52 0xb6a92b97 in KWin::Effect::paintScreen (this=0x9771ca0, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/lib/kwineffects.cpp:227
#53 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#54 0xb6a92b97 in KWin::Effect::paintScreen (this=0x9757ad8, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/lib/kwineffects.cpp:227
#55 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#56 0xaf9dd931 in KWin::ZoomEffect::paintScreen (this=0x97b92a0, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects/zoom/zoom.cpp:341
#57 0xb770f508 in KWin::EffectsHandlerImpl::paintScreen (this=0x9718f08, mask=8, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/effects.cpp:169
#58 0xb76ecf55 in KWin::Scene::paintScreen (this=0x9720300, mask=0xbf91a994, region=0xbf91aa40) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/scene.cpp:137
#59 0xb7703862 in KWin::SceneOpenGL::paint (this=0x9720300, damage=..., toplevels=...) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/scene_opengl.cpp:772
#60 0xb76e7d17 in KWin::Workspace::performCompositing (this=0x9722888) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/composite.cpp:448
#61 0xb59c78bc in QObject::event (this=0x9722888, e=0x1) at kernel/qobject.cpp:1181
#62 0xb5f580a4 in QApplicationPrivate::notify_helper (this=0x9630aa8, receiver=0x9722888, e=0xbf91af8c) at kernel/qapplication.cpp:4462
#63 0xb5f5d85e in QApplication::notify (this=0xbf91b2b4, receiver=0x9722888, e=0xbf91af8c) at kernel/qapplication.cpp:3862
#64 0xb72e777b in KApplication::notify (this=0xbf91b2b4, receiver=0x9722888, event=0xbf91af8c) at /var/tmp/portage/kde-base/kdelibs-4.6.2-r2/work/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:311
#65 0xb7670bf0 in KWin::Application::notify (this=0xbf91b2b4, o=0x9722888, e=0xbf91af8c) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/main.cpp:376
#66 0xb59b4db2 in QCoreApplication::notifyInternal (this=0xbf91b2b4, receiver=0x9722888, event=0xbf91af8c) at kernel/qcoreapplication.cpp:731
#67 0xb59e73cf in sendEvent (this=0x9631230) at kernel/qcoreapplication.h:215
#68 QTimerInfoList::activateTimers (this=0x9631230) at kernel/qeventdispatcher_unix.cpp:604
#69 0xb59e7538 in QEventDispatcherUNIX::processEvents (this=0x9610950, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#70 0xb601a83e in QEventDispatcherX11::processEvents (this=0x9610950, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#71 0xb59b381a in QEventLoop::processEvents (this=0xbf91b1e4, flags=) at kernel/qeventloop.cpp:149
#72 0xb59b3c9a in QEventLoop::exec (this=0xbf91b1e4, flags=...) at kernel/qeventloop.cpp:201
#73 0xb59b82f1 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#74 0xb5f56d68 in QApplication::exec () at kernel/qapplication.cpp:3736
#75 0xb7673a6c in kdemain (argc=3, argv=0xbf91b534) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2/kwin/main.cpp:542
#76 0x080486bb in main (argc=3, argv=0xbf91b534) at /var/tmp/portage/kde-base/kwin-4.6.2/work/kwin-4.6.2_build/kwin/kwin_dummy.cpp:3

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-04-16 23:42:25 UTC
driver bug

*** This bug has been marked as a duplicate of bug 252817 ***
Comment 2 Toralf Förster 2011-04-17 11:46:10 UTC
Well, rather the xorg-server itself.

I switched from xorg-server 1.95 to 1.10.1 and now the issue seems to be fixed.
Comment 3 Toralf Förster 2011-04-17 13:44:46 UTC
(In reply to comment #2)
> Well, rather the xorg-server itself.
> 
> I switched from xorg-server 1.95 to 1.10.1 and now the issue seems to be fixed.
nope - not fixed :-(
Comment 4 Thomas Lübking 2011-04-17 16:56:11 UTC
it's a gallium issue, see the dupe (have no intel chip to test, but believe their findings)
Comment 5 Toralf Förster 2011-04-17 17:31:31 UTC
(In reply to comment #4)
> it's a gallium issue, see the dupe (have no intel chip to test, but believe
> their findings)

Hhm, I'm wondering then why I get this error b/c I set Gentoo to use classic (intel GM45 graphic) :

foerste@n22 ~ $ eselect mesa list
i915 (Intel 915, 945)
  [1]   classic *
  [2]   gallium
i965 (Intel 965, G/Q3x, G/Q4x)
  [1]   classic *
  [2]   gallium
r300 (Radeon R300-R500)
r600 (Radeon R600-R700, Evergreen, Northern Islands)
sw (Software renderer)
  [1]   classic *
  [2]   gallium

Just for the record this error I found in Xorg.log with current environment (xorg 1.10.1, mesa 7.10.2, intel 2.15.0, KDE 4.6.2) :

Backtrace:
[  3251.280] 0: /usr/bin/X (xorg_backtrace+0x3c) [0x80ea36c]
[  3251.280] 1: /usr/bin/X (0x8048000+0x60e71) [0x80a8e71]
[  3251.280] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb788140c]
[  3251.280] 3: /usr/lib/dri/i965_dri.so (0xb6e25000+0x199b6) [0xb6e3e9b6]
[  3251.280] 4: /usr/lib/dri/i965_dri.so (0xb6e25000+0x1c800) [0xb6e41800]
[  3251.280] 5: /usr/lib/dri/i965_dri.so (0xb6e25000+0x1f70c8) [0xb701c0c8]
[  3251.280] 6: /usr/lib/xorg/modules/extensions/libglx.so (0xb7426000+0x838a) [0xb742e38a]
[  3251.280] 7: /usr/lib/xorg/modules/extensions/libglx.so (0xb7426000+0x322a2) [0xb74582a2]
[  3251.280] 8: /usr/lib/xorg/modules/extensions/libglx.so (0xb7426000+0x37b73) [0xb745db73]
[  3251.280] 9: /usr/bin/X (0x8048000+0x2ad27) [0x8072d27]
[  3251.280] 10: /usr/bin/X (0x8048000+0x1d88a) [0x806588a]
[  3251.280] 11: /lib/libc.so.6 (__libc_start_main+0xe6) [0xb759dbb6]
[  3251.280] 12: /usr/bin/X (0x8048000+0x1d441) [0x8065441]
[  3251.280] Segmentation fault at address 0x30
[  3251.280]
Fatal server error:
[  3251.280] Caught signal 11 (Segmentation fault). Server aborting
Comment 6 Thomas Lübking 2011-04-17 17:53:08 UTC
Errrr... the summary and first post state that you tried the gallium driver & got a crash in kwin while the classic driver works fine.

This is however a segfault in X11 (clients should not be able  to segfault X11, therefore it's a pure driver/X11 bug), ie. a completely different issue (though GLX related - basically do never attempt to run two OpenGL clients on the intel driver, so at least suspend compositing before running any other OpenGL application or use the XRender backend)
Comment 7 Toralf Förster 2011-04-17 18:11:11 UTC
(In reply to comment #6)
(though
> GLX related - basically do never attempt to run two OpenGL clients on the intel
> driver, so at least suspend compositing before running any other OpenGL
> application or use the XRender backend)

Right - Thanks - I changed to XRender and the crashes went away :-)

Should I file a bug against freedesktop and/or intel driver ? (And BTW unmark this bug as a duplicate ?)
Comment 8 Thomas Lübking 2011-04-17 18:43:48 UTC
This bug as presented is a dupe of #252817 - if you've other crashes with different backtraces you should file them independently, but i foresee a dupe there as well (and at least upstream, the intel driver has a "history" since they the kms move :-(

I assume the original (dupe) bug is known to freedesktop/intel but you could file or search the bug there to track its progress.
Comment 9 Thomas Lübking 2011-05-06 13:12:48 UTC
wrong dupe... :S
(though very likely same upstream source)

*** This bug has been marked as a duplicate of bug 255094 ***