Bug 255094 - KWin crashed exiting from Flash fullscreen mode
Summary: KWin crashed exiting from Flash fullscreen mode
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 261929 271088 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-24 12:00 UTC by Andrea Diamantini
Modified: 2011-06-18 22:09 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrea Diamantini 2010-10-24 12:00:34 UTC
Application: kwin (4.5.2 (KDE 4.5.2))
KDE Platform Version: 4.5.2 (KDE 4.5.2) (Compiled from sources)
Qt Version: 4.7.0
Operating System: Linux 2.6.36 i686

-- Information about the crash:
- What I was doing when the application crashed:

I was seeing a youtube video fullscreen. Exiting fullscreen mode, the browser window remained black and after a couple of seconds kwin crashed.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0xb0954272 in ?? () from /usr/lib/xorg/modules/dri/i965_dri.so
#7  0xb093a357 in ?? () from /usr/lib/xorg/modules/dri/i965_dri.so
#8  0xb092b398 in ?? () from /usr/lib/xorg/modules/dri/i965_dri.so
#9  0xb0a117ac in ?? () from /usr/lib/xorg/modules/dri/i965_dri.so
#10 0xb0a0ee07 in ?? () from /usr/lib/xorg/modules/dri/i965_dri.so
#11 0xb0a0ee60 in ?? () from /usr/lib/xorg/modules/dri/i965_dri.so
#12 0xb09d71cc in ?? () from /usr/lib/xorg/modules/dri/i965_dri.so
#13 0xb09d72ab in ?? () from /usr/lib/xorg/modules/dri/i965_dri.so
#14 0xb72e6b23 in KWin::PaintClipper::Iterator::next (this=0xbfa4d188) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwineffects.cpp:1001
#15 0xb72ee266 in KWin::renderGLGeometry (region=..., count=4, vertices=0xb4c7b50, texture=0xa791df0, color=0x0, dim=2, stride=0)
    at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwinglutils.cpp:181
#16 0xb76c1340 in KWin::SceneOpenGL::Window::renderQuads (this=0xa251920, region=..., quads=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/scene_opengl.cpp:1649
#17 0xb76c57c9 in KWin::SceneOpenGL::Window::performPaint (this=0xa251920, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/scene_opengl.cpp:1519
#18 0xb76b4899 in KWin::Scene::finalDrawWindow (this=0x9f12500, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/scene.cpp:330
#19 0xb76cc4bc in KWin::EffectsHandlerImpl::drawWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:232
#20 0xb72e04a7 in KWin::Effect::drawWindow (this=0xa29ca38, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwineffects.cpp:252
#21 0xb76cc533 in KWin::EffectsHandlerImpl::drawWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:228
#22 0xb72e04a7 in KWin::Effect::drawWindow (this=0xa267110, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwineffects.cpp:252
#23 0xb76cc533 in KWin::EffectsHandlerImpl::drawWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:228
#24 0xb72e04a7 in KWin::Effect::drawWindow (this=0xa28f490, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwineffects.cpp:252
#25 0xb76cc533 in KWin::EffectsHandlerImpl::drawWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:228
#26 0xb72e04a7 in KWin::Effect::drawWindow (this=0xa2724f8, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwineffects.cpp:252
#27 0xb76cc533 in KWin::EffectsHandlerImpl::drawWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:228
#28 0xb72e04a7 in KWin::Effect::drawWindow (this=0xa282848, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwineffects.cpp:252
#29 0xb76cc533 in KWin::EffectsHandlerImpl::drawWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:228
#30 0xb72e04a7 in KWin::Effect::drawWindow (this=0xa2aa4f8, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwineffects.cpp:252
#31 0xb76cc533 in KWin::EffectsHandlerImpl::drawWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:228
#32 0xb72e04a7 in KWin::Effect::drawWindow (this=0xa2ac760, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwineffects.cpp:252
#33 0xb76cc533 in KWin::EffectsHandlerImpl::drawWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:228
#34 0xb72e04a7 in KWin::Effect::drawWindow (this=0xa2985f8, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwineffects.cpp:252
#35 0xb76cc533 in KWin::EffectsHandlerImpl::drawWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:228
#36 0xb76b4109 in KWin::Scene::finalPaintWindow (this=0x9f12500, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/scene.cpp:321
#37 0xb76cc602 in KWin::EffectsHandlerImpl::paintWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:203
#38 0xafe83e21 in KWin::LogoutEffect::paintWindow (this=0xa29ca38, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects/logout/logout.cpp:198
#39 0xb76cc679 in KWin::EffectsHandlerImpl::paintWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:199
#40 0xafe8a96c in KWin::PresentWindowsEffect::paintWindow (this=0xa267108, w=0x9dd16f0, mask=9, region=..., data=...)
    at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects/presentwindows/presentwindows.cpp:370
#41 0xb76cc679 in KWin::EffectsHandlerImpl::paintWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:199
#42 0xafe7a391 in KWin::DialogParentEffect::paintWindow (this=0xa28f490, w=0x9dd16f0, mask=9, region=..., data=...)
    at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects/dialogparent/dialogparent.cpp:70
#43 0xb76cc679 in KWin::EffectsHandlerImpl::paintWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:199
#44 0xafe7dd65 in KWin::FadeEffect::paintWindow (this=0xa2724f8, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects/fade/fade.cpp:160
#45 0xb76cc679 in KWin::EffectsHandlerImpl::paintWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:199
#46 0xafea9b6d in KWin::SlidingPopupsEffect::paintWindow (this=0xa282848, w=0x9dd16f0, mask=9, region=..., data=...)
    at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects/slidingpopups/slidingpopups.cpp:127
#47 0xb76cc679 in KWin::EffectsHandlerImpl::paintWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:199
#48 0xafec56a9 in KWin::CubeSlideEffect::paintWindow (this=0xa2aa4f8, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects/cube/cubeslide.cpp:412
#49 0xb76cc679 in KWin::EffectsHandlerImpl::paintWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:199
#50 0xafeb144a in KWin::CoverSwitchEffect::paintWindow (this=0xa2ac760, w=0x9dd16f0, mask=9, region=..., data=...)
    at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects/coverswitch/coverswitch.cpp:500
#51 0xb76cc679 in KWin::EffectsHandlerImpl::paintWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:199
#52 0xafe7b6a7 in KWin::DimScreenEffect::paintWindow (this=0xa2985f8, w=0x9dd16f0, mask=9, region=..., data=...)
    at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects/dimscreen/dimscreen.cpp:88
#53 0xb76cc679 in KWin::EffectsHandlerImpl::paintWindow (this=0xa23e418, w=0x9dd16f0, mask=9, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:199
#54 0xb76b4a9a in KWin::Scene::paintWindow (this=0x9f12500, w=0xa251920, mask=9, region=..., quads=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/scene.cpp:315
#55 0xb76b5ec3 in KWin::Scene::paintSimpleScreen (this=0x9f12500, orig_mask=8, region=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/scene.cpp:286
#56 0xb76b4041 in KWin::Scene::finalPaintScreen (this=0x9f12500, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/scene.cpp:179
#57 0xb76cc79c in KWin::EffectsHandlerImpl::paintScreen (this=0xa23e418, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:172
#58 0xafe8416c in KWin::LogoutEffect::paintScreen (this=0xa29ca38, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects/logout/logout.cpp:207
#59 0xb76cc80b in KWin::EffectsHandlerImpl::paintScreen (this=0xa23e418, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:168
#60 0xafe88ccb in KWin::PresentWindowsEffect::paintScreen (this=0xa267108, mask=8, region=..., data=...)
    at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects/presentwindows/presentwindows.cpp:196
#61 0xb76cc80b in KWin::EffectsHandlerImpl::paintScreen (this=0xa23e418, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:168
#62 0xb72e056f in KWin::Effect::paintScreen (this=0xa28f490, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwineffects.cpp:227
#63 0xb76cc80b in KWin::EffectsHandlerImpl::paintScreen (this=0xa23e418, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:168
#64 0xb72e056f in KWin::Effect::paintScreen (this=0xa2724f8, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwineffects.cpp:227
#65 0xb76cc80b in KWin::EffectsHandlerImpl::paintScreen (this=0xa23e418, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:168
#66 0xb72e056f in KWin::Effect::paintScreen (this=0xa282848, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwineffects.cpp:227
#67 0xb76cc80b in KWin::EffectsHandlerImpl::paintScreen (this=0xa23e418, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:168
#68 0xafec5424 in KWin::CubeSlideEffect::paintScreen (this=0xa2aa4f8, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects/cube/cubeslide.cpp:111
#69 0xb76cc80b in KWin::EffectsHandlerImpl::paintScreen (this=0xa23e418, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:168
#70 0xafeb4997 in KWin::CoverSwitchEffect::paintScreen (this=0xa2ac760, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects/coverswitch/coverswitch.cpp:124
#71 0xb76cc80b in KWin::EffectsHandlerImpl::paintScreen (this=0xa23e418, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:168
#72 0xb72e056f in KWin::Effect::paintScreen (this=0xa2985f8, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/lib/kwineffects.cpp:227
#73 0xb76cc80b in KWin::EffectsHandlerImpl::paintScreen (this=0xa23e418, mask=8, region=..., data=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/effects.cpp:168
#74 0xb76b5214 in KWin::Scene::paintScreen (this=0x9f12500, mask=0xbfa4ef8c, region=0xbfa4f054) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/scene.cpp:137
#75 0xb76c60b9 in KWin::SceneOpenGL::paint (this=0x9f12500, damage=..., toplevels=...) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/scene_opengl.cpp:748
#76 0xb76b13e0 in KWin::Workspace::performCompositing (this=0xb0c39410) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/composite.cpp:454
#77 0xb762d313 in KWin::Workspace::qt_metacall (this=0xb0c39410, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa4f17c)
    at /tmp/build-kdebase_workspace/build/kwin/workspace.moc:583
#78 0xb68bf8e7 in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /opt/qt/lib/libQtCore.so.4
#79 0xb68d1a91 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /opt/qt/lib/libQtCore.so.4
#80 0xb691e298 in QTimer::timeout() () from /opt/qt/lib/libQtCore.so.4
#81 0xb68d709d in QTimer::timerEvent(QTimerEvent*) () from /opt/qt/lib/libQtCore.so.4
#82 0xb68cb19d in QObject::event(QEvent*) () from /opt/qt/lib/libQtCore.so.4
#83 0xb5d86c17 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /opt/qt/lib/libQtGui.so.4
#84 0xb5d8d579 in QApplication::notify(QObject*, QEvent*) () from /opt/qt/lib/libQtGui.so.4
#85 0xb6e7fe1a in KApplication::notify (this=0xbfa4f9b4, receiver=0xb0c396c0, event=0xbfa4f6c0) at /tmp/build-kdelibs/kdelibs/kdeui/kernel/kapplication.cpp:310
#86 0xb76475dc in KWin::Application::notify (this=0xbfa4f9b4, o=0xb0c396c0, e=0xbfa4f6c0) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/main.cpp:372
#87 0xb68ba1e1 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /opt/qt/lib/libQtCore.so.4
#88 0xb68e8e2c in ?? () from /opt/qt/lib/libQtCore.so.4
#89 0xb68e8f75 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/qt/lib/libQtCore.so.4
#90 0xb5e3e50c in ?? () from /opt/qt/lib/libQtGui.so.4
#91 0xb68b8f4a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/qt/lib/libQtCore.so.4
#92 0xb68b9344 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/qt/lib/libQtCore.so.4
#93 0xb68bd38a in QCoreApplication::exec() () from /opt/qt/lib/libQtCore.so.4
#94 0xb5d86caf in QApplication::exec() () from /opt/qt/lib/libQtGui.so.4
#95 0xb7649d81 in kdemain (argc=1, argv=0xbfa4fc14) at /tmp/build-kdebase_workspace/kdebase_workspace/kwin/main.cpp:531
#96 0x0804874a in main (argc=1, argv=0xbfa4fc14) at /tmp/build-kdebase_workspace/build/kwin/kwin_dummy.cpp:3

Reported using DrKonqi
Comment 1 Martin Flöser 2010-10-24 14:52:10 UTC
Sorry, driver bug.
Comment 2 Thomas Lübking 2011-01-03 16:10:15 UTC
*** Bug 261929 has been marked as a duplicate of this bug. ***
Comment 3 Thomas Lübking 2011-05-06 13:10:42 UTC
from bug #261929
i wonder whether is segfaults on invalid width/height (ie. GL_INVALID return) -
it's  nevertheless a driver bug.
Comment 4 Thomas Lübking 2011-05-06 13:12:48 UTC
*** Bug 271088 has been marked as a duplicate of this bug. ***
Comment 5 Manfred Kitzbichler 2011-06-18 21:59:55 UTC
It pains me to see that this extremely annoying bug has been marked as RESOLVED. 

It definitely isn't resolved and it isn't at all clear that this is a driver issue. Looking at the comments on the Ubuntu forum below, a possible but unsatisfactory cure it to disable the "Suspend desktop effects for fullscreen windows" setting in KDE. Also people report no problems using compiz instead of Kwin. These pieces of evidence point at a bug in Kwin rather than the display driver.

http://ubuntuforums.org/showthread.php?t=1748294

KDE 4.6.4
Kernel 2.6.39
Xorg X11R7.6 (1.9.3)
Comment 6 Martin Flöser 2011-06-18 22:09:02 UTC
For more info see duplicate bug report.
>Also people report no problems using compiz instead of
> Kwin.

What a surprise given that Compiz does not use unredirect fullscreen windows by default, but KWin does. A real surprise that they don't have that crash, but it's of course an unsatisfactory cure to disable the option in KWin.

*** This bug has been marked as a duplicate of bug 252817 ***