Bug 271039 - Plasma crashed when I tried to open network Manager.
Summary: Plasma crashed when I tried to open network Manager.
Status: RESOLVED DUPLICATE of bug 266097
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-15 16:19 UTC by Henrik Gyllensvärd
Modified: 2011-04-16 01:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik Gyllensvärd 2011-04-15 16:19:42 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
I simply tried to open my network manager. My panel lies on the right side of the scren.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb1b7ba30 (LWP 1702))]

Thread 2 (Thread 0xa80bcb70 (LWP 1706)):
#0  0xb3a8de36 in clock_gettime (clock_id=-1280761868, tp=0xa80bbed0) at ../sysdeps/unix/clock_gettime.c:100
#1  0xb665050b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0xb67276e5 in QTimerInfoList::updateCurrentTime (this=0x9842db4) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb672772a in QTimerInfoList::timerWait (this=0x9842db4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb67257a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xa80bbffc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb672583d in timerSourcePrepare (source=0x0, timeout=0xb3a91ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb39fbe6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb39fc279 in ?? () from /lib/libglib-2.0.so.0
#9  0xb39fc848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb672559f in QEventDispatcherGlib::processEvents (this=0x98425e0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0xb66f5609 in QEventLoop::processEvents (this=0xa80bc1d0, flags=) at kernel/qeventloop.cpp:149
#12 0xb66f5a8a in QEventLoop::exec (this=0xa80bc1d0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb65f1b7e in QThread::exec (this=0x9842158) at thread/qthread.cpp:490
#14 0xb66d435b in QInotifyFileSystemWatcherEngine::run (this=0x9842158) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb65f4df9 in QThreadPrivate::start (arg=0x9842158) at thread/qthread_unix.cpp:266
#16 0xb3f9dba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 1 (Thread 0xb1b7ba30 (LWP 1702)):
[KCrash Handler]
#7  0xb670f0e2 in QObject::disconnect (sender=0x97ca7a8, signal=0x0, receiver=0x937dc20, method=0xaa003732 "2hasDefaultRouteChanged(bool)") at kernel/qobject.cpp:2749
#8  0xa9ff309d in disconnect (this=0x97ca7a8) at /usr/include/qt4/QtCore/qobject.h:229
#9  InterfaceItem::currentConnectionChanged (this=0x97ca7a8) at ../../applet/interfaceitem.cpp:311
#10 0xa9ff3a6b in InterfaceItem::connectionStateChanged (this=0x97ca7a8, state=Solid::Control::NetworkInterface::Disconnected) at ../../applet/interfaceitem.cpp:426
#11 0xa9ff272b in InterfaceItem::handleConnectionStateChange (this=0x97ca7a8, new_state=3, old_state=8, reason=38) at ../../applet/interfaceitem.cpp:358
#12 0xa9fe7339 in InterfaceItem::qt_metacall (this=0x97ca7a8, _c=QMetaObject::InvokeMetaMethod, _id=48, _a=0xbfce0790) at moc_interfaceitem.cpp:120
#13 0xb66fc8ca in QMetaObject::metacall (object=0x97ca7a8, cl=2852155380, idx=48, argv=0xbfce0790) at kernel/qmetaobject.cpp:237
#14 0xb670f6ad in QMetaObject::activate (sender=0x9457238, m=0xaa15f62c, local_signal_index=3, argv=0x0) at kernel/qobject.cpp:3280
#15 0xaa142b7f in Solid::Control::NetworkInterface::connectionStateChanged (this=0x9457238, _t1=3, _t2=8, _t3=38) at ./networkinterface.moc:157
#16 0xaa142cfb in Solid::Control::NetworkInterface::qt_metacall (this=0x9457238, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfce0900) at ./networkinterface.moc:125
#17 0xaa14598a in Solid::Control::WiredNetworkInterface::qt_metacall (this=0x9457238, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfce0900) at ./wirednetworkinterface.moc:74
#18 0xb66fc8ca in QMetaObject::metacall (object=0x9457238, cl=2852155380, idx=7, argv=0xbfce0900) at kernel/qmetaobject.cpp:237
#19 0xb670f6ad in QMetaObject::activate (sender=0x941ff00, m=0xa9f5eaf4, local_signal_index=2, argv=0x0) at kernel/qobject.cpp:3280
#20 0xa9f4bc7f in NMNetworkInterface::connectionStateChanged (this=0x941ff00, _t1=3, _t2=8, _t3=38) at ./networkinterface.moc:183
#21 0xa9f4bbe1 in NMNetworkInterface::stateChanged (this=0x941ff00, new_state=3, old_state=8, reason=38) at ../../../solid/networkmanager-0.7/networkinterface.cpp:247
#22 0xa9f4cd80 in NMNetworkInterface::qt_metacall (this=0x941ff00, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbfce0b20) at ./networkinterface.moc:120
#23 0xa9f5003a in NMWiredNetworkInterface::qt_metacall (this=0x941ff00, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfce0b20) at ./wirednetworkinterface.moc:87
#24 0xb66fc8ca in QMetaObject::metacall (object=0x941ff00, cl=2852155380, idx=7, argv=0xbfce0b20) at kernel/qmetaobject.cpp:237
#25 0xb670f6ad in QMetaObject::activate (sender=0x95d4358, m=0xa9f5fae4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#26 0xa9f5672f in OrgFreedesktopNetworkManagerDeviceInterface::StateChanged (this=0x95d4358, _t1=3, _t2=8, _t3=38) at ./nm-deviceinterface.moc:134
#27 0xa9f567b4 in OrgFreedesktopNetworkManagerDeviceInterface::qt_metacall (this=0x95d4358, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfce0d2c) at ./nm-deviceinterface.moc:90
#28 0xb684b9dc in QDBusConnectionPrivate::deliverCall (this=0x9034848, object=0x95d4358, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:919
#29 0xb68571f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0xa32ac80, object=0x95d4358) at qdbusintegrator_p.h:103
#30 0xb67096a2 in QObject::event (this=0x95d4358, e=0x937dc20) at kernel/qobject.cpp:1219
#31 0xb5bdbfdc in QApplicationPrivate::notify_helper (this=0x8f77420, receiver=0x95d4358, e=0xa32ac80) at kernel/qapplication.cpp:4396
#32 0xb5be204e in QApplication::notify (this=0x8f6b438, receiver=0x95d4358, e=0xa32ac80) at kernel/qapplication.cpp:3798
#33 0xb6d0568a in KApplication::notify (this=0x8f6b438, receiver=0x95d4358, event=0xa32ac80) at ../../kdeui/kernel/kapplication.cpp:310
#34 0xb66f6b3b in QCoreApplication::notifyInternal (this=0x8f6b438, receiver=0x95d4358, event=0xa32ac80) at kernel/qcoreapplication.cpp:732
#35 0xb66f9d8b in sendEvent (receiver=0x0, event_type=0, data=0x8f17028) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8f17028) at kernel/qcoreapplication.cpp:1373
#37 0xb66f9f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#38 0xb6725a74 in sendPostedEvents (s=0x8f79728) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#39 postEventSourceDispatch (s=0x8f79728) at kernel/qeventdispatcher_glib.cpp:277
#40 0xb39f8855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#41 0xb39fc668 in ?? () from /lib/libglib-2.0.so.0
#42 0xb39fc848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#43 0xb6725565 in QEventDispatcherGlib::processEvents (this=0x8f16ce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#44 0xb5c9dbe5 in QGuiEventDispatcherGlib::processEvents (this=0x8f16ce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0xb66f5609 in QEventLoop::processEvents (this=0xbfce1554, flags=) at kernel/qeventloop.cpp:149
#46 0xb66f5a8a in QEventLoop::exec (this=0xbfce1554, flags=...) at kernel/qeventloop.cpp:201
#47 0xb66fa00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#48 0xb5bdae07 in QApplication::exec () at kernel/qapplication.cpp:3672
#49 0xb77a786e in kdemain (argc=1, argv=0xbfce1764) at ../../../../plasma/desktop/shell/main.cpp:118
#50 0x080485bb in main (argc=1, argv=0xbfce1764) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 271034, bug 270316, bug 269733, bug 268863, bug 268862.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-04-16 01:39:28 UTC

*** This bug has been marked as a duplicate of bug 266097 ***