Bug 271028 - KDM resets few system settings to default after using it
Summary: KDM resets few system settings to default after using it
Status: RESOLVED DUPLICATE of bug 264200
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_kdm (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdm bugs tracker
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-15 14:33 UTC by Stefan T.
Modified: 2011-10-08 16:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan T. 2011-04-15 14:33:59 UTC
Version:           unspecified (using KDE 4.6.2) 
OS:                Linux

KDM resets few system settings to default values after using it. I am not sure that you can reproduce this bug if you haven't changed this settings on your system: Fonts and Main Toolbar text.

Fonts:
1. Go to System Settings/Application Appearance/Fonts
2. Click on Adjust All Fonts.
3. Default Fonts on my system are Ubuntu fonts (Kubuntu 11.04 b2). Change it to something else, for example DejaVu Sans.
4. Go to KDM (System Settings/Login Screen/Theme) and change something (install new theme).
5. After that Fonts are again Ubuntu fonts (default value) and not DejaVu Sans as expected.

Main Toolbar text:
1. Default settings

http://img860.imageshack.us/i/mainttoolbarsettingsdef.jpg/

2. My settings

http://img40.imageshack.us/i/mainttoolbarsettingsmys.jpg/

3. After KDM

http://img35.imageshack.us/i/mainttoolbarsettingsset.jpg/


So as you can see "Main toolbar text" has changed from "No text" to "Text beside icons", and all this happens when you use KDM which has another bug (when you install new theme, new theme doesn't appear on list).

Reproducible: Didn't try
Comment 1 avlas 2011-04-16 15:56:16 UTC
I also have this problem, it's very annoying, but after looking at this https://bugs.kde.org/show_bug.cgi?id=264200, I think it's surely related to downstream packaging in kubuntu. Somebody should confirm this and then we would report a bug in launchpad.
Comment 2 Stefan T. 2011-04-18 22:14:11 UTC
I don't know. I will report it in Launchpad as soon as possible (tomorrow probably)... since there is no response to this bug here...
Comment 3 avlas 2011-04-18 22:44:50 UTC
when ready, could you please attach here the link to the bug in launchpad? I would like to make them note that there is more people suffering it...
thanks!
Comment 4 Stefan T. 2011-04-20 15:46:57 UTC
Here is report on Launchpad
Comment 5 Oswald Buddenhagen 2011-05-15 17:23:44 UTC

*** This bug has been marked as a duplicate of bug 264200 ***
Comment 6 Jean-Philippe Fleury 2011-10-08 16:34:17 UTC
Report on Launchpad is https://bugs.launchpad.net/ubuntu/+source/kdebase/+bug/766145