Bug 268173 - kded crashed while kpackagekit updated packages
Summary: kded crashed while kpackagekit updated packages
Status: RESOLVED DUPLICATE of bug 182372
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kded (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-11 00:04 UTC by S. Burmeister
Modified: 2011-11-25 20:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2011-03-11 00:04:41 UTC
Application: kded4 ($Id: kded.cpp 1204125 2010-12-06 11:17:10Z dfaure $)
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.2
Operating System: Linux 2.6.37.1-1.2-default i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed: Not sure whether it was a coincidince but kded crashed while kpackagekit was updating packages.

-- Backtrace:
Application: KDE-Dienst (kdeinit4), signal: Aborted
[Current thread is 1 (Thread 0xb5809710 (LWP 2068))]

Thread 5 (Thread 0xad622b70 (LWP 2087)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb603d03e in poll () from /lib/libc.so.6
#2  0xb5a830bb in g_poll () from /lib/libglib-2.0.so.0
#3  0xb5a72c46 in ?? () from /lib/libglib-2.0.so.0
#4  0xb5a72fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb6e35fc7 in QEventDispatcherGlib::processEvents (this=0x81f15a0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6e06a6d in QEventLoop::processEvents (this=0xad6222b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6e06c99 in QEventLoop::exec (this=0xad6222b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6d07d49 in QThread::exec (this=0x81ed100) at thread/qthread.cpp:492
#9  0xb6de67fd in QInotifyFileSystemWatcherEngine::run (this=0x81ed100) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6d0a993 in QThreadPrivate::start (arg=0x81ed100) at thread/qthread_unix.cpp:320
#11 0xb6c8db05 in start_thread () from /lib/libpthread.so.0
#12 0xb6047d5e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xaccffb70 (LWP 2128)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6055e53 in __lll_lock_wait_private () from /lib/libc.so.6
#2  0xb5fe82fb in _L_lock_10372 () from /lib/libc.so.6
#3  0xb5fe6a66 in free () from /lib/libc.so.6
#4  0xb5a795e6 in g_free () from /lib/libglib-2.0.so.0
#5  0xb5a6e939 in ?? () from /lib/libglib-2.0.so.0
#6  0xb6e36448 in QEventDispatcherGlib::~QEventDispatcherGlib (this=0x8202288, __in_chrg=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:373
#7  0xb6e36582 in QEventDispatcherGlib::~QEventDispatcherGlib (this=0x8202288, __in_chrg=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:401
#8  0xb6d09b9c in QThreadPrivate::finish (arg=0xb6f438b0) at thread/qthread_unix.cpp:356
#9  0xb6d0a99b in ~__pthread_cleanup_class (arg=0xb6f438b0) at /usr/include/pthread.h:535
#10 QThreadPrivate::start (arg=0xb6f438b0) at thread/qthread_unix.cpp:279
#11 0xb6c8db05 in start_thread () from /lib/libpthread.so.0
#12 0xb6047d5e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xade23b70 (LWP 16680)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb603d03e in poll () from /lib/libc.so.6
#2  0xb5a830bb in g_poll () from /lib/libglib-2.0.so.0
#3  0xb5a72c46 in ?? () from /lib/libglib-2.0.so.0
#4  0xb5a72fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb6e35fc7 in QEventDispatcherGlib::processEvents (this=0x8206ab8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6e06a6d in QEventLoop::processEvents (this=0xade232c0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6e06c99 in QEventLoop::exec (this=0xade232c0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6d07d49 in QThread::exec (this=0x81fbbf8) at thread/qthread.cpp:492
#9  0xafe85ef7 in ?? () from /usr/lib/kde4/kded_bluedevil.so
#10 0xb6d0a993 in QThreadPrivate::start (arg=0x81fbbf8) at thread/qthread_unix.cpp:320
#11 0xb6c8db05 in start_thread () from /lib/libpthread.so.0
#12 0xb6047d5e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa80cbb70 (LWP 30164)):
#0  0xb6c92f03 in pthread_getspecific () from /lib/libpthread.so.0
#1  0xb6d0aab4 in get_thread_data () at thread/qthread_unix.cpp:161
#2  QThreadData::current () at thread/qthread_unix.cpp:199
#3  0xb6e35a47 in postEventSourcePrepare (s=0x81f6500, timeout=0x0) at kernel/qeventdispatcher_glib.cpp:254
#4  0xb6e35ac7 in postEventSourceCheck (source=0x81f6500) at kernel/qeventdispatcher_glib.cpp:270
#5  0xb5a72180 in g_main_context_check () from /lib/libglib-2.0.so.0
#6  0xb5a72ac8 in ?? () from /lib/libglib-2.0.so.0
#7  0xb5a72fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#8  0xb6e35fc7 in QEventDispatcherGlib::processEvents (this=0x83a7f90, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#9  0xb6e06a6d in QEventLoop::processEvents (this=0xa80cb2c0, flags=...) at kernel/qeventloop.cpp:149
#10 0xb6e06c99 in QEventLoop::exec (this=0xa80cb2c0, flags=...) at kernel/qeventloop.cpp:201
#11 0xb6d07d49 in QThread::exec (this=0x8164e88) at thread/qthread.cpp:492
#12 0xafe85ef7 in ?? () from /usr/lib/kde4/kded_bluedevil.so
#13 0xb6d0a993 in QThreadPrivate::start (arg=0x8164e88) at thread/qthread_unix.cpp:320
#14 0xb6c8db05 in start_thread () from /lib/libpthread.so.0
#15 0xb6047d5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5809710 (LWP 2068)):
[KCrash Handler]
#7  0xffffe430 in __kernel_vsyscall ()
#8  0xb5f9f8df in raise () from /lib/libc.so.6
#9  0xb5fa1220 in abort () from /lib/libc.so.6
#10 0xb5fdbe07 in __libc_message () from /lib/libc.so.6
#11 0xb5fe1e2b in malloc_printerr () from /lib/libc.so.6
#12 0xb5fe2bab in _int_free () from /lib/libc.so.6
#13 0xb5fe6a6d in free () from /lib/libc.so.6
#14 0xb6d045db in qFree (ptr=0x8317c20) at global/qmalloc.cpp:60
#15 0xb6d39e17 in QMapData::node_delete (this=0x8140c68, update=0xbfc11360, offset=68, node=0x8317c64) at tools/qmap.cpp:170
#16 0xb7152724 in QMap<QString, KDirWatchPrivate::Entry>::remove (this=0x8140380, akey=...) at /usr/include/QtCore/qmap.h:681
#17 0xb708a89d in KDirWatchPrivate::removeEntry (this=0x8140360, instance=0x82d38d8, e=0x8317c24, sub_entry=0x0) at /usr/src/debug/kdelibs-4.6.0/kdecore/io/kdirwatch.cpp:1030
#18 0xb708aac2 in KDirWatchPrivate::removeEntry (this=0x8140360, instance=0x82d38d8, _path=..., sub_entry=0x0) at /usr/src/debug/kdelibs-4.6.0/kdecore/io/kdirwatch.cpp:984
#19 0xb708ade6 in KDirWatchPrivate::removeEntries (this=0x8140360, instance=0x82d38d8) at /usr/src/debug/kdelibs-4.6.0/kdecore/io/kdirwatch.cpp:1061
#20 0xb708af24 in KDirWatch::~KDirWatch (this=0x82d38d8, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kdecore/io/kdirwatch.cpp:1748
#21 0xb708af82 in KDirWatch::~KDirWatch (this=0x82d38d8, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kdecore/io/kdirwatch.cpp:1755
#22 0xb5426992 in Kded::updateDirWatch (this=0x80e16e8) at /usr/src/debug/kdelibs-4.6.0/kded/kded.cpp:478
#23 0xb542b290 in Kded::recreate (this=0x80e16e8, initial=false) at /usr/src/debug/kdelibs-4.6.0/kded/kded.cpp:539
#24 0xb542b327 in Kded::recreate (this=0x80e16e8) at /usr/src/debug/kdelibs-4.6.0/kded/kded.cpp:521
#25 0xb542b41c in Kded::qt_metacall (this=0x80e16e8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfc1168c) at /usr/src/debug/kdelibs-4.6.0/build/kded/kded.moc:88
#26 0xb6e0e07d in QMetaObject::metacall (object=0x80e16e8, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0xbfc1168c) at kernel/qmetaobject.cpp:237
#27 0xb6e1d4cc in QMetaObject::activate (sender=0x80bd7a8, m=0xb6f425a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#28 0xb6e6d6a5 in QTimer::timeout (this=0x80bd7a8) at .moc/release-shared/moc_qtimer.cpp:134
#29 0xb6e24856 in QTimer::timerEvent (this=0x80bd7a8, e=0xbfc11bcc) at kernel/qtimer.cpp:271
#30 0xb6e1cc04 in QObject::event (this=0x80bd7a8, e=0xbfc11bcc) at kernel/qobject.cpp:1181
#31 0xb630f684 in QApplicationPrivate::notify_helper (this=0x80e21f0, receiver=0x80bd7a8, e=0xbfc11bcc) at kernel/qapplication.cpp:4462
#32 0xb6318427 in QApplication::notify (this=0xbfc11f10, receiver=0x80bd7a8, e=0xbfc11bcc) at kernel/qapplication.cpp:3862
#33 0xb7462221 in KApplication::notify (this=0xbfc11f10, receiver=0x80bd7a8, event=0xbfc11bcc) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#34 0xb6e0778e in QCoreApplication::notifyInternal (this=0xbfc11f10, receiver=0x80bd7a8, event=0xbfc11bcc) at kernel/qcoreapplication.cpp:731
#35 0xb6e38b89 in sendEvent (this=0x80e4ccc) at kernel/qcoreapplication.h:215
#36 QTimerInfoList::activateTimers (this=0x80e4ccc) at kernel/qeventdispatcher_unix.cpp:619
#37 0xb6e35885 in timerSourceDispatch (source=0x80e49f8) at kernel/qeventdispatcher_glib.cpp:184
#38 idleTimerSourceDispatch (source=0x80e49f8) at kernel/qeventdispatcher_glib.cpp:231
#39 0xb5a72509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#40 0xb5a72d10 in ?? () from /lib/libglib-2.0.so.0
#41 0xb5a72fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#42 0xb6e35f7b in QEventDispatcherGlib::processEvents (this=0x80b69d0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#43 0xb63c61da in QGuiEventDispatcherGlib::processEvents (this=0x80b69d0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#44 0xb6e06a6d in QEventLoop::processEvents (this=0xbfc11e74, flags=...) at kernel/qeventloop.cpp:149
#45 0xb6e06c99 in QEventLoop::exec (this=0xbfc11e74, flags=...) at kernel/qeventloop.cpp:201
#46 0xb6e0b740 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#47 0xb630d3d4 in QApplication::exec () at kernel/qapplication.cpp:3736
#48 0xb542843d in kdemain (argc=1, argv=0x809e8f8) at /usr/src/debug/kdelibs-4.6.0/kded/kded.cpp:925
#49 0x0804e531 in launch (argc=1, _name=0x805275c "kded4", args=<value optimized out>, cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x80525e3 "0") at /usr/src/debug/kdelibs-4.6.0/kinit/kinit.cpp:730
#50 0x08050f44 in main (argc=) at /usr/src/debug/kdelibs-4.6.0/kinit/kinit.cpp:1845

Reported using DrKonqi
Comment 1 Asen Lekov 2011-11-24 17:32:00 UTC
Duplicate of bug 198396
Comment 2 Myriam Schweingruber 2011-11-25 20:03:01 UTC
(In reply to comment #1)
> Duplicate of bug 198396

No, check the kdelibs components involved.

*** This bug has been marked as a duplicate of bug 182372 ***