Bug 270768 - Picture in black and white mode is displaying normally.
Summary: Picture in black and white mode is displaying normally.
Status: VERIFIED FIXED
Alias: None
Product: calligrastage
Classification: Unclassified
Component: filter/ppt (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Matus Uzak
URL:
Keywords:
: 270767 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-12 14:54 UTC by swathi
Modified: 2011-05-04 16:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Test data in MS Powerpoint 2003 (41.50 KB, application/vnd.ms-powerpoint)
2011-04-12 14:55 UTC, swathi
Details
Screenshot in MS Powerpoint (33.75 KB, image/x-png)
2011-04-12 14:55 UTC, swathi
Details
Screenshot in Calligra Stage (33.56 KB, image/x-png)
2011-04-12 14:56 UTC, swathi
Details
Test data in MS Powerpoint 2000 (40.00 KB, application/vnd.ms-powerpoint)
2011-04-12 14:58 UTC, swathi
Details
MS Powerpoint 2003 file with picture in gray scale mode (101.50 KB, application/vnd.ms-powerpoint)
2011-04-12 15:02 UTC, swathi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description swathi 2011-04-12 14:54:21 UTC
Version: git text-layoutrestructure-boemann branch
         (Using KDE 4.5.5)                
     OS: Kubuntu 10.10

Test data is in MS PowerPoint 2003 format which has picture in
Black and White mode in the 2nd slide.
Open the same document in calligra stage and check the display of picture.

Expected outcome:
Picture should be displayed in Black and White mode.

Actual outcome:
Picture is displaying normally.
Please check the screenshots attached,
	
Frequency:
Always.
Comment 1 swathi 2011-04-12 14:55:17 UTC
Created attachment 58840 [details]
Test data in MS Powerpoint 2003
Comment 2 swathi 2011-04-12 14:55:53 UTC
Created attachment 58841 [details]
Screenshot in MS Powerpoint
Comment 3 swathi 2011-04-12 14:56:46 UTC
Created attachment 58842 [details]
Screenshot in Calligra Stage
Comment 4 swathi 2011-04-12 14:58:32 UTC
Created attachment 58843 [details]
Test data in MS Powerpoint 2000

Similar issue is observed for the MS Powerpoint 2000 file also.
Comment 5 swathi 2011-04-12 15:02:14 UTC
Created attachment 58844 [details]
MS Powerpoint 2003 file with picture in gray scale mode

Picture in gray scale mode is also displaying normally.
Attaching that test data also.
Comment 6 swathi 2011-04-12 15:32:30 UTC
*** Bug 270767 has been marked as a duplicate of this bug. ***
Comment 7 Matus Uzak 2011-05-02 20:35:01 UTC
Git commit b037c47b66a68c3e0f977a773f8a5bcf4f559b1f by Matus Uzak.
Committed on 02/05/2011 at 20:44.
Pushed by uzak into branch 'master'.

libmso: Added support for pictures in BW/Greyscale modes.

BUG:270768

M  +7    -2    filters/libmso/ODrawToOdf.cpp     

http://commits.kde.org/calligra/b037c47b66a68c3e0f977a773f8a5bcf4f559b1f
Comment 8 swathi 2011-05-04 16:19:21 UTC
Verified in df1a8d36dcc689caecf341f3d4dfd9632cadaaf9.