Bug 270617 - Only way to restore original version of a translated tweet is restarting Choqok
Summary: Only way to restore original version of a translated tweet is restarting Choqok
Status: RESOLVED FIXED
Alias: None
Product: choqok
Classification: Unclassified
Component: general (show other bugs)
Version: 1.1
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: 1.2
Assignee: Mehrdad Momeny
URL:
Keywords:
: 274986 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-10 20:41 UTC by stefanauss
Modified: 2011-06-05 18:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stefanauss 2011-04-10 20:41:17 UTC
Version:           1.1 (using KDE 4.6.2) 
OS:                Linux

When an update is translated with the new translator plugin, there is no way to restore the original version.
The translation is showed until the next restart.

Reproducible: Always

Steps to Reproduce:
Right click > Translate to > Select desired language.

Actual Results:  
The message is translated, but it's not possible to show the original message again.

Expected Results:  
"Right click > Translate to >" menu should show an option to restore the original, untranslated message.

This is desirable because:
1. Often the translation is poor.
2. If someone click on the wrong language, he might not be able to get a meaningful message again unless the app is restarted.
Comment 1 Mehrdad Momeny 2011-06-02 09:50:56 UTC
Git commit 71f8dd450b192d3ff8d26e2e6eecaed9d607f0e9 by Mehrdad Momeny.
Committed on 02/06/2011 at 09:49.
Pushed by momeny into branch 'master'.

FEATURE:270617 a hyperlink (original post) added when a post is translated, So, User can restore post to original one!

M  +8    -1    libchoqok/ui/postwidget.cpp     
M  +3    -2    plugins/translator/translator.cpp     

http://commits.kde.org/choqok/71f8dd450b192d3ff8d26e2e6eecaed9d607f0e9
Comment 2 Mehrdad Momeny 2011-06-05 18:58:25 UTC
*** Bug 274986 has been marked as a duplicate of this bug. ***