Bug 270477 - package icon
Summary: package icon
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-09 05:45 UTC by Fábio Abreu
Modified: 2011-04-09 14:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fábio Abreu 2011-04-09 05:45:01 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:the icon of the update package comes quickly several times per day in plasma, thought it might be related to some system failure, and when I clicked on the icon, opened the bug report. wish that this could be corrected.

-- Backtrace:
Application: Espaço de trabalho do Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77ca720 (LWP 1722))]

Thread 2 (Thread 0xae9b9b70 (LWP 1724)):
#0  0x05c3f93f in g_main_context_check () from /lib/libglib-2.0.so.0
#1  0x05c4045e in ?? () from /lib/libglib-2.0.so.0
#2  0x05c40848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x076ab59f in QEventDispatcherGlib::processEvents (this=0x89fb420, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#4  0x0767b609 in QEventLoop::processEvents (this=0xae9b9280, flags=) at kernel/qeventloop.cpp:149
#5  0x0767ba8a in QEventLoop::exec (this=0xae9b9280, flags=...) at kernel/qeventloop.cpp:201
#6  0x07577b7e in QThread::exec (this=0x89f9258) at thread/qthread.cpp:490
#7  0x0765a35b in QInotifyFileSystemWatcherEngine::run (this=0x89f9258) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x0757adf9 in QThreadPrivate::start (arg=0x89f9258) at thread/qthread_unix.cpp:266
#9  0x00453cc9 in start_thread () from /lib/libpthread.so.0
#10 0x00a9f69e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb77ca720 (LWP 1722)):
[KCrash Handler]
#7  0x030a53aa in KJob::isAutoDelete (this=0x908a888) at ../../kdecore/jobs/kjob.cpp:353
#8  0x007d15a7 in Plasma::ServiceJob::setResult (this=0x908a888, result=...) at ../../plasma/servicejob.cpp:80
#9  0x03fe3d6d in StatusNotifierItemJob::contextMenuReady (this=0x908a888, menu=0x941b900) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#10 0x03fe3ded in StatusNotifierItemJob::qt_metacall (this=0x908a888, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbfe74158) at ./statusnotifieritemjob.moc:75
#11 0x076828ca in QMetaObject::metacall (object=0x908a888, cl=125503928, idx=27, argv=0xbfe74158) at kernel/qmetaobject.cpp:237
#12 0x076956ad in QMetaObject::activate (sender=0x8f39930, m=0x3feac40, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#13 0x03fdd0a3 in StatusNotifierItemSource::contextMenuReady (this=0x8f39930, _t1=0x941b900) at ./statusnotifieritemsource.moc:109
#14 0x03fdd2b1 in StatusNotifierItemSource::contextMenuReady (this=0x8f39930) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:369
#15 0x03fe2803 in StatusNotifierItemSource::qt_metacall (this=0x8f39930, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbfe7427c) at ./statusnotifieritemsource.moc:90
#16 0x076828ca in QMetaObject::metacall (object=0x8f39930, cl=125503928, idx=11, argv=0xbfe7427c) at kernel/qmetaobject.cpp:237
#17 0x076956ad in QMetaObject::activate (sender=0x8f10830, m=0x6e27d84, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#18 0x06e12567 in DBusMenuImporter::menuUpdated() () from /usr/lib/libdbusmenu-qt.so.2
#19 0x06e17cdc in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#20 0x06e18f2b in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#21 0x076828ca in QMetaObject::metacall (object=0x8f10830, cl=125503928, idx=12, argv=0xbfe744bc) at kernel/qmetaobject.cpp:237
#22 0x076956ad in QMetaObject::activate (sender=0x941b900, m=0x1d5dfe8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#23 0x0189cee7 in QMenu::aboutToShow (this=0x941b900) at .moc/release-shared/moc_qmenu.cpp:151
#24 0x018a4193 in QMenu::qt_metacall (this=0x941b900, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfe7460c) at .moc/release-shared/moc_qmenu.cpp:97
#25 0x076828ca in QMetaObject::metacall (object=0x941b900, cl=125503928, idx=27, argv=0xbfe7460c) at kernel/qmetaobject.cpp:237
#26 0x07686352 in QMetaMethod::invoke (this=0xbfe7479c, object=0x941b900, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#27 0x07687a1f in QMetaObject::invokeMethod (obj=0x941b900, member=0x6e1e3e1 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#28 0x06e1293e in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#29 0x03fde6ef in StatusNotifierItemSource::contextMenu (this=0x8f39930, x=1240, y=751) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#30 0x03fe533e in StatusNotifierItemJob::start (this=0x908a888) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#31 0x007d1423 in Plasma::ServiceJobPrivate::slotStart (this=0x919c680) at ../../plasma/servicejob.cpp:37
#32 0x007d14f4 in Plasma::ServiceJob::qt_metacall (this=0x908a888, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x95afe28) at ./servicejob.moc:72
#33 0x03fe3dca in StatusNotifierItemJob::qt_metacall (this=0x908a888, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x95afe28) at ./statusnotifieritemjob.moc:70
#34 0x076828ca in QMetaObject::metacall (object=0x908a888, cl=125503928, idx=26, argv=0x95afe28) at kernel/qmetaobject.cpp:237
#35 0x0768ddf6 in QMetaCallEvent::placeMetaCall (this=0x9588fb8, object=0x908a888) at kernel/qobject.cpp:534
#36 0x0768f6a2 in QObject::event (this=0x908a888, e=0x8886d58) at kernel/qobject.cpp:1219
#37 0x013d8fdc in QApplicationPrivate::notify_helper (this=0x8541a60, receiver=0x908a888, e=0x9588fb8) at kernel/qapplication.cpp:4396
#38 0x013df04e in QApplication::notify (this=0x8536570, receiver=0x908a888, e=0x9588fb8) at kernel/qapplication.cpp:3798
#39 0x010ce68a in KApplication::notify (this=0x8536570, receiver=0x908a888, event=0x9588fb8) at ../../kdeui/kernel/kapplication.cpp:310
#40 0x0767cb3b in QCoreApplication::notifyInternal (this=0x8536570, receiver=0x908a888, event=0x9588fb8) at kernel/qcoreapplication.cpp:732
#41 0x0767fd8b in sendEvent (receiver=0x0, event_type=0, data=0x8520010) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8520010) at kernel/qcoreapplication.cpp:1373
#43 0x0767ff4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#44 0x076aba74 in sendPostedEvents (s=0x8543580) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x8543580) at kernel/qeventdispatcher_glib.cpp:277
#46 0x05c3c855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#47 0x05c40668 in ?? () from /lib/libglib-2.0.so.0
#48 0x05c40848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#49 0x076ab565 in QEventDispatcherGlib::processEvents (this=0x851fcd0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#50 0x0149abe5 in QGuiEventDispatcherGlib::processEvents (this=0x851fcd0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x0767b609 in QEventLoop::processEvents (this=0xbfe75574, flags=) at kernel/qeventloop.cpp:149
#52 0x0767ba8a in QEventLoop::exec (this=0xbfe75574, flags=...) at kernel/qeventloop.cpp:201
#53 0x0768000f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#54 0x013d7e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#55 0x00e5186e in kdemain (argc=1, argv=0xbfe75784) at ../../../../plasma/desktop/shell/main.cpp:118
#56 0x080485bb in main (argc=1, argv=0xbfe75784) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 241562.

Possible duplicates by query: bug 269350, bug 268033, bug 266605, bug 265668, bug 265352.

Reported using DrKonqi
Comment 1 Dario Andres 2011-04-09 14:03:49 UTC
Fixed already in KDE SC 4.6. Check the duplicates: bug 241562. Thanks!

*** This bug has been marked as a duplicate of bug 241562 ***